Вход | Регистрация


1С:Предприятие ::

Метки: 

Замер производительности, нужна помощь с уменьшением потерь времени.

Я
   dante_reg45
 
21.03.18 - 21:42
Доброго времени суток, форумчане. Недавно обновил Розницу с версии 2.1 на 2.2, в результате чего появилась заметная задержка в работе. Провел замер производительности на старой версии базы и на новой, дабы сравнить результат.
В качестве примера, взял одну процедуру и сделал замеры на ней:
Первый вопрос. На рознице 2.1 время выполнения процедуры 0,13с, на рознице 2.2 та же самая процедура выполняется 0,29с. Чем может быть вызвано такое замедление работы процедуры? Все бы ничего, но замедление проявляется не на одной это процедуре и в результате существенно замедляется работы 1С Розницы в целом.
Второй вопрос. В замере производительности 1 процедуры, время выполнения всех строк в сумме 0,000169с, а общее время выполнения процедуры показывает 0.28с, куда еще может уходить время при выполнении?
P.S. База запускается в тонком клиенте файловый вариант.
 
  Рекламное место пустует
   Fram
 
1 - 21.03.18 - 23:00
а в общем какой процесс замедлилися? потому что 0.29с это точно не проблема
   Fram
 
2 - 21.03.18 - 23:05
платформу за одно не обновлял?
   Cyberhawk
 
3 - 21.03.18 - 23:06
"куда еще может уходить время при выполнении" // Например, на запрос дин. списка. В замере ты этого времени не увидишь
   Cyberhawk
 
4 - 21.03.18 - 23:07
Но автор, сдается мне, платформу и/или режим совместимости поменял
   dante_reg45
 
5 - 22.03.18 - 00:18
1. Все замеры проводились на одной версии платформы 8.3.10.2650
2. В общем замедлились все процессы, т.е. нет какой то направленности на чтение/запись или работу с оборудование. Например, один из замеров я делал на открытие формы наличной оплаты в интерфейсе РМК. В процессе открытия формы выполняется процедура:
&НаСервере
Функция ПолучитьМаксимальнуюСкидку()
    МаксСкидка=0;
    Для каждого стрДок из Объект.Товары цикл
        Если стрДок.ПроцентАвтоматическойСкидки > МаксСкидка Тогда
            МаксСкидка = Окр(стрДок.ПроцентАвтоматическойСкидки);    
        КонецЕсли;
    КонецЦикла;
    Возврат(МаксСкидка);
КонецФункции

В рознице 2.1 эта процедура выполняется 0.13с, в рознице 2.2 - 0.29с. Эта процедура всего лишь одна из многих, которые идентичны в обеих версих Розницы, но при этом в Рознице 2.2 выполняются дольше, а в совокупности замедление хоть и незначительное работы всех этих процедур выливается в 1-3с замедления операций открытия форм, записи документов и т.п.
База изначально работа в комплектации Розница 2.1 на платформе 8.3.10.2650, потом просто было проведено обновление Розницы до версии 2.2, никаких дополнительных действий с базой или с конфигурацией не производилось.
   МимохожийОднако
 
6 - 22.03.18 - 08:02
Для начала поставь 8.3.10.2699
   Cyberhawk
 
7 - 22.03.18 - 09:16
"поставь 8.3.10.2699" // и удивись антикряку )
   TormozIT
 
8 - 22.03.18 - 23:24
(7) Антикряк появился в 8.3.11.2900
   Fram
 
9 - 22.03.18 - 23:26
(8) что за антикряк? где почитать можно?
   Cyberhawk
 
10 - 23.03.18 - 01:47
(8) Нет, он появился начиная с 8.3.10.хх99 и 8.3.11.хх99
 
  Рекламное место пустует
   Cyberhawk
 
11 - 23.03.18 - 01:48
   TormozIT
 
12 - 23.03.18 - 06:51
(10) Про 8.3.10 упустил из вида. Спасибо.
   Fram
 
13 - 23.03.18 - 07:06
(11) серверная часть тоже?
   cons74
 
14 - 23.03.18 - 10:09
ТС, куда-то не туда копаешь.
Если код функции действительно 100% идентичен, и никаких вычислений нет, и "Объект.Товары" содержит одно количество строк - то остается: выполнение на разных процессорах на разных компах. Еще посмотри режим совместимости в 2.1 и 2.2 - может изменился (вряд-ли дело в этом, но кто знает).
И лучше бы проверить на какой-то другой функции.
   dante_reg45
 
15 - 24.03.18 - 09:09
Господа, проблему нашел, может кому поможет. Замедление выполнения процедур было связано с использованием расширений конфигурации. Хотя вынесенный в расширение код и не был связан с продажами, почему то это отражалось на выполнении. Может быть кто нибудь сталкивался с ними и знает как пофиксить? Все таки хотелось бы оставить возможность вносить изменения в код без вмешательства в конфигурацию.
   ildary
 
16 - 24.03.18 - 10:32
(15) расскажите подробнее - что за расширение: к каким объектам привязано, что делает.
   Фрэнки
 
17 - 24.03.18 - 10:36
да уж, все эти расширения - штучка та еще. Без рассказа о том, что в это Расширение занесено и каким способом, ничего нельзя придумать
   ildary
 
18 - 24.03.18 - 11:58
(17) навскидку - одно дело, когда расширение относится к форме какого-нибудь малоиспользуемого справочника, другое дело - если в расширении перехвачен общий модуль, вызываемый из каждого второго объекта.
   vcv
 
19 - 24.03.18 - 15:30
Может у вас что-то типа ошибки SW1199262 "В клиент-серверном варианте информационной базы при одновременном запуске нескольких клиентских сеансов с одинаковым набором расширений конфигурации наблюдается избыточная нагрузка на процессор и увеличенный расход оперативной памяти."?
Эта исправлена в 8.3.10.2753
   cons74
 
20 - 26.03.18 - 08:38
(15) как на расширение вышел? Т.е. как понял что причина в нем?
   ildary
 
21 - 26.03.18 - 09:45
(20) наверное отключил его и повторно замерил скорость.
   Cyberhawk
 
22 - 26.03.18 - 11:14
(21) Такой сценарий кстати еще не позволяет говорить, что дело было в расширении
   Вафель
 
23 - 26.03.18 - 11:20
получается что сал медленнее работать механизм платформенной сериализации форм



Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует