Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

СКД . программно управлять выводом группировки можно?

СКД . программно управлять выводом группировки можно?
Я
   palpetrovich
 
21.03.18 - 13:16
вывод в таблицу, строки: Товар, Партия 
Можно как-то управлять выводом Партии в зависимости от флага на форме?

Или нужно 2 варианта делать, с парией и без?
 
 
   Малыш Джон
 
1 - 21.03.18 - 13:18
(0) можно, но тебя проклянут

делай 2 варианта
   palpetrovich
 
2 - 21.03.18 - 13:21
(1) а че проклянут ?
переход  с 7-ки, пользователи привыкли к "крыжикам" :)

пробовал так, но "ВыбранныеПоля" - не те беру по-ходу ... если они вообще доступны для управления

Процедура УстановитьПоля(ВыбранныеПоля, МассивПолей, ВыбИспользование)
    Для Каждого ВыбранноеПоле Из ВыбранныеПоля Цикл
        Если МассивПолей.Найти(Строка(ВыбранноеПоле.Поле)) <> Неопределено Тогда
            //ВыбранноеПоле.Использование = ВыбИспользование;

        КонецЕсли;            
    КонецЦикла;
КонецПроцедуры
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    ВыводитьПартии = Настройки.ПараметрыДанных.Элементы.Найти("ВыводитьПартии").Значение;
    //ВыбранныеПоля = Настройки.Выбор.Элементы;

    //ВыбранныеПоля = Настройки.Выбор.ДоступныеПоляВыбора.Элементы;

    ВыбранныеПоля = Настройки.ДоступныеПоляГруппировок.Элементы;
    МассивПолей = Новый Массив;
    МассивПолей.Добавить("Партия");
    УстановитьПоля(ВыбранныеПоля, МассивПолей, ВыводитьПартии);    
КонецПроцедуры
   Жан Пердежон
 
3 - 21.03.18 - 13:47
Добавь группировку в пользовательские настройки
   palpetrovich
 
4 - 21.03.18 - 14:04
(3) наверное, не заню как, программмно?

собственно что мне надо, можно сделать в "Изменить  вариант отчета" - просто поставитв/убрав галку "Партии" в структуре отчета

но пользователям хочется управлять с флага на форме
   Жан Пердежон
 
5 - 21.03.18 - 14:23
(4) зачем программно? в любой типовой уже давно есть основная форма отчета, которая вытягивает пользовательские настройки быстрого доступа на форму и управляет ими;
Тебе остается только настроить макет СКД
   Жан Пердежон
 
6 - 21.03.18 - 14:23
   palpetrovich
 
7 - 21.03.18 - 14:31
(6) ЦарЬ!!!!
спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует