Вход | Регистрация


Обмен через каталог обмена УТ10 и БП3

Обмен через каталог обмена УТ10 и БП3
Я
   Гений 1С
 
20.03.18 - 14:48
Забавно, друзья мои.

Если в БП3 грузит филец из УТ10, то правила обмена в файле игнорятся, а берутся правила из CorrespondentExchangeRules.xml.

Это как называется?

Ну ладно, как называется, можете не говорить.

Это как-то лечится? Приходится поддерживать одни и те же правила в двух базах.

COM на стороне УТ не предлагать, базы физически разделены.
 
 
   Гений 1С
 
1 - 20.03.18 - 16:26
Короче, поставил в БП затычку:

В обработке "КонвертацияОбъектовИнформационныхБаз"

Такой код:

    //Осипов 20180320 +++

    //ВАЖНО! Для узлов обмена с УТ10 правила всегда берем из файла, а не из сохраненных правил...

    Если Метаданные.НайтиПоТипу(ТипЗнч(УзелОбменаЗагрузкаДанныхОбъект)) = Метаданные.ПланыОбмена.ОбменУправлениеТорговлей103БухгалтерияПредприятия30 Тогда
        ТаблицаПравилКонвертации.Очистить();
    КонецЕсли;
    //Осипов 20180320 ---

    
    
    Если ТаблицаПравилКонвертации.Количество() = 0 Тогда
        ЗагрузитьПравилаОбмена(ФайлОбмена, "ЧтениеXML");
        Если ФлагОшибки() Тогда
            ВызватьИсключение НСтр("ru = 'При загрузке правил обмена данными возникли ошибки.'");
        КонецЕсли;
    Иначе
        одПропустить(ФайлОбмена);
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует