Вход | Регистрация

1С:Предприятие ::

Метки: 

Не работает обмен УПП <=> ЗУП 3

Я
   1CIlya
 
19.03.18 - 17:32
Здравствуйте, друзья!

Работаю над обменом УПП <=> ЗУП 3. При получении данных из УПП в ЗУП 3 получил следующую ошибку:

Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(15598)}: Ошибка формата сообщения обмена.
            ВызватьИсключение НСтр("ru = 'Ошибка формата сообщения обмена.'");

Что было сделано на стороне ЗУП 3:
1. Создал план обмена НТХ_ОбменУПП_ЗУП3;
Состав: спр.СпособыОтраженияЗарплатыВБухУчете, регсв.СоответствияОбъектовИнформационныхБаз. Авторегистрация - запретить для всех;
2. Добавил запись в процедуру в ОбменДаннымиПереопределяемый\ПолучитьПланыОбмена;
3. В модуль менеджера плана обмена добавил процедуру:

Процедура ПриПолученииНастроек(Настройки) Экспорт    
    Настройки.ИмяКонфигурацииИсточника = Метаданные.Имя;    
КонецПроцедуры

4. К плану обмена добавил 3 макета: ПравилаРегистрации, ПравилаОбмена, ПравилаОбменаКорреспондента, вставил в них правила из конвертации данных;
5. Сделал свой модуль НТХ_ОбменДаннымиСобытия и 2 подписки на спр.СпособыОтраженияЗарплатыВБухУчете:
Процедура НТХ_ОбменЗУП3_УППРегистрацияПередЗаписью(Источник, Отказ) Экспорт    ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписью("НТХ_ОбменУПП_ЗУП3", Источник, Отказ);
КонецПроцедуры

Процедура НТХ_ОбменЗУП3_УППРегистрацияУдаленияПередУдалением(Источник, Отказ) Экспорт    ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередУдалением("НТХ_ОбменУПП_ЗУП3", Источник, Отказ);
КонецПроцедуры

6. Добавил новый план обмена к типу параметра команды у списка общих команд:  ЗагрузитьКомплектПравил, ЗагрузитьПравилаКонвертацииОбъектов, ЗагрузитьПравилаРегистрацииОбъектов, НастроитьПараметрыТранспортаСообщенийОбмена, ПолучитьНастройкиСинхронизацииДляДругойПрограммы, Синхронизировать, СинхронизироватьСДополнительнымиПараметрами, СобытияОтправки, СобытияПолучения, СоставОтправляемыхДанных, СценарииСинхронизации, УдалитьНастройкуСинхронизации;
7. Запустил обработку ОбновлениеВспомогательныхДанных.epf.

В режиме предприятия создаю новую синхронизацию данных с подключением через сетевой каталог, правила загрузились из макетов, выгрузка из ЗУП 3 в УПП прошла нормально, объектов в файле нет, так и задумано.

Что было сделано на стороне УПП:
1. Создал план обмена НТХ_ОбменУПП_ЗУП3;
Состав: спр.СпособыОтраженияЗарплатыВБухУчете, регсв.СоответствияОбъектовИнформационныхБаз. Авторегистрация - запретить для всех;

В режиме предприятия создаю новый узел обмена, загружаю правила конвертации, с помощью монитора обмена данными регистрирую 1 объект на выгрузку. Выполнил обмен загрузка из ЗУП 3 в УПП прошла нормально, Выгрузка из УПП в ЗУП прошла нормально, выгружен 1 объект. Посмотрел на него в .xml, нормальный красивый такое нпп=1 с дочерними узлами.

Перехожу в ЗУП 3 нажимаю Синхронизировать - данные не получены, ошибка описана выше.

Первый раз настраиваю обмен с 8.3. Все делал согласно ИТС - описание библиотеки стандартных подсистем, если что-то напутал, прошу указать.

Т.е. повторюсь, посмотрел глазками на содержимое файла обмена, нормальное такое содержимое, а он на ошибку формата ругается.
 
  Рекламное место пустует
   1CIlya
 
1 - 19.03.18 - 17:54
Посмотрел под отладчиком, ЗУП 3 вызывает исключение на узле ДанныеПоФоновомуОбмену, хотя в УПП поле Фоновый обмен стоит не использовать, в xml узел ДанныеПоФоновомуОбмену попадает.
   1CIlya
 
2 - 23.03.18 - 11:43
Если кто столкнется с подобной проблемой - решение в использовании не обмена данными в УПП, а синхронизации данных. УПП нужно запустить под тонким клиентом и сходить в Администрирование \ Синхронизация данных. Сам обмен настраивается согласно методическим указаниям ИТС (https://its.1c.ru/db/bsp245doc#content:45:1).
   ИС-2
 
3 - 23.03.18 - 11:46
свои правила или типовые ?
   1CIlya
 
4 - 23.03.18 - 11:47
свои, справочники и кадровые документы.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует