Вход | Регистрация



Заполнение текстового поля

Заполнение текстового поля
Я
   Anton26
 
19.03.18 - 13:32
Доброе время суток, есть 1с 8.3.10 УТ 11
в ней есть форма где есть текстовое поле грузоотправитель которое выбирается из контрагентов подскажите как в конфигурации реализовать автозаполнение данного поля, то есть грузоотправитель всегда один как  присвоить определенного контрагента к данному полю.
 
 
   Anton26
 
1 - 19.03.18 - 13:32
при открытии данной формы после заполнялось автоматически
   Cyberhawk
 
2 - 19.03.18 - 13:41
Оставляй пустым, все тлен
   Anton26
 
3 - 19.03.18 - 19:49
и тишина
   mistеr
 
4 - 19.03.18 - 21:30
(0) Грузоотправитель = Справочники.Контрагенты.НайтиПоКоду("...");

С тебя 150 р.
   Anton26
 
5 - 23.03.18 - 00:02
пытаюсь найти и вставить в текстовое поле и по наименованию и по коду но при открытии документа текстовое поле все ровно пустое и не каких ошибок не выдает
&НаСервере
Процедура ПеревозчикПриИзмененииНаСервере()
    // Вставить содержимое обработчика.

    Перевозчик1 = Справочники.Контрагенты.НайтиПоНаименованию ("1232").ПолучитьОбъект();
    Если Не ЗначениеЗаполнено(Перевозчик1) Тогда Сообщить("Не найден документ!"); Возврат; 
    КонецЕсли;
    Перевозчик1.Записать();
    
КонецПроцедуры
   Fram
 
6 - 23.03.18 - 00:09
(5) как вот это "пытаюсь найти и вставить в текстовое поле и по наименованию и по коду но при открытии документа текстовое поле все ровно пустое и не каких ошибок не выдает "
связано с приведенным кодом можешь объяснить ?
   hhhh
 
7 - 23.03.18 - 07:03
(5) Перевозчик1 = Справочники.Контрагенты.НайтиПоНаименованию ("1232").ПолучитьОбъект();

что за хрень? Зачем ПолучитьОБъект()  ??

и почему не найден документ?
   Anton26
 
8 - 23.03.18 - 07:05
изначально получитьобъект не было я просто экспериментировал. текстовое поле все ровно остается пустым
   Anton26
 
9 - 23.03.18 - 07:24
Если у кого есть пример что нужно писать на сервере и на клиенте что бы текстовое поле заполнилось то прошу скинуть сюда
   Fram
 
10 - 23.03.18 - 07:26
[объект данных текстового поля] = [новое значение]
 
 Рекламное место пустует
   hhhh
 
11 - 23.03.18 - 08:12
(8) ничего себе экпериментировал. Это всё равно что голову отрубить топором, а потом сказать - это я экспериментировал.
   Anton26
 
12 - 23.03.18 - 08:39
Хорошо скажем не экспериментировал а с начала не понимал разницы так как я не профессионал а только изучаю 1с.
Все же если кто может перевести пример как заполнить текстовое поле
   Малыш Джон
 
13 - 23.03.18 - 08:43
(12) ты с программированием раньше сталкивался? что такое "присвоить значение" понимаешь?
   Anton26
 
14 - 23.03.18 - 08:45
да понимаю
   Малыш Джон
 
15 - 23.03.18 - 08:48
ну и как тогда поместить значение в поле ввода?
   Малыш Джон
 
16 - 23.03.18 - 08:49
видимо, если А - это значение твоего текстового поля, а 5 - это значение которое надо присвоить, то тогда надо писать "А=5"?
   Малыш Джон
 
17 - 23.03.18 - 08:49
п..ц какой-то
   Fish
 
18 - 23.03.18 - 08:50
(12) Начни изучать с азов. Книжки почитай какие-нибудь для начала. Курсы посмотри.
   Anton26
 
19 - 23.03.18 - 09:33
Если бы вы не критиковали не придирались а просто предоставили пример что я думаю для вас не составило бы сложности я бы по нему как раз бы и разобрался и не было бы глупых вопросов и ответов.
   AneJIbcuH
 
20 - 23.03.18 - 09:41
Чего накинулись-то )
"Перевозчик1 = Справочники.Контрагенты.НайтиПоНаименованию ("1232").ПолучитьОбъект();
    Если Не ЗначениеЗаполнено(Перевозчик1) Тогда Сообщить("Не найден документ!"); Возврат; 
    КонецЕсли;
    Перевозчик1.Записать();"
Хотя это невообразимая кака ))

По делу: В модуле формы, "ПриСозданииНаСервере"
Пробовал:
Объект.Перевозчик1 = Справочники.Контрагенты.НайтиПоНаименованию("1232"); ?
   AneJIbcuH
 
21 - 23.03.18 - 09:43
(0) грузоотправитель  - это реквизит формы или объекта?
Наверное, Мозг порвал..
   Fish
 
22 - 23.03.18 - 10:41
(19) Например, если грузоотправитель выбирается из контрагентов, то это уже не текстовое поле, а ссылочное. :)
   Anton26
 
23 - 23.03.18 - 11:59
Поле ввода Перевозчик, Данные поля ввода Объект.Перевозчик - Тип СправочникСсылка.Контрагенты
   Anton26
 
24 - 23.03.18 - 12:18
AneJIbcuH - да пробовал поле ввода все ровно остается пустым.
   hhhh
 
25 - 23.03.18 - 12:59
(24) показывайте поле ввода, что у него в свойстве Данные, надеюсь там написано Перевозчик1.
   Anton26
 
26 - 23.03.18 - 13:02
я же написал что у него в свойстве данные Объект.Перевозчик
   Fish
 
27 - 23.03.18 - 13:06
(26) А откуда взялся Перевозчик1? Это что такое?
   Anton26
 
28 - 23.03.18 - 13:11
Немного все уже запуталось давайте повторю все с начала и подробнее.
Имеется 1с 8.3 УТ в которой есть Документ ТранспортнаяНакладная в ней есть форма документа с полем ввода Перевозчик- Путь к данным Объект.Перевозчик, Объект.Перевозчик имеет Тип СправочникСсылка.Контрагенты
Хочу добиться того чо-бы это поле при открытии этого документа заполнялось постоянным контрагентом тут в теме подсказали что это можно реализовать НайтиПоКоду но я не могу разобраться что куда, что не попробую все ровно поле остается пустым
   AneJIbcuH
 
29 - 23.03.18 - 13:27
(28) К (20) Объект.Перевозчик = Справочники.Контрагенты.НайтиПоНаименованию("1232")
   Evgenchik
 
30 - 23.03.18 - 13:32
(29) уж тогда по коду "1232"
   Anton26
 
31 - 23.03.18 - 13:54
пробовал поле остается пустым.
   Anton26
 
32 - 23.03.18 - 13:55
и код и наименование
   Evgenchik
 
33 - 23.03.18 - 14:06
Так может нет контрагентов ни с кодом 1232, ни с наименованием 1232?
 
 
   Anton26
 
34 - 23.03.18 - 14:22
Такой контрагент есть
   hhhh
 
35 - 23.03.18 - 14:24
(34) покажи на картинках. что-то ты нас совсем запутал.
   Anton26
 
36 - 23.03.18 - 14:39
   okSYS
 
37 - 23.03.18 - 14:40
так и знал)
   okSYS
 
38 - 23.03.18 - 14:44
возможно где-то в ПриОткрытии() этот Объект.Перевозчик очищается
   Anton26
 
39 - 23.03.18 - 14:45
самого контрагента надо ?
   Evgenchik
 
40 - 23.03.18 - 14:45
Либо (33) либо у тебя ниже затирается перевозчик
   hhhh
 
41 - 23.03.18 - 14:48
(39) давай. может там пробелов в коде наставил
   Anton26
 
42 - 23.03.18 - 14:50
данный объект больше не где не используется а то-есть он не очищается
   hhhh
 
43 - 23.03.18 - 14:53
(42) ну так пробуй
    Если Не ЗначениеЗаполнено(Объект.Перевозчик) Тогда Сообщить("Не найден документ!");  
    КонецЕсли;
   Малыш Джон
 
44 - 23.03.18 - 14:54
время познакомиться с отладчиком
   Evgenchik
 
45 - 23.03.18 - 14:54
+(41)
Может код контрагента "     1232" или "1232     "?
   Anton26
 
46 - 23.03.18 - 14:56
   Evgenchik
 
47 - 23.03.18 - 15:00
Вряд ли код контрагента из 4 символов состоит, попробуй пробелами дополнить до максимальной длины кода
   Anton26
 
48 - 23.03.18 - 15:04
Если Не ЗначениеЗаполнено(Объект.Перевозчик) Тогда Сообщить("Не найден документ!");  
    КонецЕсли;
нечего не выдает
и да я пробовал не только на данном контрагенте
   Evgenchik
 
49 - 23.03.18 - 15:06
Что выдает?:
Сообщить(Справочники.Контрагенты.НайтиПоНаименованию ("1232"));
 
 Рекламное место пустует
   Anton26
 
50 - 23.03.18 - 15:15
Сообщить(Справочники.Контрагенты.НайтиПоНаименованию ("1232"));
открывает окно сообщение но в нем нечего не написано.
   Малыш Джон
 
51 - 23.03.18 - 15:16
а если 
Сообщить(Справочники.Контрагенты.НайтиПоНаименованию ("1232")+";");

?
   Anton26
 
52 - 23.03.18 - 15:20
{Документ.ТранспортнаяНакладная.Форма.ФормаДокумента.Форма(8)}: Преобразование значения к типу Число не может быть выполнено
   Evgenchik
 
53 - 23.03.18 - 15:20
(50) значит не нашел такого контрагента.
Выбери руками этого контрагента в поле перевозчик, потом сделай кнопку - и по нажатию выведи код
Сообщить("Код="+Объект.Перевозчик.Код+".")
   Serg_1960
 
54 - 23.03.18 - 15:21
Процедура ПриСозданииНаСервере
   Перевозчик = Справочники.Контрагенты.НайтиПоНаименованию("1232")
   Малыш Джон
 
55 - 23.03.18 - 15:22
(52) значит нет у тебя такого контрагента
   Serg_1960
 
56 - 23.03.18 - 15:26
(51) Не путайте автора :( Это всегда будет выдавать ошибку. Вот так лучше (хотя по прежнему не вижу смысла)
Сообщить("" + Справочники.Контрагенты.НайтиПоНаименованию ("1232", Истина));
   Малыш Джон
 
57 - 23.03.18 - 15:28
(56) точно) просто я по умолчанию в строку заворачиваю значение, если выводить нужно, поэтому и не обратил внимания
   Serg_1960
 
58 - 23.03.18 - 15:32
А вообще, если вы хотите что-то найти, но не уверены в точном соответствии, то - запрос, Наименование ПОДОБНО и т.д.
   Anton26
 
59 - 23.03.18 - 15:33
(53) Добавил кнопку, при нажатии пишет что Поле объекта не обнаружено (Код)
   Serg_1960
 
60 - 23.03.18 - 15:41
Сейчас выяснится что автор потерял не только своего контрагента "007", но у него пропал сам Объект :)

Понимаю - пятница, конец недели, все устали... но не настолько же :(
   Anton26
 
61 - 23.03.18 - 15:43
(59) извиняюсь там немного запутался но теперь он выводит сообщение Код=.
   Anton26
 
62 - 23.03.18 - 15:44
после нажатия кнопки Сообщить("Код="+Объект.Перевозчик.Код+".")
   Serg_1960
 
63 - 23.03.18 - 15:48
(61) Я даже догадываюсь какая ошибка была - ты написал "Объект.Код"? "Объект" - это документ, чью форму ты редактируешь. А у документа нет кода - есть номер и дата.
   Anton26
 
64 - 23.03.18 - 15:50
сделал кнопку она выдает просто сообщение код=. то-есть она не видит не какого кода.
   Evgenchik
 
65 - 23.03.18 - 16:00
Ты контрагента выбрал руками? Поле заполнено? И после того как руками выбрал - жми кнопку для сообщения кода
   Anton26
 
66 - 23.03.18 - 16:01
(65) да именно так я сделал.
   Evgenchik
 
67 - 23.03.18 - 16:06
Ставь точку останова, подключайся отладчиком и смотри что у тебя в объекте есть, что в объект.перевозчик
   hhhh
 
68 - 23.03.18 - 16:07
(66) ладно, дарю

https://pastenow.ru/b610fe18c3dcfa198d9c33ed18b2c194

наслаждайся
   Evgenchik
 
69 - 23.03.18 - 16:08
Капец
   Serg_1960
 
70 - 23.03.18 - 16:14
А всё-таки, интереса ради что будет найдено, если:
    Запрос = Новый Запрос("ВЫБРАТЬ Контрагенты.Наименование ИЗ Справочник.Контрагенты КАК Контрагенты ГДЕ    Контрагенты.Наименование ПОДОБНО ""%1232%""");
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        Сообщить("Найдено с наименованием <" + Выборка.Наименование + ">");
    КонецЦикла;
   Anton26
 
71 - 23.03.18 - 16:28
Всем спасибо я извиняюсь что развел такую большую дискуссию. Все получилось довольно просто по коду не смогло найти так как у Контрагента почему то нет кода, очень помогла кнопка только за место Кода сделал Наименование и после Объект.Перевозчик = Справочники.Контрагенты.НайтиПоНаименованию(""); честно скажу я пробовал до этого так но почему то не получилось только после создания кнопки и копирования того что она вывела все получилось. Всем большое спасибо и еще раз извиняюсь.
   Anton26
 
72 - 23.03.18 - 16:28
(70) он даже документ не захотел открывать
   Anton26
 
73 - 23.03.18 - 16:28
(70) просто вывел пустое сообщение
   Evgenchik
 
74 - 23.03.18 - 16:40
Ты все таки постарайся построить алгоритм таким образом, чтобы не было использования Найтипонаименованию и покоду
   Anton26
 
75 - 23.03.18 - 16:46
(74) вы имеете ввиду построить запрос с использованием ПОДОБНО ?
   Serg_1960
 
76 - 23.03.18 - 16:54
(75) Возможно Вам посоветовали объявить эту запись (которую, я так думаю, вы хотите использовать как значение "по умолчанию") предопределенной или записать эту ссылку в константу и ен использовать ни запрос, ни поиск по коду или наименованию.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует