Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вызов серверной процедуры при заполнении ТЧ из внешней обработки

Вызов серверной процедуры при заполнении ТЧ из внешней обработки
Я
   iva77ru
 
15.03.18 - 17:26
Добрый день!
Пожалуйста, помогите разобраться:

Заполняю ТЧ документа из дополнительной обработки. После добавления строки нужно обработать ТЧ процедурой описанной в модуле формы документа(не тащить же ее в обработку. Проблема с вызовом этой процедуры.

1) Вызов в модуле формы
&НаСервере
Процедура Заполнить()
ОбщийМодуль.Заполнить(ЭтаФорма);
КонецПроцедуры

2) Как вызвать в модуле обработки заполнения? Передать форму документа  на сервер нет получается
 
 
   xxTANATORxx
 
1 - 15.03.18 - 18:28
(0)скажи мне пожалуйста тип значения ЭтаФорма
   d4rkmesa
 
2 - 15.03.18 - 20:15
Допустим у вас есть внешняя обработка на БСП, с видом "ЗаполнениеОбъекта" и в команде указано в колонке "Использование" значение "ЗаполнениеФормы". Интерфейс выполнения команды, для примера:

// Интерфейс для выполнения команд обработки.

Процедура ВыполнитьКоманду(ИмяКоманды, ОбъектыНазначения, ПараметрыВыполнения) Экспорт    
    
    Если ИмяКоманды = "ЗаполнитьРеализациейЗаМесяц" Тогда
        
        ЗаполнитьРеализациейЗаМесяц(ПараметрыВыполнения.ЭтаФорма);
        
    КонецЕсли;
    
КонецПроцедуры

Т.е. можно использовать ПараметрыВыполнения.ЭтаФорма - это и будет форма документа.
   Cyberhawk
 
3 - 15.03.18 - 20:35
Если тип команды у подключаемой обработки - открытие формы, то форма документа - это владелец формы обработки
   iva77ru
 
4 - 16.03.18 - 14:35
ВладелецФормы - доступен только на клиенте, требуется сообщить процедуре на сервере об УП.

Есть вызов в модуле формы документа:

&НаСервере
Процедура ЗаполнитьНаСервере
ОбщийМодуль.ЗаполнитьЧто-то(ЭтаФорма);
КонецПроцедуры

Можно ли из обработки заполнения документа вызвать эту же процедуру, передав ей объект Управ. форма документа?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует