Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

При копировании документа не все реквизиты копируются

При копировании документа не все реквизиты копируются
Я
   prilforreal
 
15.03.18 - 09:19
Добрый день! Конфа самописная, 1с 8.3 Есть документ ПредзаказТовара, при копировании заполняются все реквизиты кроме кассы (Поле пустое) и Даты (Дата ставится текущая), мне же нужно чтобы все реквизиты, кроме номера документа конечно же совпадали с документом основания. Ни в модуле формы, ни в модуле объекта нет процедур связаных с копированием.
 
 
   Повелитель
 
1 - 15.03.18 - 09:24
(0) Ни в модуле формы, ни в модуле объекта нет процедур связаных с копированием.
Думаю есть.
   Повелитель
 
2 - 15.03.18 - 09:25
(1) В форме, ПриОткрытии, ПередОткрытием, Модуль внизу без процедур.
В Модуле, ПриКоприовании, Модуль внизу без процедур.
   prilforreal
 
3 - 15.03.18 - 09:28
(1) Есть то конечно, но у меня ничего такого не описано, насколько я понимаю мне нужно в модуле объекта, в процедуре при копировании написать что то вроде
ЭтотОбъект.Дата=ДокументОснования.Дата
ЭтотОбъект.Касса=ДокументОснования.Касса
   prilforreal
 
4 - 15.03.18 - 09:30
(2) Подскажите, будьте любезны, как ссылку на основание получить?)
   catena
 
5 - 15.03.18 - 09:35
При чем тут копирование и ДокументОснование?
   catena
 
6 - 15.03.18 - 09:38
Т.е. сперва кодом где-то эти параметры затираются, а потом ты их обратно будешь добавлять. Тебе все равно придется искать, чтобы стратегически свои пляски вставить после затирания, иначе толку не будет.
   prilforreal
 
7 - 15.03.18 - 09:38
(5) Извините, ОбъектКопирования)
Пишу:

Процедура ПриКопировании(ОбъектКопирования)
    ЭтотОбъект.Дата=ОбъектКопирования.Дата;
    ЭтотОбъект.Касса=ОбъектКопирования.Касса;
КонецПроцедуры

Дата копируется, касса остается пустой.
   prilforreal
 
8 - 15.03.18 - 09:40
Ага! Нашел!

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
//    ПриЗаписиПерепроводить(1);

    Если ЭтоНовый() тогда
        Автор=ТекПользователь;
        Касса=Автор.Касса3;
    КонецЕсли;    
    КонецПроцедуры 

Значит теперь нужно написать условие:
Если не Копирование Тогда

Конец если;
   prilforreal
 
9 - 15.03.18 - 09:41
Стоп, тут же указано ЕСЛИ ЭтоНовый, тогда почему касса не копируется?
   Fish
 
10 - 15.03.18 - 09:42
(9) Потому что, когда копируешь, то создаётся НОВЫЙ документ в базе :))
 
 Рекламное место пустует
   prilforreal
 
11 - 15.03.18 - 09:44
(10) Еще только утро, а фляжка свистит =D Я понял уже)
   prilforreal
 
12 - 15.03.18 - 09:51
В итоге получилось так:

Процедура ПриКопировании(ОбъектКопирования)
    ЭтотОбъект.Дата=ОбъектКопирования.Дата;
    ЭтотОбъект.Касса=ОбъектКопирования.Касса;
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если ЭтоНовый() тогда
        Автор=ТекПользователь;
        Если ПараметрОбъектКопирования=0 Тогда
        Касса=Автор.Касса3;
        КонецЕсли;
    КонецЕсли;    
    КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует