Вход | Регистрация


Проблема с кодом, подскажите

Проблема с кодом, подскажите
Я
   s3xt4z1
 
12.03.18 - 08:34
&НаКлиенте
Процедура Заполнить(Команда)
    Количество =  ЗаполнитьНаСервере(ГруппаНоменклатура, 
        ВидНоменклатуры);
    Предупреждение("Обработано элементов " + Количество);
КонецПроцедуры

&НаСервере
Функция ЗаполнитьНаСервере(ГруппаНоменклатура, 
        ВидНоменклатуры)    
        
    Выборка = Справочники.Номенклатура.ВыбратьИерархически(ГруппаНоменлатуры);    
    
    Количество = 0;
        
    Пока Выборка.Следующий() Цикл
        
        Если Выборка.ЭтоГруппа Тогда
            Продолжить;
        КонецЕсли;
        
        // СправочникОбъект.Номенклатура

        СправочникОбъект = Выборка.ПолучитьОбъект();
        СправочникОбъект.ВидНоменклатуры = ВидНоменклатуры;
        СправочникОбъект.Записать();
        
        Количество = Количество + 1;
        
    КонецЦикла;
    
    Возврат Количество;
    
КонецФункции



{Обработка.ЗаполнениеВидовНоменклатуры.Форма.Форма.Форма(13,57)}: Переменная не определена (ГруппаНоменлатуры)
    Выборка = Справочники.Номенклатура.ВыбратьИерархически(<<?>>ГруппаНоменлатуры);     (Проверка: Сервер)

Не могу понять почему сервер не читает его?
 
 
   nordbox
 
1 - 12.03.18 - 08:36
ГруппаНоменлатуры буква К где? )
   Малыш Джон
 
2 - 12.03.18 - 08:36
(0) странный совет, но...

прочитай внимательнее названия переменной
   s3xt4z1
 
3 - 12.03.18 - 08:39
ох как же стыдно то))
   nordbox
 
4 - 12.03.18 - 08:42
(3) Не переживай, тут много чего видели )
   s3xt4z1
 
5 - 12.03.18 - 08:43
nordbox спасибо)) 
Главное в окно не влезает код полностью приходится крутить в право ползунок, даже не заметил синтаксическую ошибку
   13_Mult
 
6 - 12.03.18 - 08:46
(5) Ты на смартфоне кодишь? :)
   Масянька
 
7 - 12.03.18 - 08:47
(5) Где-то там есть синтаксический контроль. Не редко - первое, что нужно сделать при возникновении ошибок.
   s3xt4z1
 
8 - 12.03.18 - 08:54
(5) +
   СвинТуз
 
9 - 12.03.18 - 08:57
А зачем параметром передавать то что там и так доступно если вызов контекстный?
   Eiffil123
 
10 - 12.03.18 - 09:02
(9) ну например, ГруппаНоменклатура - это переменная модуля формы. Переменные модуля формы не мигрируют между клиентом и сервером, а если бы эта переменная была серверной, то она бы еще и очищалась при уходе кода с сервера.
 
 Рекламное место пустует
   Малыш Джон
 
11 - 12.03.18 - 09:07
(9) ну почему бы и не передать? :)
   СвинТуз
 
12 - 12.03.18 - 09:17
Сам вызов может быть не контекстный?
Похоже что может.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует