Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Переименование группы справочника

Переименование группы справочника
Я
   jyurik
 
07.03.18 - 10:53
Как программно поменять наименование все группы справочника номенклатура на их же код. Чтобы код и имя группы справочника совпадали.
 
 
   ildary
 
1 - 07.03.18 - 10:54
(0) это надо программиста позвать.
   ildary
 
2 - 07.03.18 - 10:55
Ну или здесь на форуме озвучить гонорар и бросить - клич. Только учтите - учитывая уровень форума - дешево не получится.
   ildary
 
3 - 07.03.18 - 11:10
(0) Ещё хороший вариант - внести пожертвование на новый сервер Мисты - тогда я помогу бесплатно.
   Михаил Козлов
 
4 - 07.03.18 - 11:16
(0) Универсальный подбор и обработка объектов с произвольным алгоритмом типа:
Объект.Наименование = Объект.Код;
Объект.Записать();
Только не забыть отобрать папки.
   nordbox
 
5 - 07.03.18 - 11:19
(4) Ты чо хлеб перебиваешь у (2) )))
   jyurik
 
6 - 07.03.18 - 11:24
(4) как переименовать элемент справочника мне и так известно, а вот как переименовать группу не могу понять, как отобрать
Вот вариант, какой у меня работает по элементу:

   Выборка = Справочники.СпецификацииНоменклатуры.Выбрать(); 
    Пока Выборка.Следующий() Цикл
        ТекОбъект = Выборка.ПолучитьОбъект();
        ТекОбъект.КодКэмз = ТекОбъект.Код;
        ТекОбъект.Записать();
    КонецЦикла;
   jyurik
 
7 - 07.03.18 - 11:25
(6) Выборка = Справочники.Номенклатура.Выбрать();
   nordbox
 
8 - 07.03.18 - 11:26
а хде проверка ЭтоГруппа()
   Рэйв
 
9 - 07.03.18 - 11:37
(6)Элемент от группы отличается только полем ЭтоГруппа
   jyurik
 
10 - 07.03.18 - 11:51
(9) Так?
  Выборка = Справочники.Номенклатура.Выбрать(); 
    Пока Выборка.Следующий() Цикл
        ТекОбъект = Выборка.ПолучитьОбъект();
        ТекОбъект.ЭтоГруппа.Наименование = ТекОбъект.ЭтоГруппа.Код;
        ТекОбъект.Записать();
    КонецЦикла;
 
 Рекламное место пустует
   nordbox
 
11 - 07.03.18 - 11:57
(10) Ты долго г....кодить будешь? ))
   nordbox
 
12 - 07.03.18 - 11:59
ЭтоГруппа (IsFolder)
Использование:

Только чтение.
Описание:

Тип: Булево.
Позволяет определить является ли элемент справочника группой.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Примечание:

Истина - элемент является группой;
Ложь - элемент не является группой.
   silent person
 
13 - 07.03.18 - 12:09
Пока Выборка.Следующий() Цикл
  Если НЕ Выборка.ЭтоГруппа тогда
Продолжить;
КонецЕсли;
.... здесь переименовать
    КонецЦикла;
   jyurik
 
14 - 07.03.18 - 12:09
(12) Извините, ничего не понял. Можно конкретно, что у меня надо изменить
   user-ok
 
15 - 07.03.18 - 12:12
>> что у меня надо изменить
род деятельности

    Запрос = Новый запрос;
    
    Запрос.Текст = "ВЫБРАТЬ
                   |    СпецификацииНоменклатуры.Ссылка,
                   |    СпецификацииНоменклатуры.Код
                   |ИЗ
                   |    Справочник.СпецификацииНоменклатуры КАК СпецификацииНоменклатуры
                   |ГДЕ
                   |    СпецификацииНоменклатуры.ЭтоГруппа = ИСТИНА";
                   
    Выборка = Запрос.Выполнить().Выбрать();
    
    пока Выборка.Следующий() Цикл
        
        Объект = Выборка.ПолучитьОбъект();
        
        Объект.Наименование = Выборка.Код;
        
        Объект.Записать();
        
    КонецЦикла;    


лови код
   nordbox
 
16 - 07.03.18 - 12:15
Ну сделай хотя бы так, другие варианты уже не будем трогать
Выборка = Справочники.Номенклатура.Выбрать(); 
    Пока Выборка.Следующий() Цикл
     ТекОбъект = Выборка.ПолучитьОбъект();
     Если ТекОбъект.ЭтоГруппа() Тогда 
        ТекОбъект.Наименование = ТекОбъект.Код;
        ТекОбъект.Записать();
      КонецЕсли;
    КонецЦикла;
   silent person
 
17 - 07.03.18 - 12:17
(15) гы-гы.
ща он этот код запустит, а ему походу надо номенклатуру переименовывать.
   1Сергей
 
18 - 07.03.18 - 12:18
вы охренели? гранату обезьяне давать

(0) Какой смысл всем группам присваивать одиннаковые наименования и коды?
   nordbox
 
19 - 07.03.18 - 12:22
(18) История это умалчивает
ТС уже отмечает наверное 
Остается надеяться это у него копия или учебная для познания
   hhhh
 
20 - 07.03.18 - 12:22
(18) собеседование может
   jyurik
 
21 - 07.03.18 - 12:25
(16) Метод объекта не обнаружен (ЭтоГруппа)
(15) Метод объекта не обнаружен (ПолучитьОбъект)
   silent person
 
22 - 07.03.18 - 12:26
(21) ха-ха-ха
   catena
 
23 - 07.03.18 - 12:28
>>собеседование может

Сами помогаем геодезистам пройти собеседование, потом сами ругаемся, когда геодезисты за программиста вкалывают. Г-логика.
   nordbox
 
24 - 07.03.18 - 12:28
(22) А ты где это делаешь?
   catena
 
25 - 07.03.18 - 12:29
(21)Стаж на форуме 5 лет 10 месяцев. Последние 12 тем по УПП. Тролль или алкаш?
   1Садовник
 
26 - 07.03.18 - 12:31
(25) аккаунт угнали)
   nordbox
 
27 - 07.03.18 - 12:31
(24) для (21)
   tesseract
 
28 - 07.03.18 - 12:33
Групповую обработку реквизитов уже выжгли из БСП?
   nordbox
 
29 - 07.03.18 - 12:35
(28) Погоди, тут интереснее )
сначала ждем ответ на (18) и (24)
   jyurik
 
30 - 07.03.18 - 12:37
(25) сидим, бухаем и празднуем
С Наступающим!!! :)
   Малыш Джон
 
31 - 07.03.18 - 12:39
(29) не, в (18) все верно

ЭтоГруппа - это не метод, а свойтво

А ПолучитьОбъект() надо к ссылке применять, а не к выборке
   catena
 
32 - 07.03.18 - 12:41
(30)Чорт, хотела тему закрыть, а тут такое :) Теперь рука не поднимается. Осторожно там, на рабочей базе весь предложенный код сегодня не запускай))
   nordbox
 
33 - 07.03.18 - 12:41
(31) Да пусть называет как хочет )
они бухают
 
 
   1Сергей
 
34 - 07.03.18 - 12:54
(31) >>А ПолучитьОбъект() надо к ссылке применять, а не к выборке

Чо правда?
   1Сергей
 
35 - 07.03.18 - 12:55
   silent person
 
36 - 07.03.18 - 13:11
там же выборка из результата запроса, а не СправочникВыборка
   user-ok
 
37 - 07.03.18 - 13:46
(17) в (6) он писал про спецификации
   user-ok
 
38 - 07.03.18 - 13:46
(31) согласен. спешил


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует