Вход | Регистрация

1С:Предприятие ::

Метки: 

Как определить к какому журналу принадлежит документ?

Я
   Хрюкин
 
07.03.18 - 06:06
В обработке перебираю все документы. Требуется отделить документы, которые относятся к журналу "Кадровые документы" от остальных.
 
  Рекламное место пустует
   catena
 
1 - 07.03.18 - 06:09
Сделать запрос к нужному журналу.
   Хрюкин
 
2 - 07.03.18 - 06:16
(1) Это да. К конкретному журнал можно сделать запрос. А как сделать тогда запрос ко всем остальным журналам?
   Mankubus
 
3 - 07.03.18 - 06:24
(2) не надо к остальным. Делай через выбор когда мой журнал тогда ок иначе остальнойжурнал конец
   Eiffil123
 
4 - 07.03.18 - 06:38
Например, так:


&НаСервере
Процедура Команда1НаСервере()
    
    Для Каждого ТекДок Из Метаданные.Документы Цикл
        
        МассивЖурналов = Новый Массив;
        Для Каждого ТекЖурнал из Метаданные.ЖурналыДокументов Цикл
            Если ТекЖурнал.РегистрируемыеДокументы.Содержит(ТекДок) Тогда
                МассивЖурналов.Добавить(ТекЖурнал);
            КонецЕсли;
        КонецЦикла;
        
        // В массиве МассивЖурналов для нужного текущего типа документа все журналы, где он участвует

        
    КонецЦикла;
    
КонецПроцедуры


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует