Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Сохранение и загрузка настроек управляемой формы

Сохранение и загрузка настроек управляемой формы
Я
   Vladislava-smile
 
06.03.18 - 19:00
функции сохранения написаны, работают:
&НаСервере
Процедура СохранитьНастройкиУФСписка(КомпоновщикНастроек, ЭтотОбъект, мТекущаяНастройка) Экспорт 
    
     Если мТекущаяНастройка<>Неопределено Тогда
        СтруктураНастройки = мТекущаяНастройка;
    Иначе
        СтруктураНастройки = Новый Структура;
        СтруктураНастройки.Вставить("ИмяОбъекта", Строка(ЭтотОбъект));
        СтруктураНастройки.Вставить("НаименованиеНастройки", Неопределено);
        СтруктураНастройки.Вставить("ИспользоватьПриОткрытии", Ложь);
        СтруктураНастройки.Вставить("СохранятьАвтоматически", Ложь);
    КонецЕсли;

    СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
    СохраненнаяНастройка = Новый ХранилищеЗначения(КомпоновщикНастроек.ПолучитьНастройки());
    СтруктураНастройки.Вставить("СохраненнаяНастройка", СохраненнаяНастройка);

    ВозвращаемаяСтруктура = УниверсальныеМеханизмы.СохранениеНастроек(СтруктураНастройки);

    Если ВозвращаемаяСтруктура <> Неопределено Тогда
        мТекущаяНастройка = ВозвращаемаяСтруктура;
    Иначе
        мТекущаяНастройка = СтруктураНастройки;
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Процедура ЗагрузитьНастройкиУФСписка(КомпоновщикНастроек, ЭтотОбъект, мТекущаяНастройка) Экспорт  
    
    СтруктураНастройки = Новый Структура;
    СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
    СтруктураНастройки.Вставить("ИмяОбъекта", Строка(ЭтотОбъект));
    СтруктураНастройки.Вставить("НаименованиеНастройки", ?(мТекущаяНастройка = Неопределено, Неопределено, мТекущаяНастройка.НаименованиеНастройки));

    ВозвращаемаяСтруктура = УниверсальныеМеханизмы.ВосстановлениеНастроек(СтруктураНастройки);

    Если ВозвращаемаяСтруктура <> Неопределено Тогда
        мТекущаяНастройка = ВозвращаемаяСтруктура;
        КомпоновщикНастроек.ЗагрузитьНастройки(мТекущаяНастройка.СохраненнаяНастройка.Получить());
    КонецЕсли;

КонецПроцедуры

Но при открытии стандартной процедуры настроить список - я не вижу настройки, которые были сохранены, и которые уже работют с данными списка. Не понимаю в чем затык????
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует