Вход | Регистрация



Конвертация данных 3.0

Конвертация данных 3.0
Я
   Автоматизатор_1C
 
06.03.18 - 10:42
Коллеги, всем привет.
Настраиваю две отраслевые конфигурации в части канка и кассы через дописанный "МенеджерОбменаЧерезУниверсальныйФормат"

Вопрос связан с документом Поступление на расчетный счет с видом операции "Поступления от продаж по платежным картам и банковским кредитам"

Настраиваю ПКС для документа "Документ_ПРСПоПлатежнымКартам_Отправка"
в документе, в таб части есть реквизит:
РасшифровкаПлатежа.ДоговорКонтрагента, но нет свойство формата по этому реквизиту.
Вопрос как это поле корректно перенести?
Кто сталкивался поделитесь опытом пожалуйста
 
 
   Автоматизатор_1C
 
1 - 06.03.18 - 10:46
(0) Настраиваю обмен между двумя разными отраслевыми конфигурациями в части БП (банк и касса)

Версия БСП: 2.3.5.81
версии конфигурации в части БП:
Конфигурация1: 3.0.51.11
Конфигурация2: 3.0.52.42
   hhhh
 
2 - 06.03.18 - 10:48
по идее не должно быть РасшифровкаПлатежа.ДоговорКонтрагента в этом случае. Это же прочее поступление, банк платит общую сумму за день, без разбивки по договорам.
   Автоматизатор_1C
 
3 - 06.03.18 - 11:09
(2) но в документ можно добавить теоретически две строки расшифровки с разными договорами.
Как отработать если будет такой вариант?
   Автоматизатор_1C
 
4 - 06.03.18 - 11:14
(2) Да, ты прав.
Если в документе одна строка, то в документе есть реквизит "ДоговорКонтрагента" (не в таб части) , но в свойство формата все равно нет договора(
Как его выгрузить?
   nordbox
 
5 - 06.03.18 - 11:29
(4) Может не по теме.
Но я для УТ 10.3, для клиента делал, там выписка банка,
я назначение платежа от банка разбирал на "запчати" чуть поправил типовую и все нормально.
Там подставлялась операция, договор эквайринга и выделял комиссию банка, она тоже в назначении была.
Выделял потому что банк не присылал комиссию за весь месяц.
я х.з. почему, это не мое дело, я клиенту сказал как должно быть, но он сказал что не было и нет
   Defender aka LINN
 
6 - 06.03.18 - 11:38
Там есть эквайрер, банковский счет и терминал. На основании этого и генери договор
   Автоматизатор_1C
 
7 - 06.03.18 - 11:51
Полазил в типовой обмен 
там в обработке ПередЗаписьюПолученныхДанных есть такой фрагмент кода:
    ДоговорЭквайринга = ДоговорЭквайринга(ПолученныеДанные.Организация, ПолученныеДанные.Контрагент);
    Для Каждого Расшифровка Из ПолученныеДанные.РасшифровкаПлатежа Цикл
        Если НЕ ЗначениеЗаполнено(Расшифровка.ДоговорКонтрагента) Тогда
            Расшифровка.ДоговорКонтрагента = ДоговорЭквайринга;
        КонецЕсли;
    КонецЦикла;

По контрагенту и организации получает договор контрагента уже в базе приемник.
Но в базе источник может быть несколько договоров эквайринга и нужно каким то образом передать именно тот договор который указан в базе иСТОЧНИК
   Автоматизатор_1C
 
8 - 06.03.18 - 11:53
Функция ДоговорЭквайринга(Организация, Контрагент)
    Если НЕ ЗначениеЗаполнено(Организация) 
        ИЛИ НЕ ЗначениеЗаполнено(Контрагент) Тогда
        Возврат Справочники.ДоговорыКонтрагентов.ПустаяСсылка();
    КонецЕсли;
    
    НаименованиеЭлементаДляОбменаПоУмолчанию = НСтр("ru='Договор эквайринга'");
    ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.Прочее;
    
    ПараметрыДоговора = Новый Структура;
    ПараметрыДоговора.Вставить("Наименование",         НаименованиеЭлементаДляОбменаПоУмолчанию);
    ПараметрыДоговора.Вставить("Организация",          Организация);
    ПараметрыДоговора.Вставить("Владелец",             Контрагент);
    ПараметрыДоговора.Вставить("ВалютаВзаиморасчетов", ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета());
    ПараметрыДоговора.Вставить("ВидДоговора",          ВидДоговора);
    
    Договор = ДоговорСПараметрамиПоУмолчанию(ПараметрыДоговора);
    
    Возврат Договор.Ссылка;
КонецФункции
   Zombi
 
9 - 06.03.18 - 11:55
(7) Вроде договор получает в приемнике по контрагенту и организации, если в источнике не заполнен. Может заполнить его в источнике?
   hhhh
 
10 - 06.03.18 - 11:57
(7) ну с банком обычно один договор на эквайринг заключается. Поэтому вы по банку уже можете разделять. Для каждого банка свой договор.
 
 Рекламное место пустует
   Defender aka LINN
 
11 - 06.03.18 - 12:11
Передавай через доп. сведения
   Автоматизатор_1C
 
12 - 06.03.18 - 12:17
(10) Наши бухгалтера - умельцы создали несколько договоров( (11) Попробую, спасибо
   Автоматизатор_1C
 
13 - 06.03.18 - 12:30
(11) Есть какой нибудь пример?
   Defender aka LINN
 
14 - 06.03.18 - 12:49
(13) В ПриОтправкеДанных:
ДанныеXDTO.Вставить("AdditionalInfo", Новый Структура("КодТНВЭД, Код", СокрЛП(ДанныеИБ.КодТНВЭД.НаименованиеПолное), СокрЛП(ДанныеИБ.КодТНВЭД.Код)));

   Автоматизатор_1C
 
15 - 06.03.18 - 13:42
(14) Спасибо попробовал.
    Если ЗначениеЗаполнено(ДанныеИБ.ДоговорКонтрагента) Тогда
        ДанныеXDTO.Вставить("AdditionalInfo", Строка(ДанныеИБ.ДоговорКонтрагента.УникальныйИдентификатор()))
    КонецЕсли;

При отладке проверил в ДанныеXDTO, свойство AdditionalInfo заполнилось.
Но открываю файл выгрузки, там этого поля нет.

Может потому что в пакете EnterpriseData_1_4_3 у объекта Документ.ПБДСПоПлатежнымКартам - базовый тип пустой?
   Defender aka LINN
 
16 - 06.03.18 - 14:29
(15) AdditionalInfo входит в тип "Object" пакета ExchangeMessage (https://www.screencast.com/t/DNfhvjQx), т.е. должен быть у всех. Надо смотреть, почему в файл не попадает
   Автоматизатор_1C
 
17 - 06.03.18 - 15:10
(16) Спасибо все работает)
забыл ";" поставить)
   Автоматизатор_1C
 
18 - 06.03.18 - 16:40
Рано порадовался, данные не выгружались.

Заработало после внесения изменений в пакет: EnterpriseData_1_4_3 

Документ.ПБДСПоПлатежнымКартам базовый тип = Object (http://www.1c.ru/SSL/Exchange/Message)
   Вафель
 
19 - 06.03.18 - 16:43
изменения в пакет вносить крайне не желательно.
Ибо никаких средств объединения пакетов нет
   Автоматизатор_1C
 
20 - 06.03.18 - 16:49
(19) (16)
Как еще могу решить проблему переноса гребаного договора?
без внесения изменений в пакет.
Проверил в БСП у документа ПБДСПоПлатежнымКартам тоже не установлен "Базовый тип"
   Вафель
 
21 - 06.03.18 - 17:07
Переходи на EnterpriseData_1_5_2
   Franchiser
 
22 - 06.03.18 - 17:08
(18) Это уже обмен не через универсальный формат)
   Автоматизатор_1C
 
23 - 06.03.18 - 17:11
(21) а в чем подвох?
там все также
   Вафель
 
24 - 06.03.18 - 17:16
я думал там поправили косяк
   Cyberhawk
 
25 - 06.03.18 - 17:26
Переходи на обмен КД 2
   Автоматизатор_1C
 
26 - 06.03.18 - 17:47
(25) К сожалению уже поздно(


Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует