Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка в параметрах запроса

Ошибка в параметрах запроса
Я
   antihacker
 
06.03.18 - 06:32
Есть такой код.
        спСчетов = ОтчетыДляРуководителя.ПолучитьСписокСчетовИсключаемыхИзРасчетаЗадолженности(1);
        Если спСчетов <> Неопределено Тогда
            Для Каждого Счет Из спСчетов Цикл
                Если Запрос.Параметры.ИсключенныеСчета.НайтиПоЗначению(Счет)  = Неопределено Тогда
                    вввв=Запрос.Параметры.ИсключенныеСчета.НайтиПоЗначению(Счет);
                    //сообщить(Счет);

                    Запрос.Параметры.ИсключенныеСчета.Добавить(Счет);
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;


В списке значения спСчетов есть толкь один счет. То есть там реально одна запись. И это как мы вмдим передаем в параметр запроса.

Но запрос выдает ошибку

Неверные параметры
И НЕ Счет В ИЕРАРХИИ (<<?>>&ИсключенныеСчета)

В чем проблема ? Не могу понять.
 
 
   antihacker
 
1 - 06.03.18 - 06:32
Ой яч привентствия не туда написал )) сорри.
   cons74
 
2 - 06.03.18 - 06:40
А такой синтаксис разве работает
Запрос.Параметры.ИсключенныеСчета.Добавить ?
обычно
запрос.УстановитьПараметр(Имя,Значение)
   antihacker
 
3 - 06.03.18 - 06:42
А этот запрос.УстановитьПараметр("СчетаПользователя",Счет);

Вызызвает такую же ошибку.
   antihacker
 
4 - 06.03.18 - 06:44
Но при этом отладчик да и сообщить(Счет) показывает что Счет равно на типовой счет.
   shadow_sw
 
5 - 06.03.18 - 06:49
убери В ИЕРАРХИИ, ты формируешь список значений
   shadow_sw
 
6 - 06.03.18 - 06:49
НЕ Счет В (&ИсключенныеСчета) 

как то так
   Fram
 
7 - 06.03.18 - 06:54
(0) попробуй Массив вместо СписокЗначений
   catena
 
8 - 06.03.18 - 06:56
(3)
>>А этот запрос.УстановитьПараметр("СчетаПользователя",Счет); 
>>И НЕ Счет В ИЕРАРХИИ (<<?>>&ИсключенныеСчета) 

Какой параметр устанавливаем-то?
   antihacker
 
9 - 06.03.18 - 07:11
НЕ Счет В (&ИсключенныеСчета) 
точно такая же ошибка.
 
  catena,

Запрос.Параметры.ИсключенныеСчета.Добавить(Счет);
   shadow_sw
 
10 - 06.03.18 - 07:13
имена параметров не пересекаются
Запрос.УстановитьПараметр("ИсключенныеСчета", Счет);
 
 Рекламное место пустует
   Рэйв
 
11 - 06.03.18 - 07:17
(9)Сденлай сначала СЗ со счетами и потом поставь его параметром по человечески

Запрос.УстановитьПараметр("ИсключенныеСчета", спСчетов );
   Рэйв
 
12 - 06.03.18 - 07:17
и в СЗ не должно быть Неопределено и другого мусора
   mehfk
 
13 - 06.03.18 - 07:19
(0) За четыре года так и не научился устанавливать параметры запроса. Может лучше сменить профессию?
   antihacker
 
14 - 06.03.18 - 07:21
Рэйв, пробовал не получается. Отчет был создан в старой версии платформы. Теперь В новой версий вот такую выкидыывает.

mehfk, ты скажи где я не правильно устанавливаю, если силен.
   antihacker
 
15 - 06.03.18 - 07:22
СПЗначений = Новый списокЗначений;
                    СПЗначений.Добавить(Счет);
                    Запрос.Параметры.ИсключенныеСчета.Добавить(СПЗначений);
   МимохожийОднако
 
16 - 06.03.18 - 07:24
Надо (11) Запрос.Параметры.УстановитьПараметр("ИсключенныеСчета",СПЗначений)
   antihacker
 
17 - 06.03.18 - 07:36
Да пробовал я так.
   Umga2002
 
18 - 06.03.18 - 07:38
Сделай МАССИВ наконец-то.....
   catena
 
19 - 06.03.18 - 07:40
Нормально В ИЕРАРХИИ работает и со списком, и с массивом. Что с типом самого параметра?

<Выражение> [НЕ] В [ИЕРАРХИИ] ( <Список значений> | <Массив значений> ) |
<Выражение> [НЕ] В [ИЕРАРХИИ] ( <Описание запроса> ) |
   catena
 
20 - 06.03.18 - 07:43
спСчетов - что? Список значений? Тогда почему добавляешь Счет, а не Счет.Значение?
   mehfk
 
21 - 06.03.18 - 07:59
(14) Только по предоплате.
   Fram
 
22 - 06.03.18 - 08:03
(17) выложи ка сюда весь код от и до. А так же скрин отладки перед самым выполнением запроса со всеми параметрами
   antihacker
 
23 - 06.03.18 - 08:14
Вроде так работает

 Запрос.Параметры.ИсключенныеСчета.Добавить(Счет.Значение);

 catena, я просто слепой и тупой.
   antihacker
 
24 - 06.03.18 - 08:19
А вот   mehfk молодец. Деньги делает на ответах ))) Случайно не еврей  ? )
   mehfk
 
25 - 06.03.18 - 08:21
А ты таки антисемит?
   mehfk
 
26 - 06.03.18 - 08:23
Миста нуждается в твоих деньгах. Ей нужны новые SSD.
OFF: ТехИнфо: Работа форума восстановлена после сбоя
   mehfk
 
27 - 06.03.18 - 08:23
Ты же ничего не можешь без Мисты, пришло время ей помочь!
   antihacker
 
28 - 06.03.18 - 08:31
Я анти иудаид )
   Fram
 
29 - 06.03.18 - 08:35
(23) как только просишь скрин из отладки волшебным образом вдруг все проясняется ))
   МимохожийОднако
 
30 - 06.03.18 - 08:36
ОФФ:(28) ((
см (23) последняя строка
   antihacker
 
31 - 06.03.18 - 08:42
Отладка не помогла. Помогла внимательность   catena. Кстати. Куда кинуть деньги ? В поддержку форума ?  пожертвую десят баксов )
   mehfk
 
32 - 06.03.18 - 08:46
Свяжись с Волшебник
   antihacker
 
33 - 06.03.18 - 09:37
ОК !
 
 


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует