Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Значение "МФ00-037239" поля "Номер" не уникально

Значение "МФ00-037239" поля "Номер" не уникально
Я
   6en9er
 
28.02.18 - 09:41
Добрый день. База УТ 11.3, Платформа 8.3 (8.3.10.2252). Необходимо сделать, чтобы номер реализации совпадал с номером заказа. Соответственно сделал подписку:
Процедура Авэкс_ПриУстановкеНовогоНомера(Источник, СтандартнаяОбработка, Префикс) Экспорт
    Если ТипЗнч(Источник) = Тип("ДокументОбъект.РеализацияТоваровУслуг") Тогда
        Если Источник.ЭтоНовый()
            И ЗначениеЗаполнено(Источник.ЗаказКлиента)
            И ТипЗнч(Источник.ЗаказКлиента) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
            СтандартнаяОбработка = Ложь;
            Источник.Номер = Источник.ЗаказКлиента.Номер;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Из несколько тысяч реализаций 4 -5 не создаются из за ошибки.
{ОбщийМодуль.ОбщегоНазначенияУТКлиент.Модуль(1815)}: Ошибка при вызове метода контекста (Записать)
  Результат = Форма.Записать(ПараметрыЗаписи);
по причине:
Значение "МФ00-037239" поля "Номер" не уникально
В базе нет ни одной реализации с таким номером.
Подскажите куда копать.
 
 
   Звездец
 
1 - 28.02.18 - 09:42
Может не стоит? а если по заказу 2 реализации?
   b_ru
 
2 - 28.02.18 - 09:46
>>В базе нет ни одной реализации с таким номером.

В базе есть одна реализация с таким номером. Смотри лучше (подсказка, отбор по организациям там или что-то подобное)
   hhhh
 
3 - 28.02.18 - 09:47
(0) может сразу 2 реализации пишешь.
   spectre1978
 
4 - 28.02.18 - 09:52
(0) вы стреляете себе в ногу, делая подобную манипуляцию. Не советую.
   VladZ
 
5 - 28.02.18 - 09:56
(0) "Необходимо сделать, чтобы номер реализации совпадал с номером заказа" - для чего необходимо и кому? Я, например, не вижу такой необходимости.
   МимохожийОднако
 
6 - 28.02.18 - 10:26
(0) У реализации есть ссылка на заказ. Этого достаточно.
   yzimin
 
7 - 28.02.18 - 10:32
>>Необходимо сделать, чтобы номер реализации совпадал с номером заказа

Тогда и номер счет-фактуры делайте одинаковым, а то распечатаете УПД в статусе 1 и удивитесь)))
   МимохожийОднако
 
8 - 28.02.18 - 10:33
(7) Не учи плохому
   yzimin
 
9 - 28.02.18 - 10:34
(0)

Глобальный контекст (Global context)
ОбновитьНумерациюОбъектов (RefreshObjectsNumbering)
Синтаксис:

ОбновитьНумерациюОбъектов(<Метаданные>)

(8) это скорее сарказм)))

Список тем форума
Рекламное место пустует  Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует