Вход | Регистрация

1С:Предприятие ::

Метки: 

Не работает запрос с параметром ТЗ.

Я
   antihacker
 
28.02.18 - 06:42
Всем привет не могу понять почему запрос не выдает общую сумму остатка номенклатурную группу
Если вхНоменклатура.ЭтоГРуппа Тогда
    Запрос = Новый Запрос;
    Запрос.Текст = 

        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |   Номенклатура.Ссылка
        |ИЗ
        |   Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |Номенклатура.Ссылка В ИЕРАРХИИ(&Папка)";


Запрос.УстановитьПараметр("Папка",вхНоменклатура);

ТЗНоменклатура = Новый ТаблицаЗначений;
РезЗапрос = Запрос.Выполнить().Выгрузить();

КОнецЕсли;
        //---Проверяем остаток---------------------------------

        запрос=новый запрос;
        запрос.Текст=
        "    
        |ВЫБРАТЬ
        |    ТоварыНаСкладахОстатки.Склад КАК Склад,
        |    ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
        |    ТоварыНаСкладахОстатки.КоличествоОстаток КАК КоличествоОстаток
        |ИЗ
        |    РегистрНакопления.ТоварыНаСкладах.Остатки(
        |            ,
        |            Склад = &выбСписСклады
        |                И Номенклатура В (&Номенклатура)) КАК ТоварыНаСкладахОстатки";

            
        запрос.УстановитьПараметр("ДатаОст",КонецДня(ЭтотОБъект.Дата));    
        запрос.УстановитьПараметр("выбСписСклады",вхСклад);
        
        Если вхНоменклатура.ЭтоГРуппа Тогда
        запрос.УстановитьПараметр("Номенклатура",ТЗНоменклатура);        
        Иначе
        запрос.УстановитьПараметр("Номенклатура",вхНоменклатура);        
        КонецЕсли;
                                          
        КолОстаток=запрос.Выполнить().Выбрать();

        Если КолОстаток.Количество()=0 Тогда
             Возврат 0;
        Иначе
             Пока КолОстаток.Следующий() Цикл   
                  Возврат  КолОстаток.КоличествоОстаток; 
                    //сообщить(КолОстаток.КоличествоОстаток);

             КонецЦикла;                
      КонецЕсли;


Возвращает остаток только первого элемента в группе
 
 
   antihacker
 
1 - 28.02.18 - 06:43
Ой подправил

ТЗНоменклатура = Новый ТаблицаЗначений;
ТЗНоменклатура = Запрос.Выполнить().Выгрузить();
   МимохожийОднако
 
2 - 28.02.18 - 07:02
(1) Потому что Возврат выбрасывает тебя из цикла сразу


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует