Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Табличный документ в веб-клиенте

Табличный документ в веб-клиенте
Я
   Kindman
 
27.02.18 - 15:53
Доброго времени суток! При вызове метода "Показать()" табличного документа в режиме веб-клиента появляется ошибка "Процедура или функция с указанным именем не определена (StrSplit)". Не подскажете, в чём может быть дело? Спасибо
 
 
   ejikbeznojek
 
1 - 27.02.18 - 16:15
Пакеж код))
   tesseract
 
2 - 27.02.18 - 16:27
А плагин от 1С стоит в браузере?
   ejikbeznojek
 
3 - 27.02.18 - 16:27
(0) И протесть на копии не исчезнет ли ошибка, если режим совместимости уберёшь.
   Kindman
 
4 - 27.02.18 - 16:42
&НаКлиенте
Процедура ПечатьСкладскойБирки(Команда)
    
    ЭлементСписка = Элементы.СписокРасширенныйПоискНоменклатура.ТекущаяСтрока;
    
    Структура = Новый Структура;
    Структура.Вставить("Номенклатура", ЭлементСписка);
    
    Оповещение = Новый ОписаниеОповещения("ОткрытьФормуПечатиСкладскихБирокЗавершение", ЭтотОбъект);
    ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаПечатиСкладскихБирок",Структура,,,,, Оповещение);

КонецПроцедуры

&НаКлиенте
Процедура ОткрытьФормуПечатиСкладскихБирокЗавершение(Результат, ДополнительныеПараметры) Экспорт
    Если ТипЗнч(Результат) = Тип("Структура") Тогда
        П = Результат;
        //если не пустой табличный документ

        Если П.ТабДок.Области.Количество()>0 Тогда
            П.ТабДок.Показать();        
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

//модуль формы ФормаПечатиСкладскихБирок для некоторых настроек печати

//здесь есть кнопка печать, по которой формируется табдок
&НаКлиенте
Процедура Печать(Команда)
    
    Если ТранспортныеУпаковки.Количество() <> 0 И А4 = Истина Тогда
        Если (ПроверитьВыборТранспортнойУпаковки() = Ложь) Тогда
            Сообщить("Не выбрана транспортная упаковка для печати!!!");
            Возврат;
        КонецЕсли;
    //если нет транспортной упаковки, тогда нули по весу и объему    

    Иначе    
        
    КонецЕсли;
    
    
    
    Если ПотребительскиеУпаковки.Количество() <> 0 И А4 = Истина Тогда
        Если (ПроверитьВыборПотребительскойУпаковки() = Ложь) Тогда
            Сообщить("Не выбрана потребительская упаковка для печати!!!");
            Возврат;
        КонецЕсли;
    //если нет потребительской упаковки, тогда нулевой штрихкод    

    Иначе    
        
    КонецЕсли;

    //потребительская тема!!!

    Отбор = Новый Структура("Печать", Истина);
    МассивПотреб = ПотребительскиеУпаковки.НайтиСтроки(Отбор); 
    //выше проверено на то, чтобы галка стояла, поэтому, если не найдено, то это признак, что вообще нет потребительской упаковки

    //в этом случае нулевой штрихкод посылаем;

    Штрихкод = "";
    Если МассивПотреб.Количество() = 0 Тогда
        Штрихкод = 0;    
    Иначе    
        //здесь будет только один отмеченный элемент

        Штрихкод = МассивПотреб[0].Штрихкод;
    КонецЕсли;
    
    //транспортная тема!!!

    Отбор = Новый Структура("Печать", Истина);
    МассивТрансп = ТранспортныеУпаковки.НайтиСтроки(Отбор); 
    СсылкаТранспУп = ПолучитьПустуюСсылкуУпаковки();
    //выше проверено на то, чтобы галка стояла, поэтому, если не найдено, то это признак, что вообще нет транспортной упаковки

    //в этом случае пустую ссылку посылаем;

    Если МассивТрансп.Количество() = 0 Тогда
        
    Иначе    
        СсылкаТранспУп = МассивТрансп[0].Ссылка;     
    КонецЕсли;
    
    
    
    
    
    ТабДок = ПечатьНаСервере(Номенклатура, Штрихкод, СсылкаТранспУп);
    
    //ТабДок.Показать();

    Структура = Новый Структура;
    Структура.Вставить("ТабДок", ТабДок);
    Закрыть(Структура);
КонецПроцедуры (1)
   Kindman
 
5 - 27.02.18 - 16:42
Плагин стоит
   ejikbeznojek
 
6 - 28.02.18 - 13:48
(4) А точно П.ТабДок это табличный документ?
   Tekkonkinkreet
 
7 - 06.03.18 - 14:52
(0) Добрый день, точно такая же проблема после обновления платформы. У вас получилось решить?
   tesseract
 
8 - 07.03.18 - 01:19
Не возникает такой. Используем Firefox + принудительная чистка кэша браузера.


Функция "ПечатьНаСервере" Случайно не содержит функции СтрРазделить?

И зачем на клиента ТабДок в структуру вставлять не совсем понятно.
   Tekkonkinkreet
 
9 - 07.03.18 - 20:20
(8) у меня ошибка возникает на строке ТабДок.Показать(), думаю у автора темы также, функции СтрРазделить нигде нет(
   Cyberhawk
 
10 - 07.03.18 - 20:23
Двухмесячный баян 8.3.11.2867
 
 Рекламное место пустует
   Cyberhawk
 
11 - 07.03.18 - 20:25
Даже 3-4-месячный. Или режим совместимости 8.3.6+ ставь у конфы, или добавляй в модуль УП пару функций (StrSplit и StrFind)
   Tekkonkinkreet
 
12 - 09.03.18 - 21:09
(11) Спасибо, а так не хотелось назад откатываться(
   Cyberhawk
 
13 - 09.03.18 - 21:15
(12) Видимо, ты не прочитал до конца или не осилил сказанное мною, раз собираешься "откатываться"
   Tekkonkinkreet
 
14 - 10.03.18 - 22:25
(13) с режимом совместимости вариант мне не подходит, а вот насчет добавления функций действительно неясно, где взять сам код этих функций или просто добавить их номинально?
   Cyberhawk
 
15 - 11.03.18 - 10:20
(14) В модуль УП (и ОП, если используется такой режим запуска):

Функция StrSplit(ИсходнаяСтрока, Разделитель) Экспорт
    Возврат ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(ИсходнаяСтрока, Разделитель);
КонецФункции

Функция StrFind(ИсходнаяСтрока, ПодстрокаПоиска) Экспорт
    Возврат Найти(ИсходнаяСтрока, ПодстрокаПоиска);
КонецФункции
   Tekkonkinkreet
 
16 - 12.03.18 - 10:54
(15) спасибо! часть документов выводится теперь, а часть нет просо пустой табдок. Буду все равно возвращать прежнюю платформу, т.к. вылезло еще несколько проблем(

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует