Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

запрет изменения реквизитов в табличной части

запрет изменения реквизитов в табличной части
Я
   _barracuda_
 
27.02.18 - 14:40
добры день подскажите как можно запретить приоткрытии() изменять реквизиты ТЧ но при этом пользоватьтся скролиногм ТЧ
    Для каждого Элемент Из ЭтаФорма.ЭлементыФормы.Товары цикл 
                Элемент.Доступность= Ложь    
КонецЦикла;
так ругается на итератор
 
 
   бомболюк
 
1 - 27.02.18 - 14:42
ЭлементыФормы.Товары.толькоПросмотр = Истина;
   _barracuda_
 
2 - 27.02.18 - 14:45
(1)при таком раскладе скролинг не пашет
   Cool_Profi
 
3 - 27.02.18 - 14:48
Для каждого Элемент Из ЭтаФорма.ЭлементыФормы.Товары.Колонки цикл

?
   _barracuda_
 
4 - 27.02.18 - 14:53
Для каждого Элемент Из ЭтаФорма.ЭлементыФормы.Товары.Колонки цикл 
            Элемент.Доступность = ложь;
КонецЦикла;

все равно не пашет скролинг внизу
   МимохожийОднако
 
5 - 27.02.18 - 15:00
(4) Зачем тебе скроллинг,если не можешь изменить?
   Михаил Козлов
 
6 - 27.02.18 - 15:03
Свойство табличного поля, что-то вроде ИзменятьСоставСтрок.
   _barracuda_
 
7 - 27.02.18 - 15:05
(5) ну надо чтобы можно было смотреть таблицу она очень широкая колонок немеряно
   Optan
 
8 - 27.02.18 - 15:13
(0)
Для каждого Элемент Из ЭтаФорма.Элементы.РасчетСреднего.ПодчиненныеЭлементы Цикл
        Элемент.ТолькоПросмотр=Истина;
КонецЦикла; 

   Optan
 
9 - 27.02.18 - 15:20
(8) Тьфу ты это для УФ. Но для обычных у меня тоже так работает со скроллингом
[1C]
Для каждого Колонка Из ЭлементыФормы.ТабличноеПоле1.Колонки Цикл
Колонка.ТолькоПросмотр=Истина;
КонецЦикла
[\1C]
   Вафель
 
10 - 27.02.18 - 15:21
(2) ты не прав. Ты путаешь просмотр и доступность
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует