Вход | Регистрация


Порт подключения к серверу 1С

Порт подключения к серверу 1С
Я
   Slon747
 
27.02.18 - 13:57
Из-за конфликта портов изменил порты сервера и кластеров.
Но теперь приходится у всех пользователей в окне запуска 1с прописывать порт.
Можно ли где-то его указать глобально?
Пользователи работают через терминал.
 
 
   Cool_Profi
 
1 - 27.02.18 - 14:02
Можно. В настройке сервера вернуться с дефолтному.
Ну, или создать список бщих баз, который раздать всем через файл-ресурс. А в нём уже один раз прописать
   Slon747
 
2 - 27.02.18 - 14:03
(1) Я от дефолтного ушел из-за конфликта!
   vde69
 
3 - 27.02.18 - 14:10
я для каждого пользователя генерю отдельные файлы, очень удобно, не надо парится вообще ни с подключением, ни с групповым переносом, ни с очисткой кешп (у всех каталог базы одинаковый)
   vde69
 
4 - 27.02.18 - 14:10
//ВызватьИсключение "заблокировано"


Сообщить("=== " + ИнформационнаяБаза.Наименование + " ===");

мПуть_v8i = "\1c-holding\e$\1c\bases\new\";// это клиентский путь

мПуть_v8i = "E:\1c\bases\new\";// это серверный путь


Попытка

мСтрокаID = "ID=" + ИнформационнаяБаза.УникальныйИдентификатор();
мПользователи = глБазаКонтекста.ПользователиИнформационнойБазы.ПолучитьПользователей();
Для Каждого ПользовательИБ из мПользователи Цикл 
    ОшибкаТекущегоПользователя = "";
    
    Если ПользовательИБ.АутентификацияОС = Ложь Тогда
        Продолжить;
    КонецЕсли;
    
    мСтрокаПользователя = Сред(СокрЛП(ПользовательИБ.ПользовательОС),3);
    мИмяДомена = Лев(мСтрокаПользователя, СтрНайти(мСтрокаПользователя, "\")-1);
    мИмяПользователя = Сред(мСтрокаПользователя, СтрНайти(мСтрокаПользователя, "\")+1);
    мИмяФайла = мПуть_v8i + мИмяПользователя + "@" + мИмяДомена + ".v8i";
    мИмяФайла2 = мПуть_v8i + мИмяПользователя + "@" + мИмяДомена + ".cfg";

    //-------------------------------------------------

    мФайлНастроекПользователя2 = Новый Файл(мИмяФайла2);
    Если не мФайлНастроекПользователя2.Существует() Тогда 
        мТекст2 = Новый ТекстовыйДокумент;
        мТекст2.ДобавитьСтроку("");
        мТекст2.ДобавитьСтроку("CommonInfoBases=\1c-holding\1c\bases\" + мИмяПользователя + "@" + мИмяДомена + ".v8i");
        мТекст2.ДобавитьСтроку("");
        мТекст2.Записать(мИмяФайла2, "UTF-16");
    КонецЕсли;
    
    //-------------------------------------------------

    // имя файла определили, если будут косяки - пусть они будут видны в каталоге сборки файлов...    

    Сообщить(мИмяФайла);
    
    мФайлНастроекПользователя = Новый Файл(мИмяФайла);
    мТекст = Новый ТекстовыйДокумент;
    Если мФайлНастроекПользователя.Существует() Тогда 
        мТекст.Прочитать(мИмяФайла);
        мПоиска = мТекст.ПолучитьТекст();
        Если Найти(мПоиска, мСтрокаID)>0 Тогда
            Продолжить; 
        КонецЕсли;
    КонецЕсли;

    мТекст.ДобавитьСтроку("["+СокрЛП(ИнформационнаяБаза)+"]");
    мТекст.ДобавитьСтроку("Connect=Srvr=""" + ИнформационнаяБаза.СерверИБ + """;Ref="""+ИнформационнаяБаза.ИмяКаталогИБ+"""");
    мТекст.ДобавитьСтроку("ID=" + ИнформационнаяБаза.УникальныйИдентификатор());
    мТекст.ДобавитьСтроку("OrderInList=16640");
    мТекст.ДобавитьСтроку("Folder=/");
    мТекст.ДобавитьСтроку("ClientConnectionSpeed=Normal");
    мТекст.ДобавитьСтроку("WA=1");
    мТекст.ДобавитьСтроку("App=Auto");
    мТекст.ДобавитьСтроку("Version=8.3");
    мТекст.ДобавитьСтроку("");
    
    мТекст.Записать(мИмяФайла);
    
КонецЦикла;

Исключение
    Сообщить(ОписаниеОшибки());
КонецПопытки;
   Джексон
 
5 - 27.02.18 - 14:10
(2) Будь мужиком! Уничтожь того, кто конфликтует с твоей няшкой!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует