Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Формы Основная и дополнительная

Формы Основная и дополнительная
Я
   alik-ZmeY
 
27.02.18 - 10:28
8.3.10 обычная. Есть справочник физ лица. По умолчанию (основными) созданы формаСписка и формаЭлемента которые и открываются (из ФормыСписка открывается ФормаЭлемента) Пришла мысль сделать еще Две формы ФормаСписка1 и ФормаЭлемента1. Нужно что бы из ФормаСписка1 открывался ФормаЭлемента1 но не изменяя формы по умолчанию. Как такое можно реализовать в коде 1с.
открываю ФормуСписка1
Справочники.ФизическиеЛица.ПолучитьФорму("ФормаСписка1").Открыть();
 
 
   nordbox
 
1 - 27.02.18 - 10:30
Фиг тебе ))) (шучу)
Делай Дополнительные формы Произвольные и открывай сколько хочешь ))
   nordbox
 
2 - 27.02.18 - 10:32
Ну или сделай Обработку выбора и открывай что хочешь и как хочешь
   alik-ZmeY
 
3 - 27.02.18 - 10:47
Может есть примерчик с доп формами?
   alik-ZmeY
 
4 - 27.02.18 - 10:50
Я пробую так
Процедура СправочникСписокПередНачаломИзменения(Элемент, Отказ)
    Сообщить("нач измен");
Отказ=истина;
СсылкаНаЭлементСправочника = Элемент.текущаяСтрока.Ссылка;
ПараметрыФормы = Новый Структура("Ключ", СсылкаНаЭлементСправочника);
ОткрытьФорму(Справочники.ФизическиеЛица.ПолучитьФорму("Справочник.физическиеЛица.ФормаОбъекта", ПараметрыФормы); 

КонецПроцедуры

но уперся в ФормаОбъекта а мне нужна другая форма а не по умолчанию
   nordbox
 
5 - 27.02.18 - 10:53
"Поскольку времени не много, я просто матом объясню" 
)) 

У тебя обычные формы, создай форму списка,
Нажми на ней, в правой стороне в свойствах найди Обработка Выбора
Процедура СправочникСписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    // Вставить содержимое обработчика.

КонецПроцедуры

Далее извращайся как хочешь
   nordbox
 
6 - 27.02.18 - 10:54
Пишешь
СтандартнаяОбработка=Ложь;
Далее открывай что тебе надо
   alik-ZmeY
 
7 - 27.02.18 - 10:58
Процедура СправочникСписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СтандартнаяОбработка=ложь;
        Сообщить("обр выбора");

КонецПроцедуры

Даже сообщение не выводит и форму по умолчанию открывает (
   alik-ZmeY
 
8 - 27.02.18 - 10:59
А где можно про доп формы почитать (которые есть при создании форм в конфигураторе, там есть вкладка доп формы и основные формы). Что то я про их нигде не нашел (
   nordbox
 
9 - 27.02.18 - 11:01
А ты ту форму списка открываешь?
   alik-ZmeY
 
10 - 27.02.18 - 11:04
Да
 
 Рекламное место пустует
   alik-ZmeY
 
11 - 27.02.18 - 11:05
Сделал так вроде работает но кажется мне что как то можно правильнее сделать(
Процедура СправочникСписокПередНачаломИзменения(Элемент, Отказ)
    Сообщить("нач измен");
Отказ=истина;
СсылкаНаЭлементСправочника = Элемент.текущаяСтрока.Ссылка;
ОбъектСпр=СсылкаНаЭлементСправочника.получитьОбъект();
ОбъектСпр.ПолучитьФорму("ФормаЭлемента1").Открыть();

КонецПроцедуры
   alik-ZmeY
 
12 - 27.02.18 - 11:09
то же самое вешаем на 
Процедура СправочникСписокПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, ЭтоГруппа)
Отказ=истина;
СсылкаНаЭлементСправочника = Элемент.текущаяСтрока.Ссылка;
ОбъектСпр=СсылкаНаЭлементСправочника.получитьОбъект();
ОбъектСпр.ПолучитьФорму("ФормаЭлементаМО").Открыть();

КонецПроцедуры

нужно еще обработать копирование наверное
   Cyberhawk
 
13 - 27.02.18 - 11:11
Кончай быдлокодить уже с "ПолучитьФорму", делай "ОткрытьФорму"
   alik-ZmeY
 
14 - 27.02.18 - 11:18
ОткрытьФорму("Справочник.физическиеЛица.ФормаОбъекта", ПараметрыФормы); 
Как вместо ФормаОбъекта открыть нужную мне форму элемента??
   alik-ZmeY
 
15 - 27.02.18 - 11:20
И почему ПолучитьФорму -быдлокод??
   mehfk
 
16 - 27.02.18 - 11:24
ОткрытьФорму("Справочник.физическиеЛица.Форма.ФормаМояФормаЧтоТоТам");
   alik-ZmeY
 
17 - 27.02.18 - 11:29
ок спс буду знать
   Cyberhawk
 
18 - 27.02.18 - 11:57

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует