Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1с 8.3 управляемые формы. Окрашивание строк по условию при выводе макета

1с 8.3 управляемые формы. Окрашивание строк по условию при выводе макета
Я
   illiona
 
26.02.18 - 09:31
Добрый день. Как окрасить строки только по условию. Закрашивает всю таблицу
Для Каждого Стр из Затраты Цикл
    ОбластьСтрока.Параметры.Затрата = Стр.Статья;
    ОбластьСтрока.Параметры.СуммаЗатраты = Стр.Сумма;
        
    Отбор = новый Структура;
    Отбор.Вставить("Наименование",Стр.Статья);
    НайденныеСтроки = ТаблицаГрупп.НайтиСтроки(Отбор);
            
    Если Не НайденныеСтроки.Количество() = 0 тогда
//    ОбластьСтрока.Область(1, 1, 1, 2).ЦветФона = WebЦвета.СеребристоСерый;

    КонецЕсли;
    ТабДок.Вывести(ОбластьСтрока);
    
КонецЦикла;
 
 
   a_alenkin
 
1 - 26.02.18 - 10:08
Сделать счетчик и после вывода 
получать область в ТабДок и закрашивать уже ее
   illiona
 
2 - 26.02.18 - 10:25
а можно подробнее)?
Если Не НайденныеСтроки.Количество() = 0 тогда
    Если СокрЛП(НайденныеСтроки[0].Наименование) = СокрЛП(Стр.Статья)  тогда
                ОбластьСтрока.Область(1, 1, 1, 2).ЦветФона = WebЦвета.СеребристоСерый;
    КонецЕсли;
КонецЕсли;
Это условие
   СвинТуз
 
3 - 26.02.18 - 10:29
Могу ошибиться.

мОбласть=ТабДок.Вывести(ОбластьСтрока);
Если УсловиеВыполнено Тогда
    мОбласть..ЦветФона = WebЦвета.СеребристоСерый;
КонецЕсли;
   СвинТуз
 
4 - 26.02.18 - 10:30
Две точки.
Одна ошибка уже есть
   a_alenkin
 
5 - 26.02.18 - 10:33
Счетчик = ...// тут номер первой строки - явно сначала выводится шапка


Для Каждого Стр из Затраты Цикл
    ОбластьСтрока.Параметры.Затрата = Стр.Статья;
    ОбластьСтрока.Параметры.СуммаЗатраты = Стр.Сумма;
        
    Отбор = новый Структура;
    Отбор.Вставить("Наименование",Стр.Статья);

    ТабДок.Вывести(ОбластьСтрока);
    
    НайденныеСтроки = ТаблицаГрупп.НайтиСтроки(Отбор);
    Если СокрЛП(НайденныеСтроки[0].Наименование) = СокрЛП(Стр.Статья)  тогда
        ОбластьРаскраски = ТабДок.ПолучитьОбласть(Счетчик, 1, Счетчик, 2);
        ОбластьРаскраски.ЦветФона = WebЦвета.СеребристоСерый;
    КонецЕсли;
    
    Счетчик = Счетчик+1;
    
КонецЦикла;
   illiona
 
6 - 26.02.18 - 10:35
Выводит по условию, но у меня два столбца, а закрашивает строку и все столбцы
   СвинТуз
 
7 - 26.02.18 - 10:42
(6)
Можно имя назначить. А можно по стобцам считать.
   Тихий омут
 
8 - 26.02.18 - 10:44
(6) в этой строке
ОбластьРаскраски = ТабДок.ПолучитьОбласть(Счетчик, 1, Счетчик, 2);

напиши 

"ТабДок.Область(Счетчик" и т.д.
   a_alenkin
 
9 - 26.02.18 - 10:45
", а закрашивает строку и все столбцы"

не может быть

       ОбластьРаскраски = ТабДок.ПолучитьОбласть(Счетчик, 1, Счетчик, 2);
 
получаются столбцы с 1 по 2
   ptiz
 
10 - 26.02.18 - 10:47
(0) А возвращать обычный цвет фона при НЕвыполнении условия Пушкин будет?
 
 Рекламное место пустует
   illiona
 
11 - 26.02.18 - 10:57
a_alenkin, ошибка Поле объекта не обнаружено (ЦветФона)
   Тихий омут
 
12 - 26.02.18 - 10:59
(11) - Доктор, меня все игнорируют.
- Следующий...
:) Обрати внимание на (8). Или тоже не работает?
   illiona
 
13 - 26.02.18 - 11:04
Тихий омут, Спасибо!
a_alenkin, Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует