Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Вывод реквизитов в макет

v7: Вывод реквизитов в макет
Я
   vasant
 
23.02.18 - 15:40
Пытаюсь вывести в печатный макет реквизиты кодом ниже. Есть шаблон с колонкой и секциями Группа (содержит <Сч.Код> ) и Строка (содержит <Сч.Код> ) и Шапка.

При исполнении видно, что обходятся все счета, но <Сч.Код> не заменятся на значения, остается в виде кода поля (т.е. выводится "<Сч.Код>"). Что не так?

Процедура Печать()
  Сч=СоздатьОбъект("Счет");
// Создаем в памяти экземпляр объекта "Счет"

  Сч.ИспользоватьПланСчетов(ИспользоватьПланСчетов());
// Указываем, что будем использовать тот план счетов, который является

// текущим в открытом списке счетов
  Таб=СоздатьОбъект("Таблица");
  Таб.ИсходнаяТаблица("Таблица");
  Таб.ВывестиСекцию("Шапка");
  Сч.ВыбратьСчета();
// Открываем подборку со списком счетов в текущем плане счетов

  Пока Сч.ПолучитьСчет()=1 Цикл
    Если Сч.ЭтоГруппа()=1 Тогда
// Это счет либо субсчет, содержащий субсчета

      Таб.ВывестиСекцию("Группа");
    Иначе
// Это счет не содержащий субсчетов, либо это субсчет самого нижнего уровня

      Таб.ВывестиСекцию("Строка");
    КонецЕсли;
  КонецЦикла;
  Таб.ТолькоПросмотр(1);
  Таб.ПараметрыСтраницы(2,,1,,,,,,,1,,);
// ориентация "Ландшафт"

  Таб.Показать("План счетов");
КонецПроцедуры
 
 
   vasant
 
1 - 23.02.18 - 15:54
Платформа стоит в VirtualBox Win2003. Может не распознаются корректно угловые скобки?
   Изучаю1С8
 
2 - 23.02.18 - 15:55
А если на выражение поменять в макете, то работает?
   vasant
 
3 - 23.02.18 - 16:01
(2) Да )

Спасибо
   73с
 
4 - 23.02.18 - 19:04
А тип ячейки точно Шаблон?
   MWWRuza
 
5 - 24.02.18 - 17:26
Если это шаблон, то почему скобки не квадратные "Чего-то там [СокрЛП(Сч.Код)]"
   vasant
 
6 - 28.02.18 - 12:21
(4) (5) Действительно, не указал тип поля. Думал здесь как в HTML, самому нужно указывать тэги (в этом случае "<>"). Все закрутилось, после укзания типа яйчейки "выражение".

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует