Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Убрать пробелы с правой части строки

Убрать пробелы с правой части строки
Я
   НАТалья Голубева
 
22.02.18 - 16:09
Здравствуйте, помогите пож.. убрать пробелы с правой части строки... но почему то не удаляются ... вот код... вроде как должно быть просто..но никак..


Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.

Запрос = Новый Запрос;
Запрос.Текст=
    
"ВЫБРАТЬ
|    Номенклатура.АртПоставщика КАК Арт,
|    Номенклатура.Ссылка КАК Номенклатура,
|    Номенклатура.Артикул
|ИЗ
|    Справочник.Номенклатура КАК Номенклатура";    
Результат = Запрос.Выполнить();
ТЗ=Результат.Выгрузить();
    ВыборкаДетальныеЗаписи = ТЗ.ВыбратьСтроку();
    ВыборкаДетальныеЗаписи=Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Строка=ВыборкаДетальныеЗаписи.Арт;
            Арт = СокрЛП(Строка);
    КонецЦикла;

    
КонецПроцедуры
 
 
   piter3
 
1 - 22.02.18 - 16:09
Может Стрзаменить все-таки
   НАТалья Голубева
 
2 - 22.02.18 - 16:10
пробовала тоже не работает
   piter3
 
3 - 22.02.18 - 16:10
показывай
   НАТалья Голубева
 
4 - 22.02.18 - 16:10
Арт=СтрЗаменить(Строка,Символ(160),"");
   НАТалья Голубева
 
5 - 22.02.18 - 16:11
Арт=СтрЗаменить(Строка,"",""); и так пробовала
   piter3
 
6 - 22.02.18 - 16:13
СтрЗаменить(МояСтрока,Символы.НПП,"");
   НАТалья Голубева
 
7 - 22.02.18 - 16:14
не помогло
   piter3
 
8 - 22.02.18 - 16:14
циклом посмотри коды символа
   sixis
 
9 - 22.02.18 - 16:16
Может быть "Арт" это реквизит с фиксированной длинной?
   НАТалья Голубева
 
10 - 22.02.18 - 16:26
Через отладчик показал:
выражение- "113879 " ...
тип-строка
 
 Рекламное место пустует
   НАТалья Голубева
 
11 - 22.02.18 - 16:27
длина кода в справочнике .. посмотрела -11
   НАТалья Голубева
 
12 - 22.02.18 - 16:27
как раз они 11 и есть ... как мне лучше убрать?
   drcrasher
 
13 - 22.02.18 - 16:28
(9) и что? строка и в африке строка.
(0) кодсимвола(Прав(арт,1)) чему равен?
   hhhh
 
14 - 22.02.18 - 16:29
(12) СокрЛП(СтрЗаменить(
   НАТалья Голубева
 
15 - 22.02.18 - 16:30
Направление поняла... час попробую проработть...
   sixis
 
16 - 22.02.18 - 16:42
   НАТалья Голубева
 
17 - 22.02.18 - 16:52
sixis-пробовала не получается...
пока мучаюсь
   sixis
 
18 - 22.02.18 - 16:56
обработку выложи
   НАТалья Голубева
 
19 - 22.02.18 - 17:00
Получилось.. код то простой...а мучилась

Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.

Запрос = Новый Запрос;
Запрос.Текст=
    
"ВЫБРАТЬ
|    Номенклатура.АртПоставщика КАК Арт,
|    Номенклатура.Ссылка КАК Номенклатура,
|    Номенклатура.Артикул
|ИЗ
|    Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|    Номенклатура.Ссылка = &Ном"    ;

Запрос.УстановитьПараметр("Ном",АртПоставщика);

Результат = Запрос.Выполнить();
ТЗ=Результат.Выгрузить();
    ВыборкаДетальныеЗаписи = ТЗ.ВыбратьСтроку();
    ВыборкаДетальныеЗаписи=Результат.Выбрать();
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Строка=ВыборкаДетальныеЗаписи.Арт;
            Арт=СокрЛП(СтрЗаменить(Строка, "", "") );
    КонецЦикла;

    
КонецПроцедуры
   НАТалья Голубева
 
20 - 22.02.18 - 17:00
сп. за подсказки
   НАТалья Голубева
 
21 - 22.02.18 - 17:00
когда дружно быстрее получается
   Михаил Козлов
 
22 - 22.02.18 - 17:25
(21) А зачем Вы сначала выгружаете в ТЗ, потом выбираете из результата запроса?
Да и смысл в СтрЗаменить(Строка, "", "") как-то не проглядывается.
Если у реквизита АртПоставщика длина переменная, правый пробелов в поле результата запроса быть, вроде как, не должно.
   drcrasher
 
23 - 22.02.18 - 17:30
(22) стрЗаменить мне тоже не понятно, у неё ТЗ в форме с фиксированной длиной
   Михаил Козлов
 
24 - 22.02.18 - 17:34
(23) Ответа на (9) не было.
   НАТалья Голубева
 
25 - 22.02.18 - 17:43
Михаил Козлов-да не должно .. но они у меня загружаются с екселевской таблицы... а у разных поставщиков артикулы разные...
   НАТалья Голубева
 
26 - 22.02.18 - 17:45
Ответа на (9) не было.-я так понимаю это будет если брать 15326758-то это 8
   НАТалья Голубева
 
27 - 22.02.18 - 17:46
Так?
   drcrasher
 
28 - 22.02.18 - 17:46
(24) прикалываешься? на скрине же стоит "фикс"
   drcrasher
 
29 - 22.02.18 - 17:48
(26) да.
но уже не нужно. арт всегда будет 8 символов, ты его так завела.
   НАТалья Голубева
 
30 - 22.02.18 - 17:49
(24)да вроде не очень хорошо получается... час буду смотреть..
последняя загрузка с екселевской таблицы запутала меня...
   Mankubus
 
31 - 22.02.18 - 19:54
(19)
>>ТЗ=Результат.Выгрузить();
>>ВыборкаДетальныеЗаписи = ТЗ.ВыбратьСтроку();
Выкинь это, не позорься
   4YOU
 
32 - 23.02.18 - 11:58
оо, хоть тут нашла решение своей проблемы)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует