Вход | Регистрация



Как получить код по КОМ Соединению?

Как получить код по КОМ Соединению?
Я
   Tarlich
 
22.02.18 - 15:22
Делаю свой перенос из УТ 11 по КОМ соединению 

На определенном этапе делаю загрузку номенклатуры , поиск делаю по коду, не сразу понял что что то не то с кодом и он позадваивал мне (но эт исправлю)
А именно (Точка останова) :
смотрю : Товар.Родитель.Код = "00-00000179" а товар Код = "      " 
что не так делаю ?
 
 
   ejikbeznojek
 
1 - 22.02.18 - 15:27
(0) Код в студию!
   Tarlich
 
2 - 22.02.18 - 15:30
То же самое и с контрагентами :
КонтрагентУТ.ИНН = "5032262329" а
КонтрагентУТ.Код = ""  как так ?
   Tarlich
 
3 - 22.02.18 - 15:32
код детский то :

Контрагенты = Справочники.Контрагенты;
    Контрагент = "";
    Контрагент = Контрагенты.НайтиПоКоду(КонтрагентУТ.Код);
    Если Не ЗначениеЗаполнено(Контрагент) Тогда
        Контрагент = Контрагенты.НайтиПоНаименованию(КонтрагентУТ.Наименование, Истина);

        Если Не ЗначениеЗаполнено(Контрагент) Тогда

            Если ЗначениеЗаполнено(КонтрагентУТ.ИНН) Тогда
                Контрагент = Контрагенты.НайтиПоРеквизиту("ИНН", КонтрагентУТ.ИНН);
            КонецЕсли;
   Tarlich
 
4 - 22.02.18 - 15:33
Если ЗначениеЗаполнено(Товар.Родитель.Код) Тогда
        Родитель = Справочники.Номенклатура.НайтиПоКоду(Товар.Родитель.Код);
        Если Родитель.Пустая() Тогда
            Родитель = СоздатьРодителя(Товар.Родитель);
        КонецЕсли;
    Иначе
        Родитель = Справочники.Номенклатура.ПустаяСсылка();
    КонецЕсли;
   Tarlich
 
5 - 22.02.18 - 15:34
в УТ 10,3 код работает....
   Tatitutu
 
6 - 22.02.18 - 15:40
что то в коде не хватает и код не "детский"

1.Если Не ЗначениеЗаполнено(Контрагент) Тогда
2.ЗначениеЗаполнено(Товар.Родитель.Код)
3.Если ЗначениеЗаполнено(КонтрагентУТ.ИНН) Тогда
4.Если Родитель.Пустая() Тогда
   Tarlich
 
7 - 22.02.18 - 15:42
   Franchiser
 
8 - 22.02.18 - 15:44
(7) причем тут это, у некоторых справочников можно целиком отключить станд. реквизит Код.
   Franchiser
 
9 - 22.02.18 - 15:45
Так пробовал: КонтрагентУТ.Code ?
   tndr
 
10 - 22.02.18 - 15:46
Попробуй СокрЛП(КонтрагентУТ.Код)
 
 Рекламное место пустует
   Tarlich
 
11 - 22.02.18 - 15:46
(9) КонтрагентУТ.Code = ""
   Franchiser
 
12 - 22.02.18 - 15:48
(11) у тебя проблема с товарами или контрагентами?
   Tarlich
 
13 - 22.02.18 - 15:53
(12) Оба справочника не могу получить код , а поиск надо делать мне именно по коду ...
   Franchiser
 
14 - 22.02.18 - 15:54
1. Для всех Элементов?
2. Если встать в отладчике на КонтрагентУТ дерево реквизитов можно посмотреть?
Может надо писать Code_ или _Code
   Tarlich
 
15 - 22.02.18 - 15:59
   _Дайвер_
 
16 - 22.02.18 - 15:59
В поиске возврат где? что возвращается?
   Tarlich
 
17 - 22.02.18 - 16:00
   _Дайвер_
 
18 - 22.02.18 - 16:02
(17) В другой базе код есть?
   hhhh
 
19 - 22.02.18 - 16:03
(17) понапились уже все, что ли? Ну нет у контрагентов кода в УТ11. Вопиющая безграмотность.
   Tarlich
 
20 - 22.02.18 - 16:05
(19) я то же это не так давно слышал ... а как искать тогда ? можно ли по ИД?
   DrShad
 
21 - 22.02.18 - 16:05
(20) можно,ну лучше по ИНН + КПП
   Tarlich
 
22 - 22.02.18 - 16:06
так же и с товаром : http://ibb.co/mp7uNc
   Вафель
 
23 - 22.02.18 - 16:06
вместо кода бери УникальныйИдентификатор()
   Tarlich
 
24 - 22.02.18 - 16:06
(21) товар как ?
   Вафель
 
25 - 22.02.18 - 16:06
(21) А если физ лицо?
   Вафель
 
26 - 22.02.18 - 16:06
А если при след выгрузке у контргента уже будет другое КПП?
   Tarlich
 
27 - 22.02.18 - 16:08
(23) Товар.УникальныйИдентификатор() = COMОбъект

получив я разве смогу назначить этот же УД товару в базе приемник ?
   Вафель
 
28 - 22.02.18 - 16:09
КомБаза.String(Товар.УникальныйИдентификатор())
   hhhh
 
29 - 22.02.18 - 16:10
(20) по коду партнера ищите
   Tarlich
 
30 - 22.02.18 - 16:10
(28) не работает  = "COMОбъект"
   DrShad
 
31 - 22.02.18 - 16:10
(27) сможешь, но придется поизвращаться
лучше на КД правила напиши
   adva-li
 
32 - 22.02.18 - 16:11
(31)
Сможешь
   DrShad
 
33 - 22.02.18 - 16:11
(32) я знаю что смогу )))
 
 
   Tarlich
 
34 - 22.02.18 - 16:12
(29) Да ! КонтрагентУТ.Партнер.код = "00-00000002" -((
   DrShad
 
35 - 22.02.18 - 16:16
(34) у одного партнера может быть несколько контрагентов, кроме того в партнерах иерархия элементов )))
   adva-li
 
36 - 22.02.18 - 16:17
(30)
ГУИДОле = Оле.NewObject("УникальныйИдентификатор", Строка(идИзТекущейБазы));
СсылкаОле = Оле.Справочники[мд.Имя].ПолучитьСсылку(ГУИДОле);

Ну и для нового элемента тоже есть возможность назначить идентификатор
   Tarlich
 
37 - 22.02.18 - 16:26
Товар по наименованию не могу т.к есть одинаковый но разный артикул ..
   Tarlich
 
38 - 22.02.18 - 16:37
Смотрю УТ - но у некоторого товара код есть 
http://ibb.co/ddLnax
   trooba
 
39 - 22.02.18 - 17:00
(38) Функция НайтиСсылкуНаЭлементОУпоГУИД(СоединениеСОМ, ТипСправочника, ГУИД)
    
    НовыйGUID = СоединениеСОМ.NewObject("УникальныйИдентификатор", "" + ГУИД);
    СсылкаОУ = СоединениеСОМ.Справочники[ТипСправочника].ПолучитьСсылку(НовыйGUID);
    
    Если СсылкаОУ.Наименование <> "" Тогда
        
        Возврат СсылкаОУ;
        
    Иначе
        
        Возврат СоединениеСОМ.Справочники[ТипСправочника].ПустаяСсылка();
        
    КонецЕсли;

КонецФункции
   Tarlich
 
40 - 22.02.18 - 17:22
я как понимаю что товар в начале был загружен из чего то и по этому у него нет кода : может просто перенумеровать?
   Franchiser
 
41 - 22.02.18 - 18:31
Так сделай: СоединениеСОМ.XMLСтрока(Товар)
   Franchiser
 
42 - 22.02.18 - 18:32
СоединениеСОМ.XMLСтрока(Товар.Ссылка)
   Tarlich
 
43 - 22.02.18 - 18:49
(42) а что потом с этим делать ?
   Franchiser
 
44 - 22.02.18 - 18:56
Это уникальный идентификатор в виде строки, синхронизируй по нему...
   Tarlich
 
45 - 22.02.18 - 19:21
(44) а как его назначить новому элементу в базе приемника ?
   lodger
 
46 - 22.02.18 - 19:27
(45)
СправочникМенеджер.<Имя справочника> (CatalogManager.<Имя справочника>)
ПолучитьСсылку (GetRef)
Синтаксис:

ПолучитьСсылку(<УникальныйИдентификатор>)
Параметры:

<УникальныйИдентификатор> (необязательный)

Тип: УникальныйИдентификатор.
Уникальный идентификатор, из которого будет формироваться ссылка.
Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>.

Описание:

Формирует ссылку из значения типа УникальныйИдентификатор.
Данный уникальный идентификатор может быть в дальнейшем получен из ссылки методом УникальныйИдентификатор.
   Tarlich
 
47 - 22.02.18 - 19:35
(46) не пойму ... как назначить УИ ?
Товар = Справочники.Номенклатура.СоздатьЭлемент();
а дальше ?
   Mankubus
 
48 - 22.02.18 - 19:57
   Franchiser
 
49 - 22.02.18 - 23:40
Новый УникальныйИдентификатор(СтрокаУИД)
 
 Рекламное место пустует


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует