Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Перенос из ТиС 7.7 в 8.3 БП

Перенос из ТиС 7.7 в 8.3 БП
Я
   Tumakota
 
22.02.18 - 13:28
Значение = Лев(Источник.ЮрФизЛицо.ИНН, Найти(Источник.ЮрФизЛицо.ИНН, "/") - 1);

вот так ищб ИНН перед выгрузкой, но серовно не выгружает в 8 и в 7 ошибку не какую не выдает, подскажите что не так прописываю
 
 
   Ц_У
 
1 - 22.02.18 - 13:36
(0) а что должно получиться?
   Tumakota
 
2 - 22.02.18 - 13:37
в 8 в поле ИНН должен загрузится ИНН, но оно остается пустым
   Злопчинский
 
3 - 22.02.18 - 13:37
Овнокод
   Злопчинский
 
4 - 22.02.18 - 13:38
В тис никаких особых проверок на правильность инн нет
   Tumakota
 
5 - 22.02.18 - 13:38
(3) Спасибо за ответ, если овнокод, подскажи другой ане просто комментируй
   Злопчинский
 
6 - 22.02.18 - 13:38
Поэтому в поле заводится как угодно и что угодно
   Злопчинский
 
7 - 22.02.18 - 13:39
(5) используйте функцию из глобального модуля типа
ГлПолучитьИНН
   Tumakota
 
8 - 22.02.18 - 13:39
У меня в ТиС заведено все через этот слэш по которому ищю, все ИНН и КПП заведены так, но он и ошибок при выгрузке не дает и при загрузке не чего вообще не грузит
   Злопчинский
 
9 - 22.02.18 - 13:40
(5) это не снеговик, деточка, тут думать надо ;-) ну и конфигу знать
   Tumakota
 
10 - 22.02.18 - 13:42
(9) Спасибо за совет, знал бы 7 не писал бы здесь
 
 Рекламное место пустует
   Злопчинский
 
11 - 22.02.18 - 13:42
(8) у физиков и ип  - КПП нет
Ты точно у них инн из 12 цифр завершаешь слешем?
   Tumakota
 
12 - 22.02.18 - 13:43
(8) Я выгружаю по 1 контрагенту, где точно все правильно заполнено и 12 после 12 стоит слэш, но он даже по нему не грузит, все загружает кроме ИНН и КПП
   Злопчинский
 
13 - 22.02.18 - 13:43
Если совсем все плохо - впихни перед этим оператором
Сообщить(....инн)
   Злопчинский
 
14 - 22.02.18 - 13:46
Ну и вдогонку диагноз "не выгружает" на мой взгляд не имеет никакого отношения к приведенному коду
Удостоверься что значение вычисляется правильно.
А уже потом переходит к постановке диагноза авгрузки
   Tumakota
 
15 - 22.02.18 - 15:33
Процедура отрабатывает нормально и выводит нужные данные, но когда в КД пишу это то она та не записывает в это поле не чего
   hhhh
 
16 - 22.02.18 - 16:21
(15) модуль выгрузки в обработку записываешь?
   Tumakota
 
17 - 22.02.18 - 16:26
(16) Всмысле, этот код проверил обработкой, написали обработку по контрагенту, вывели он сообщил ИНН, а в КД перед выгрузкой засовываю
   hhhh
 
18 - 22.02.18 - 16:30
(17) ну для семерки, модуль выгрузки из КД копируешь в обработку обмена.
   Tumakota
 
19 - 22.02.18 - 16:51
(18) Ну так написали внешнюю обработку там все работает, выводит в сообщении то что надо строку с ИНН, а в КД не отрабатывает эту процедуру передает пустое значение, проверил на одном контрагенте на котором все заполнено
   Tumakota
 
20 - 22.02.18 - 17:27
Самое интересное и типовой код не отрабатывает из типовых правил
Если Источник.ЭтоГруппа() = 0 Тогда
    Если Найти(Источник.ЮрФизЛицо.ИНН, "\") <> 0 Тогда
        Значение = Лев(Источник.ЮрФизЛицо.ИНН, Найти(Источник.ЮрФизЛицо.ИНН, "\") - 1);
        
    Иначе
        Значение = СокрЛП(Источник.ЮрФизЛицо.ИНН);
        
    КонецЕсли;
Иначе
    Отказ = 1;
    
КонецЕсли;
   Tarlich
 
21 - 22.02.18 - 18:08
как я сделал 
Если (ВидСправочника8 = "Контрагенты") и (Ссылка.ЭтоГруппа() = 0) Тогда
        Если СтрДлина(СокрЛП(Ссылка.ЮрФизЛицо.ИНН)) > 5 Тогда
            
            КонтрагентИНН = "";
            КонтрагентКПП = "";
            
            НомерРазделителяИНН = Найти(Ссылка.ЮрФизЛицо.ИНН,"/");
            Если НомерРазделителяИНН = 0 Тогда
                НомерРазделителяИНН = Найти(Ссылка.ЮрФизЛицо.ИНН,"\");
            КонецЕсли;
            Если НомерРазделителяИНН = 0 Тогда
                КонтрагентИНН = Ссылка.ЮрФизЛицо.ИНН;
            Иначе 
                ИНН77 = СокрЛП(Ссылка.ЮрФизЛицо.ИНН);
                КонтрагентИНН = Лев(ИНН77,НомерРазделителяИНН-1);
                КонтрагентКПП = Прав(ИНН77,СтрДлина(ИНН77)-НомерРазделителяИНН);
            КонецЕсли;
            
            НайденныйЭлемент = Справочники[ВидСправочника8].НайтиПоРеквизиту("ИНН",КонтрагентИНН);
            Если НайденныйЭлемент <> Справочники[ВидСправочника8].ПустаяСсылка() Тогда
                ИскатьПоКоду = Ложь;
                ИскатьПоНаименованию = Ложь;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
   Tumakota
 
22 - 22.02.18 - 19:06
(21) Ваш код тоже не помог, если можете помочь могу дать удаленку
   Злопчинский
 
23 - 22.02.18 - 20:32
То есть вставить отладочные сообщения в нужном месте и нужном контексте исполнения - вообще мозгов не хватает?
   nicxxx
 
24 - 22.02.18 - 21:28
(8) "ч" и "Щ" пишем с буквой "У"


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует