Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Помогите дилетанту разобраться с формулой

Помогите дилетанту разобраться с формулой
Я
   Kent78
 
21.02.18 - 21:33
Помогите разобраться с формулой или подскажите как устанавливать %НДС при автоматическом создании номенклатуры из файла dbf
Пытаюсь вычислить по формуле, но выдает вот такую ошибку.


Ошибка при вычислении выражения Если ТекстЯчейки = "18" Тогда
    Результат = Перечисления.СтавкиНДС.НДС18;
Иначе
Если ТекстЯчейки = "10" Тогда
    Результат = Перечисления.СтавкиНДС.НДС10;
Иначе
Если ТекстЯчейки = "0" Тогда
    Результат = Перечисления.СтавкиНДС.НДС0;
Иначе
    Результат = Перечисления.СтавкиНДС.БезНДС;
КонецЕсли: {ОбщийМодуль.ор_ЗагрузкаИзЭлектронныхДокументовСервер.Модуль(3254)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(11,10)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
 
 
   nordbox
 
1 - 21.02.18 - 21:36
Если ТекстЯчейки = "18" Тогда 
    Результат = Перечисления.СтавкиНДС.НДС18; 
ИначеЕсли ТекстЯчейки = "10" Тогда
    Результат = Перечисления.СтавкиНДС.НДС10;
ИначеЕсли ТекстЯчейки = "0" Тогда
    Результат = Перечисления.СтавкиНДС.НДС0;
Иначе
    Результат = Перечисления.СтавкиНДС.БезНДС; 
КонецЕсли
Между Иначе и Если ничего не должно быть
   АНДР
 
2 - 21.02.18 - 21:36
Иначе - нет,  есть ИначеЕсли
   shpioleg
 
3 - 21.02.18 - 21:40
Чтобы не сделать структуру или соответствие, чтобы не городить лапшу условий.
   Kent78
 
4 - 21.02.18 - 21:48
Спасибо ОГРОМЕЙШЕЕЕ!!!
   Сияющий в темноте
 
5 - 22.02.18 - 09:38
Просто,после конецесли кто то поставил двоеточие,и умная 1с поняла,что это метка для перехода

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует