Вход | Регистрация


1С:Предприятие ::

Метки: 

Соединение с web-сервисом

Я
   Listener
 
21.02.18 - 15:18
Ситуация такая:
есть сервер, на нем стоит сервер 1С, IIS, база опубликована вместе с сервисом. Если из локальной сети заходить через браузер, то выскакивает окно с логином, логинимся и в браузере начинается работа. Но если поключаться через WSОпределения(, то возникает ошибка "Превышено время ожидания".
Это работало, но похоже, что после каких-то действий админов это работать перестало.
Есть у меня подозрение, что порт закрыт. Но 80 открыт, судя по тому, что через html все работает.
Тогда как узнать, через какой порт идет обращение к сервису? Гугл говорит как про стандартные порты 1с, так и про 10000. Чему верить? Куда копать?
 
  Рекламное место пустует
   ber
 
1 - 21.02.18 - 15:31
Обычно пробую добавить в ветку WS ссылки описание веб сервиса, если добавляется проблема в коде если нет, то обычно ошибку выдает.
   Listener
 
2 - 21.02.18 - 15:38
Да, и если из локальной сети в браузере набрать, "http://x.x.x.x/servis/ws/dm.1cws?wsdl";, то выдает содержимое xml.
   ber
 
3 - 21.02.18 - 15:51
Значит проблема в коде, у меня так вызывается:

ssl1 = Новый ЗащищенноеСоединениеOpenSSL(
           Новый СертификатКлиентаWindows(СпособВыбораСертификатаWindows.Авто),
           Новый СертификатыУдостоверяющихЦентровWindows());
           

Определения = Новый WSОпределения("ОписаниеWS",Логин,Пароль,,,ssl1);
   Listener
 
4 - 21.02.18 - 17:36
(3) Нет, соединение у меня незащищенное, поэтому ssl1 у меня Неопределено.

Само интересное вот где:
если запускаю соединение из базы, которая на том же сервере, то все плохо;
если запускаю из локальной файловой, которая находится на моей рабочей станции, то все ОК.
Мистика какая-то :(
   Listener
 
5 - 21.02.18 - 17:56
Скопировал файловую на сервер, запускаю там - не подключается...
Похоже, что на сервере что-то мешает подключаться к своему вебсервису.
   Listener
 
6 - 21.02.18 - 18:00
Продолжаю наблюдение...
На сервере запускаю в браузере строку "http://x.x.x.x/servis";, строка превращается в "http://x.x.x.x/servis/ru_RU/";, запускается стартовое окно 1С и ... ничего. То есть оно к адресу добавляет зачем-то "/ru_RU/".
   Listener
 
7 - 21.02.18 - 18:51
С другой стороны, когда набираешь в браузере на рабочей станции "http://x.x.x.x/servis";, то появление в строке добавки в виде "ru_RU" не мешает - вход благополучно происходит.
   Listener
 
8 - 26.02.18 - 15:24
ап
проблема там и не решилась
пробовал создать новую регистрацию базы, то же самое - застревает на стартовой странице и не дает дальше залогиниться. гугл по теме молчит. Куда дальше копнуть?
   Listener
 
9 - 26.02.18 - 16:38
Готов сформулировать проблему так:
1. если запускать непосредственно на сервере в браузере localhost/имя_сервиса, то появляется стартовая страница 1С и до авторизации не доходит;
2. если на любом компе в локальной сети запускать в браузере сервер/имя_сервиса, то все ОК.
================
- релиз платформы 8.3.8.2027
- сервер windows server 2008 r2
- IIS стандартный из комплекта
- антивирусов на сервере нет, брандмауэр отключен
- перерегистрацию базы делал. под разными именами. не помогает.
================
попробовать поставить апач и опубликовать через него?
   Listener
 
10 - 26.02.18 - 19:02
Попробовал установить апач. Все то же самое - окно заставки появляется и никакого логина с паролем :(
 
 
   Listener
 
11 - 26.02.18 - 22:56
теме ап
   Cyberhawk
 
12 - 26.02.18 - 23:06
Сколько платят за решение вопроса?
   Listener
 
13 - 26.02.18 - 23:10
Нисколько, это мой новый клиент на абонентке. И сразу началось с такой проблемы.
   Cyberhawk
 
14 - 26.02.18 - 23:17
(13) Ну, сколько абонентка и что в нее входит?
   Listener
 
15 - 26.02.18 - 23:21
Продолжаю.
Замена платформы на 8.3.11 ничего не дала. То же самое.
   Listener
 
16 - 26.02.18 - 23:22
(14) сопровождение 1С.
   Listener
 
17 - 26.02.18 - 23:27
+(16) платят копейку, меня просто само явление заинтересовало. Не припомню, чтобы передо мной возникла проблема с 1с и я не смог её победить. Я не привык сдаваться.
   Джексон
 
18 - 27.02.18 - 08:36
(17) Продолжайте докладывать каждые четыре часа. По необходимости - меняйте позицию.
   Cyberhawk
 
19 - 27.02.18 - 09:08
Ну ты даешь - мыкаться за копейку )
   hhhh
 
20 - 27.02.18 - 09:34
(17) ну, отладчиком пройдись
   Listener
 
21 - 27.02.18 - 14:37
(20) Прошелся бы, но до модуля сеанса дело не доходит ввиду того, что не дошло даже до авторизации. Повторюсь, что если вызывать подключение через браузер на другом компе, то доходит и до авторизации и до нормальной работы.
   Listener
 
22 - 27.02.18 - 23:17
Проблема разрешилась, если вдруг кому поможет.
Просто надо было перезагрузить сервер ...
   h-sp
 
23 - 28.02.18 - 07:06
(21) ты нас совсем запутал. А где же у тебя это слово находится "WSОпределения", что ты на него в отладчике не можешь встать?



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует