Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Поле объекта не обнаружено :(((

Поле объекта не обнаружено :(((
Я
   Nelo_001
 
21.02.18 - 14:31
Здравствуйте, учусь на 1С, повторяю уроки из видео,  ввожу все 1 в 1 и дало ошибку помогите пожалуйста:((

{Документ.РасходнаяНакладная.Форма.ФормаДокумента.Форма(79)}: Поле объекта не обнаружено (СтавкаНДС)
     Возврат Номенклатура.СтавкаНДС; 

&НаКлиенте
 Процедура ТоварыНоменклатураПриИзменении(Элемент)
     
     ТекущиеДанные  = Элементы.Товары.ТекущиеДанные;
     ТекущиеДанные.СтавкаНДС  = ПолучитьСтавкуНДСНоменклатуры(ТекущиеДанные.Номенклатура);
     
     
     
 РассчитатьСуммуТабличнойЧастиТовары()
 
 КонецПроцедуры

 
&НаСервереБезКонтекста
 Функция ПолучитьСтавкуНДСНоменклатуры (Номенклатура)
       
     Возврат Номенклатура.СтавкаНДС; 
 КонецФункции
 
 
   lodger
 
1 - 21.02.18 - 14:33
1)
ТекущиеДанные  = Элементы.Товары.ТекущиеДанные;
Если ТекущиеДанные  = Неопределно Тогдав Возврат; КонецЕсли;
     ТекущиеДанные.СтавкаНДС  = ПолучитьСтавкуНДСНоменклатуры(ТекущиеДанные.Номенклатура);

2)
Функция ПолучитьСтавкуНДСНоменклатуры (Номенклатура)
       Если ЗначениеЗаполнено(Номенклатура) Тогда
     Возврат Номенклатура.СтавкаНДС; 
Иначе
     Возврат Неопределно; 
КонецЕсли
 КонецФункции
   Малыш Джон
 
2 - 21.02.18 - 14:35
(0) передаешь в функцию параметр "ТекущиеДанные.Номенклатура", а в функции пытаешься обратиться к его полю .СтавкаНДС

а) ты уверен, что ТекущиеДанные.Номенклатура - это элемент справочника "Номенклатура"? а не Неопределено, к примеру?
б) ты уверен, что у элемента справочника "Номенклатура" в ТВОЕЙ базе есть поле "СтавкаНДС" ?
   Nelo_001
 
3 - 21.02.18 - 14:37
   lodger
 
4 - 21.02.18 - 14:39
(3) у Номенклатура нет СтавкаНДС.
наверное надо было добавить в предыдущем уроке?
   Малыш Джон
 
5 - 21.02.18 - 14:39
(3) какая красивая структура Расходной накладной...
   Малыш Джон
 
6 - 21.02.18 - 14:40
(4) подозреваю, что в ходе добавления реквизита "СтавкаНДС" он незаметно для ТСа превратился в "СправочникНДС" ))
   Ц_У
 
7 - 21.02.18 - 14:40
(6) ага, видимо оно
   Nelo_001
 
8 - 21.02.18 - 14:44
   Nelo_001
 
9 - 21.02.18 - 14:44
   Nelo_001
 
10 - 21.02.18 - 14:45
а вот скрин видео от куда я переписал
https://pp.userapi.com/c830609/v830609909/8e5dc/1m7c1IAClEk.jpg
 
 Рекламное место пустует
   Ц_У
 
11 - 21.02.18 - 14:45
(3) справочник номенклатура реквизит СправочникНДС - это видимо и есть твоя СтавкаНДС?
   Малыш Джон
 
12 - 21.02.18 - 14:46
(8),(9), (10)
умница! везде посмотрел, кроме тех мест, о которых говорили)

в СПРАВОЧНИКЕ "Номенклатура" в его разделе "Реквизиты" есть реквизит "СтавкаНДС"?
а ты ведь между прочим у программы просишь именно его)
   Nelo_001
 
13 - 21.02.18 - 14:50
Ураааа Сделал )))
   Nelo_001
 
14 - 21.02.18 - 14:51
Спасибо большое товарищи )))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует