Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Чтение XML

Чтение XML
Я
   skupidom
 
21.02.18 - 10:32
Записываю XML:
ЗаписатьXML(ЗаписьXML, Данные.Номер,"Номер",НазначениеТипаXML.Явное);
в файле XML получается запись:
<Номер xsi:type="xs:string" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"; xmlns:xs="http://www.w3.org/2001/XMLSchema">00000006435</Номер>;
При Чтение XML как мне прочитать что 00000006435 это Номер ?
 
 
   Cyberhawk
 
1 - 21.02.18 - 10:36
Ну имя элемента же знаешь в цикле
   skupidom
 
2 - 21.02.18 - 10:40
напишите выражение
   skupidom
 
3 - 21.02.18 - 10:43
он мне выдает вот это ="xs:string"
   Cyberhawk
 
4 - 21.02.18 - 10:45
Ага, только штаны подтяну (с)
   skupidom
 
5 - 21.02.18 - 11:01
где здесь получить Имя "Номер"?
код:
Пока ЧтениеXML.Прочитать() Цикл 
                
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда 
            
            
            ИмяУзла = ЧтениеXML.Имя; 
            
            Атрибут.Очистить();
            
            Пока ЧтениеXML.ПрочитатьАтрибут() Цикл 
                                                                     
                ТипУзла = ЧтениеXML.ТипУзла; 
                Имя = ЧтениеXML.Имя; 
                Значение = ЧтениеXML.Значение;            

                
            КонецЦикла;
            
        ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда        
            
            Если Значение = "DocumentRef.ПоступлениеТоваровУслуг" Тогда
                                                                                    
                СтрокаGUID = ЧтениеXML.Значение; 
                НовыйGUID = Новый УникальныйИдентификатор(СтрокаGUID); 
                СсылкаПТУ = Документы.ПоступлениеТоваровУслуг.ПолучитьСсылку(НовыйGUID);
                
                Если СсылкаПТУ.ПолучитьОбъект() = Неопределено Тогда
                    
                    СтруктураПТУ = Новый Структура;                                 
                    СтруктураПТУ.Вставить("УИДПТУ",НовыйGUID);            
                    
                    // Создаем новый документ в базе БИТ

                    СоздадимНовыйПТУ();                                            
                    
                КонецЕсли;
                
            ИначеЕсли Значение = "Номер" Тогда
                
                СтрокаНомер = ЧтениеXML.Значение; 
                
            ИначеЕсли Значение = "Дата" Тогда
                
                СтрокаДата = ЧтениеXML.Значение; 
                
            КонецЕсли;
            
        ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда 
            
        КонецЕсли; 
        
        сч = сч + 1;
    КонецЦикла;
   Cyberhawk
 
6 - 21.02.18 - 11:12
Отладку в помощь, если не владеешь терминами структуры ХМЛ-документа
   igorPetrov
 
7 - 21.02.18 - 11:17
(5) Учимся читать документацию и думать.
   Cyberhawk
 
8 - 21.02.18 - 11:19
(7) Послал так послал )
   skupidom
 
9 - 21.02.18 - 11:20
"Номер" должен находиться в полном имени ЗаписьXML, как его вытащить ?
   igorPetrov
 
10 - 21.02.18 - 11:25
(9) см. (6) (7)
 
 Рекламное место пустует
   Defender aka LINN
 
11 - 21.02.18 - 11:35
ФабрикаXDTO.Прочитать()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует