Вход | Регистрация


Обязательные поля справочника "склады" в ут 11.4

Обязательные поля справочника "склады" в ут 11.4
Я
   Обфускация
 
20.02.18 - 13:45
Создаю программно элемент справочника склады. Пишет, что преобразование к типу булево невозможно при записи. Подскажите, какие реквизиты надо заполнить, чтобы такого не возникало?
 
 
   Darych
 
1 - 20.02.18 - 13:47
нефиг в реквизит булево пихать всякую фигню
   Обфускация
 
2 - 20.02.18 - 13:58
Вы не поверите, но это косяк типовой записи в 1с. Они не учитывают, что в выборке может не быть записей, оттуда и ошибка. Пришлось добавить условие "если выборка.Количество()>0 тогда" - этого нет в типовой, но при программном создании без этого не получится.

Процедура ОбновитьФлагКонтроляОперативныхОстатков()
    Если ДополнительныеСвойства.Свойство("ПропуститьОбновлениеФлагаКонтроляОперативныхОстатков") Тогда
        Возврат;
    КонецЕсли;
    
    УстановитьПривилегированныйРежим(Истина);
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |    ВЫБОР
    |        КОГДА ПолитикиУчетаСерий.ПолитикаУчетаСерий ЕСТЬ NULL 
    |            ТОГДА ЛОЖЬ
    |        ИНАЧЕ ПолитикиУчетаСерий.ПолитикаУчетаСерий.УказыватьПриПланированииОтбора
    |    КОНЕЦ КАК КонтролироватьОперативныеОстатки
    |ИЗ
    |    Справочник.Склады КАК Склады
    |        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ВидыНоменклатуры.ПолитикиУчетаСерий КАК ПолитикиУчетаСерий
    |        ПО Склады.Ссылка = ПолитикиУчетаСерий.Склад
    |ГДЕ
    |    Склады.Ссылка = &Склад";
    Запрос.УстановитьПараметр("Склад", Ссылка);
    
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    если выборка.Количество()>0 тогда
    Если Выборка.КонтролироватьОперативныеОстатки Тогда
        КонтролироватьОперативныеОстатки = Истина;
    КонецЕсли;
КонецЕсли;
КонецПроцедуры
   Amra
 
3 - 20.02.18 - 14:17
(2) Садись, 2!
   Обфускация
 
4 - 20.02.18 - 14:19
(3)
а как?
   1cVandal
 
5 - 20.02.18 - 15:03
(4)
Параллельно с созданием склада необходимо делать запись в справочник политика учета серий складу. При ручном создании элемент справочника создается автоматически
   dezss
 
6 - 20.02.18 - 16:27
(5) т.е. флаг обновляется перед записью элемента?
Прикольно написали наши друзья из 1С. Элемента в базе еще нет, но его флаг надо проверить. ИМХО, там логично было бы сделать:
Если Выборка.Следующий() Тогда
...
   FIXXXL
 
7 - 20.02.18 - 16:45
(2) ДополнительныеСвойства.Свойство("ПропуститьОбновлениеФлагаКонтроляОперативныхОстатков") используй

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует