Вход | Регистрация


РИБ, в новом узле почему-то оказались не все данные

РИБ,  в новом узле почему-то оказались не все данные
Я
   repin_mike
 
20.02.18 - 09:06
Всем привет, создал ещё один узел РИБ, в этом самом новом узле почему-то оказались не все данные, а именно достаточно много документов содержат не все движения. Например открываю в центральной базе поступление - по РН Партии товаров на складах 200 записей, а в созданном узле у того же самого документа оказалось 50 записей. Написал сверку - получилось что порядка 250 документов пострадало. УТ10.3, 8.3.10. Как такое могло получиться?
 
 
   vde69
 
1 - 20.02.18 - 09:19
РИБ или просто "полный обмен"?
   bodri
 
2 - 20.02.18 - 09:21
что за РИБ? смотри регистрацию объектов и сам план обмена
   repin_mike
 
3 - 20.02.18 - 09:32
(1,2) Регистрация для всех регистров накопления включена.
Создавал подчинённый узел через соответствующую кнопку
https://otr-soft.ru/faq/faq_common/plani_obmena/Podchinennyj_uzel.png
   Фрэнки
 
4 - 20.02.18 - 09:44
получается по скрину, что План обмена Полный
Судя по тому, что доступна кнопка создания Узла - там в свойствах плана взведена галочка РИБ.
Остальное нужно смотреть по конфигурации.

Если вопрос возник внезапно, а базы уже давно в эксплуатации, то есть смысл проверить кто-то мог внести изменения в состав, правило авторегистрации и т.д.
Хотя, если объекты включены в состав, то при создании первичного образа подчиненного узла - все должно переноситься средствами платформы и в это никак нельзя влезть. Но там есть процедуры внутри модуля объекта ПланОбмена... Никто их не испортил?
   Serg_1960
 
5 - 20.02.18 - 10:06
(4) "все должно переноситься средствами платформы и в это никак нельзя влезть" - это не совсем верно. Начальный образ формирует функционал платформы, но конфигурация тоже может участвовать в этом. Достаточно вспомнить, например, что ПриОтправкеДанныхПодчинённому имеет последний параметр  СозданиеНачальногоОбраза.

Погуглите в своей конфигурации "ПриОтправкеДанныхПодчиненному" и "СозданиеНачальногоОбраза"

А в принципе, теоретически, план обмена может быть РИБ, но сам обмен данными может быть настроен на использование фильтров (по организациям, по подразделениям, по складам, по магазинам...)
   Serg_1960
 
6 - 20.02.18 - 10:15
Чисто просто так, в качестве примера подтверждения вышесказанного (УПП):

Процедура ИгнорироватьОтправкуОбъектовНачальногоОбраза(ЭлементДанных, ОтправкаЭлемента, Знач СозданиеНачальногоОбраза = Ложь)
    
    Если Не СозданиеНачальногоОбраза
        И ЭтоОбъектНачальногоОбразаУзлаРИБ(ОбъектМетаданных(ЭлементДанных))
        И Не ЭтоПредопределенныйЭлемент(ЭлементДанных) Тогда
        
        ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
        
    КонецЕсли;
    
КонецПроцедуры

Функция ИгнорироватьПолучениеОбъектовНачальногоОбраза(ЭлементДанных, ПолучениеЭлемента)
    
    Если Не СозданиеНачальногоОбраза(ЭлементДанных)
        И ЭтоОбъектНачальногоОбразаУзлаРИБ(ОбъектМетаданных(ЭлементДанных)) Тогда
        
        ПолучениеЭлемента = ПолучениеЭлементаДанных.Игнорировать;
        
    КонецЕсли;
    
КонецФункции


Функция ОбъектыНачальногоОбраза() Экспорт
    
    Результат = Новый Соответствие;
    
    Объекты = Новый Массив;
    
    // Получаем объекты начального образа

    ОбработчикиСобытия = ОбщегоНазначения.ОбработчикиСлужебногоСобытия(
        "СтандартныеПодсистемы.БазоваяФункциональность\ПриПолученииОбъектовНачальногоОбразаПланаОбмена");
    Для Каждого Обработчик Из ОбработчикиСобытия Цикл
        
        Обработчик.Модуль.ПриПолученииОбъектовНачальногоОбразаПланаОбмена(Объекты);
        
    КонецЦикла;
    
    Для Каждого Объект Из Объекты Цикл
        
        Результат.Вставить(Объект.ПолноеИмя(), Истина);
        
    КонецЦикла;
    
    Возврат Новый ФиксированноеСоответствие(Результат);
    
КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует