Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле объекта не обнаружено

Я
   Sud_med
 
18.02.18 - 08:46
1С:Предприятие 8.3 (8.3.10.2168)
Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.114.1)
Доброе утро форумчате, прошу Вас помогите не могу обновиться до версии 1.0.115.1 выдает ошибку:
{ОбщийМодуль.ПроцедурыОбновленияИнформационнойБазы.Модуль(1226)}: Поле объекта не обнаружено (а_ДокументНазначения)

Тестирование и исправление не помогает
Отладка\остановка по ошибке останавливается на этом
Выборка = Запрос.Выполнить().Выбрать();
        
        Пока Выборка.Следующий() Цикл
            УсловнаяПродолжительностьДня = Выборка.ДлительностьРабочейНедели / 5;
            
            НаборЗаписейГрафики = РегистрыСведений.ГрафикиРаботыПоВидамВремени.СоздатьНаборЗаписей();
            
            Для Каждого ЭлементОтбора Из НаборЗаписейГрафики.Отбор    Цикл
                ЭлементОтбора.Установить(Выборка[ЭлементОтбора.Имя]);
            КонецЦикла;    
            
            ЗаписьГрафика = НаборЗаписейГрафики.Добавить();
            ЗаполнитьЗначенияСвойств(ЗаписьГрафика, Выборка);
            
            ЗаписьГрафика.ПроизводственныйКалендарьПятидневка     = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "Пятидневка",   ТаблицаРегистра);
            ЗаписьГрафика.ПроизводственныйКалендарьПятидневкаЧасы = УсловнаяПродолжительностьДня * ЗаписьГрафика.ПроизводственныйКалендарьПятидневка;
            ЗаписьГрафика.ПроизводственныйКалендарьШестиДневка    = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "Шестидневка",  ТаблицаРегистра);
            ЗаписьГрафика.ПроизводственныйКалендарьКалендарныеДни = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "КалендарныеДни", ТаблицаРегистра);
            
            НаборЗаписейГрафики.Записать();
        КонецЦикла;    
        
    КонецЕсли;
    
КонецПроцедуры
 
 
   Sud_med
 
1 - 18.02.18 - 08:50
{ОбщийМодуль.ПроцедурыОбновленияИнформационнойБазы.Модуль(1226)}: Поле объекта не обнаружено (а_ДокументНазначения)
                ЭлементОтбора.Установить(Выборка[ЭлементОтбора.Имя]);
   h-sp
 
2 - 18.02.18 - 08:52
(1) в запросе посмотрите, есть это поле? "а_ДокументНазначения"  ??
   Sud_med
 
3 - 18.02.18 - 08:53
в запросе при обновлении? немного не понимаю
   AlvlSpb
 
4 - 18.02.18 - 09:21
(3) В регистре сведений ГрафикиРаботыПоВидамВремени нет поля  "а_ДокументНазначения". Посмотрите запрос (то что идет выше вашего "Выборка = Запрос.Выполнить().Выбрать()") откуда появляется это поле.
   Sud_med
 
5 - 18.02.18 - 09:36
Процедура ПереЗаполнитьПроизводственныйКалендарьСУчетомПереносов(ТекущийГод, ДатыОтмененныхПереносов = Неопределено)
    
    Если ДатыОтмененныхПереносов = Неопределено Тогда
        ДатыОтмененныхПереносов = Новый Массив
    КонецЕсли;
    
    Объект = РегистрыСведений.РегламентированныйПроизводственныйКалендарь.СоздатьНаборЗаписей();
    НаборЗаписей = РегистрыСведений.ПеренесенныеРабочиеДни.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Год.Установить(ТекущийГод);
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийГод",ТекущийГод);
    Запрос.Текст =
    "ВЫБРАТЬ ПЕРВЫЕ 1
    |    РегламентированныйПроизводственныйКалендарь.Год
    |ИЗ
    |    РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
    |ГДЕ
    |    РегламентированныйПроизводственныйКалендарь.Год = &ТекущийГод";
    
    Если Запрос.Выполнить().Пустой() Тогда
        
        ТаблицаРегистра = РегистрыСведений.РегламентированныйПроизводственныйКалендарь.ЗаполнениеКалендаряСПереносами(Дата(ТекущийГод, 1, 1), НаборЗаписей);
        
        Для каждого СтрокаНабора Из НаборЗаписей Цикл
            СтрокаНабора.Год = ТекущийГод
        КонецЦикла;
        НаборЗаписей.Записать();
        НаборЗаписей.Очистить();
        
        Объект.ЗаписатьИзТаблицыВРегистр(ТаблицаРегистра, ТекущийГод);
        Объект.Очистить();
        
    Иначе
        
        МассивДат = Новый Массив;
        
        ПеренесенныеРабочиеДни = НаборЗаписей.ВыгрузитьКолонки();
        РегистрыСведений.РегламентированныйПроизводственныйКалендарь.ЗаполнитьПереченьПеренесенныхДней(ТекущийГод, ПеренесенныеРабочиеДни);
        Для каждого СтрокаТЗ Из ПеренесенныеРабочиеДни Цикл
            
            МассивДат.Добавить(СтрокаТЗ.РабочийДень);
            МассивДат.Добавить(СтрокаТЗ.ВыходнойДень);
            
            НаборЗаписей.Отбор.РабочийДень.Установить(СтрокаТЗ.РабочийДень);
            НаборЗаписей.Отбор.ВыходнойДень.Установить(СтрокаТЗ.ВыходнойДень);
            СтрокаНабораЗаписей = НаборЗаписей.Добавить();
            ЗаполнитьЗначенияСвойств(СтрокаНабораЗаписей, СтрокаТЗ);
            СтрокаНабораЗаписей.Год    = ТекущийГод;
            НаборЗаписей.Записать();
            НаборЗаписей.Очистить();
            
        КонецЦикла;
        
        Для каждого Значение Из ДатыОтмененныхПереносов Цикл
            МассивДат.Добавить(Значение);
            НаборЗаписей.Отбор.РабочийДень.Установить(Значение);
            НаборЗаписей.Записать();
        КонецЦикла;
        
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    РегламентированныйПроизводственныйКалендарь.ДатаКалендаря,
        |    РегламентированныйПроизводственныйКалендарь.Год,
        |    РегламентированныйПроизводственныйКалендарь.Пятидневка,
        |    РегламентированныйПроизводственныйКалендарь.Шестидневка,
        |    РегламентированныйПроизводственныйКалендарь.КалендарныеДни,
        |    РегламентированныйПроизводственныйКалендарь.ВидДня
        |ИЗ
        |    РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
        |ГДЕ
        |    РегламентированныйПроизводственныйКалендарь.ДатаКалендаря В(&МассивДат)";
        
        Запрос.УстановитьПараметр("МассивДат", МассивДат);
        ТаблицаРегистра = Запрос.Выполнить().Выгрузить();    
        
        Для Каждого СтрокаТЗ Из ПеренесенныеРабочиеДни Цикл
            РегистрыСведений.РегламентированныйПроизводственныйКалендарь.ПеренестиДатыПроизводственногоКалендаря(ТаблицаРегистра, СтрокаТЗ);
        КонецЦикла;
        
        Для Каждого СтрокаТаблицы Из ТаблицаРегистра Цикл
            
            Если ДатыОтмененныхПереносов.Найти(СтрокаТаблицы.ДатаКалендаря) <> Неопределено Тогда
                СтрокаТаблицы.ВидДня = Перечисления.ВидыДнейПроизводственногоКалендаря.Рабочий;
            КонецЕсли;
            
            ЗаполнитьРесурсыЗаписиРегистра(СтрокаТаблицы);
            Объект.Отбор.ДатаКалендаря.Установить(СтрокаТаблицы.ДатаКалендаря);
            ЗаполнитьЗначенияСвойств(Объект.Добавить(), СтрокаТаблицы);
            Объект.Записать();
            Объект.Очистить();
            
        КонецЦикла;    
        
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    ГрафикиРаботыПоВидамВремени.ГрафикРаботы,
        |    ГрафикиРаботыПоВидамВремени.Месяц,
        |    ГрафикиРаботыПоВидамВремени.План,
        |    ГрафикиРаботыПоВидамВремени.ВидУчетаВремени,
        |    ГрафикиРаботыПоВидамВремени.Дата,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначение,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначение,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьПятидневка,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьПятидневкаЧасы,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьШестидневка,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьКалендарныеДни,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеНорма,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеНорма,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеПолное,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеПолное,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеНормаПолное,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеНормаПолное,
        |    ГрафикиРаботыПоВидамВремени.Документ,
        |    ГрафикиРаботыПоВидамВремени.ГрафикРаботы.ДлительностьРабочейНедели КАК ДлительностьРабочейНедели
        |ИЗ
        |    РегистрСведений.ГрафикиРаботыПоВидамВремени КАК ГрафикиРаботыПоВидамВремени
        |ГДЕ
        |    ГрафикиРаботыПоВидамВремени.Дата В(&МассивДат)
        |    И ГрафикиРаботыПоВидамВремени.ГрафикРаботы ССЫЛКА Справочник.ГрафикиРаботы
        |    И ГрафикиРаботыПоВидамВремени.ВидУчетаВремени В (ЗНАЧЕНИЕ(Перечисление.ВидыУчетаВремени.ПоДням), ЗНАЧЕНИЕ(Перечисление.ВидыУчетаВремени.ПоЧасам))";
        
        Выборка = Запрос.Выполнить().Выбрать();
        
        Пока Выборка.Следующий() Цикл
            УсловнаяПродолжительностьДня = Выборка.ДлительностьРабочейНедели / 5;
            
            НаборЗаписейГрафики = РегистрыСведений.ГрафикиРаботыПоВидамВремени.СоздатьНаборЗаписей();
            
            Для Каждого ЭлементОтбора Из НаборЗаписейГрафики.Отбор    Цикл
                ЭлементОтбора.Установить(Выборка[ЭлементОтбора.Имя]);
            КонецЦикла;    
            
            ЗаписьГрафика = НаборЗаписейГрафики.Добавить();
            ЗаполнитьЗначенияСвойств(ЗаписьГрафика, Выборка);
            
            ЗаписьГрафика.ПроизводственныйКалендарьПятидневка     = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "Пятидневка",   ТаблицаРегистра);
            ЗаписьГрафика.ПроизводственныйКалендарьПятидневкаЧасы = УсловнаяПродолжительностьДня * ЗаписьГрафика.ПроизводственныйКалендарьПятидневка;
            ЗаписьГрафика.ПроизводственныйКалендарьШестиДневка    = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "Шестидневка",  ТаблицаРегистра);
            ЗаписьГрафика.ПроизводственныйКалендарьКалендарныеДни = ОтмеченВРесурсеПроизводственногоКалендаря(Выборка.Дата, "КалендарныеДни", ТаблицаРегистра);
            
            НаборЗаписейГрафики.Записать();
        КонецЦикла;    
        
    КонецЕсли;
    
КонецПроцедуры
   Sud_med
 
6 - 18.02.18 - 09:38
КонецЦикла;    
        
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    ГрафикиРаботыПоВидамВремени.ГрафикРаботы,
        |    ГрафикиРаботыПоВидамВремени.Месяц,
        |    ГрафикиРаботыПоВидамВремени.План,
        |    ГрафикиРаботыПоВидамВремени.ВидУчетаВремени,
        |    ГрафикиРаботыПоВидамВремени.Дата,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначение,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначение,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьПятидневка,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьПятидневкаЧасы,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьШестидневка,
        |    ГрафикиРаботыПоВидамВремени.ПроизводственныйКалендарьКалендарныеДни,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеНорма,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеНорма,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеПолное,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеПолное,
        |    ГрафикиРаботыПоВидамВремени.ОсновноеЗначениеНормаПолное,
        |    ГрафикиРаботыПоВидамВремени.ДополнительноеЗначениеНормаПолное,
        |    ГрафикиРаботыПоВидамВремени.Документ,
        |    ГрафикиРаботыПоВидамВремени.ГрафикРаботы.ДлительностьРабочейНедели КАК ДлительностьРабочейНедели
        |ИЗ
        |    РегистрСведений.ГрафикиРаботыПоВидамВремени КАК ГрафикиРаботыПоВидамВремени
        |ГДЕ
        |    ГрафикиРаботыПоВидамВремени.Дата В(&МассивДат)
        |    И ГрафикиРаботыПоВидамВремени.ГрафикРаботы ССЫЛКА Справочник.ГрафикиРаботы
        |    И ГрафикиРаботыПоВидамВремени.ВидУчетаВремени В (ЗНАЧЕНИЕ(Перечисление.ВидыУчетаВремени.ПоДням), ЗНАЧЕНИЕ(Перечисление.ВидыУчетаВремени.ПоЧасам))";
   Джексон
 
7 - 18.02.18 - 09:50
(0) Найдите того, кто добавил нетиповое измерение в регистр сведений ГрафикиРаботыПоВидамВремени. Узнайте смысл этого и то, как этот персонаж надеялся взаимодействовать с типовой. Затем исправьте процедуры обновления типовой с учётом открывшегося знания.
   Sud_med
 
8 - 18.02.18 - 10:10
Спасибо
   Sud_med
 
9 - 18.02.18 - 10:13
Вам огромное
   Sud_med
 
10 - 19.02.18 - 14:40
Скажите пожалуйста как быть? этого человека уже не найти, что можно сделать с ГрафикиРаботыПоВидамВремени удалить его или переделать в изначальное состояние
 
 Рекламное место пустует
   Волшебник
 
Модератор
11 - 19.02.18 - 14:42
(10) Пригласите другого программиста.
   Sud_med
 
12 - 19.02.18 - 15:21
Он ругается на это а_ДокументНазначения что это такое не могупонять как его удалить или переделать. Спасибо Пробую удалить не удаляется пишет на него имеются ссылки
   Волшебник
 
Модератор
13 - 19.02.18 - 15:22
(12) Удалите ссылки


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует