Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как создать новый документ в управляемых формах

Как создать новый документ в управляемых формах
Я
   sidalexsandr
 
16.02.18 - 12:35
Создал процедуру:
&НаСервере
Процедура ВозврДок(НовРеал)
    НовРеал = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    //НовРеал.Номер = "111";

    НовРеал.Дата = ТекущаяДата();
    НовРеал.Записать();
КонецПроцедуры

Вызываю её:
&НаКлиенте
Процедура Запустить(Команда)
            НовРеал = "";
    ВозврДок(НовРеал);
КонецПроцедуры

Выдает ошибку: Ошибка преобразования данных XDTO
Текст:  false
 
 
   Darych
 
1 - 16.02.18 - 12:37
ессно.. что хочешь?
   aka AMIGO
 
2 - 16.02.18 - 12:41
(1) Спрашивает: как создать.. Без ошибки.
   VladZ
 
3 - 16.02.18 - 12:43
(0) Все правильно говорит. Как думаешь, в чем разница между объектом и ссылкой?
   sidalexsandr
 
4 - 16.02.18 - 12:48
(3) Ссылка это указатель на объект. А можно объяснить по подробней?
   Darych
 
5 - 16.02.18 - 12:48
(2) ну так создает.. ошибка при возврате объекта
   Darych
 
6 - 16.02.18 - 12:49
(4) объект в клиент возвращаешь при вызове процедуры
   VladZ
 
7 - 16.02.18 - 12:49
&НаСервере
Функция СоздатьНовыйДокумент()
    НовРеал = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    //НовРеал.Номер = "111";


    НовРеал.Дата = ТекущаяДата();
    НовРеал.Записать();

Возврат НовРеал.ссылка;
КонецПроцедуры

&НаКлиенте 
Процедура Запустить(Команда)

    МойНовыйДок = СоздатьНовыйДокумент();
КонецПроцедуры
   ejikbeznojek
 
8 - 16.02.18 - 12:49
А что ты хочешь дальше сделать с объектом?
   VladZ
 
9 - 16.02.18 - 12:50
Упс.. Опечатка:
Возврат НовРеал.ссылка;
КонецФункции
   aka AMIGO
 
10 - 16.02.18 - 12:51
Вот этот ГКод у меня работает уже год.. даже больше:
&НаСервере
Процедура СоздатьЧекиККМнаСервере(КаталогИБПриемника)
...
        ДокЧек = Документы.ЧекККМ.СоздатьДокумент();
        ДокЧек.Номер = Накл.НомерДок;
        ДокЧек.Дата = Накл.ДатаДок;
        ДокЧек.КассаККМ = КассаККМ;        
...
        РежимЗаписи = РежимЗаписиДокумента.Запись;
        ДокЧек.Записать(РежимЗаписи);
...
        ДокПоступлениеТоваров = Документы.ПоступлениеТоваров.СоздатьДокумент();
        ДокПоступлениеТоваров.Номер = Стр.НомерДок;
        ДокПоступлениеТоваров.Дата = ДатаНачПериода - 24*60*60;
        ДокПоступлениеТоваров.Магазин = Магазин;
        ДокПоступлениеТоваров.Склад = Склад;
...
        РежимЗаписи = РежимЗаписиДокумента.Проведение;
        ДокПоступлениеТоваров.Записать(РежимЗаписи);

&НаКлиенте
Процедура СоздатьЧекиККМ()
    СоздатьЧекиККМнаСервере(КаталогИБПриемника);
    ЭтаФорма.Закрыть();
    ЗакрытьОкноСлужебныеСообщения();
    Сообщить("Создание ЧековККМ завершено.");
    Форма = ОткрытьФорму("Документ.ЧекККМ.Форма.ФормаСписка");//Открываем форму

КонецПроцедуры
 
 Рекламное место пустует
   Darych
 
11 - 16.02.18 - 12:53
(10) и что?)
   aka AMIGO
 
12 - 16.02.18 - 12:53
(11) И - ничего. Пример создания документов.
   Darych
 
13 - 16.02.18 - 12:55
(12) та к и в (0) создается)
   aka AMIGO
 
14 - 16.02.18 - 12:56
У ТС - с ошибкой в XDTO
   Catseye
 
15 - 16.02.18 - 12:58
Как вариант - если ты хочешь создать новый документ из списка документов и открыть форму нового документа, то так:

&НаКлиенте
Процедура СписокПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа)
        
    Если Копирование Тогда
        ПараметрыФормы = Новый Структура("ЗначениеКопирования", Элемент.ТекущаяСтрока); 
        ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаДокументаУпр", ПараметрыФормы);
    Иначе 
        ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаДокументаУпр",,, Новый УникальныйИдентификатор);
    КонецЕсли; 
    
КонецПроцедуры

Ты про это?
   Darych
 
16 - 16.02.18 - 12:58
(14) так он его в клиент вертает)
   sidalexsandr
 
17 - 16.02.18 - 13:04
(7) Документ не создался
   Darych
 
18 - 16.02.18 - 13:08
(17) как это понял?
   Catseye
 
19 - 16.02.18 - 13:09
Тогда так:

&НаСервере
Функция ВозврДок()

    НовРеал = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    НовРеал.Дата = ТекущаяДата();
    НовРеал.Записать();
    Возврат НовРеал.Ссылка;
КонецФункции

&НаКлиенте
Процедура Запустить(Команда)
    НовыйДокСсылка   = ВозврДок();
 
    ПараметрыФормы = Новый Структура("Ключ", НовыйДокСсылка  ); 
    ОткрытьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаДокументаУпр", ПараметрыФормы);
    
КонецПроцедуры

Тогда откроет форму уже созданного на сервере документа и переданного на клиент по ссылке
   ejikbeznojek
 
20 - 16.02.18 - 13:09
(17) На вид, создался))
   sidalexsandr
 
21 - 16.02.18 - 13:15
(18) Документ создался. В журнале стоял отбор по фирме.
   Darych
 
22 - 16.02.18 - 13:16
(21) я знал)
   aka AMIGO
 
23 - 16.02.18 - 13:18
(22) И что молчал-то? :)
   Darych
 
24 - 16.02.18 - 13:20
(23) в (18) намекнул)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует