Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Штрихкод и управляемые формы

Штрихкод и управляемые формы
Я
   margoigo
 
16.02.18 - 07:29
Осваиваю управляемые формы. Печатаю штрихкод - красиво выходит, все нормально, но сканер не считывает конкретно этот штрихкод, другие читает без проблем. Если печатаю тот же штрихкод из обычного приложения, то считывает нормально. Что не так может быть?
 
 
   margoigo
 
1 - 16.02.18 - 07:44
Вообще какая-то ерунда происходит, один штрихкод нормально печатает, другой не нормально

Как вставить рисунок здесь?
   VladZ
 
2 - 16.02.18 - 07:53
Да... Управляемые формы - они такие. Тут думать нужно...

По поводу рисунка - есть куча ссылок. Ищи.
   margoigo
 
3 - 16.02.18 - 07:55
тут что интересно один штрихкод печатает нормально, вот этот 7000010031820, а другой криво 7000010033160
   VladZ
 
4 - 16.02.18 - 07:56
Картинку покажи.
   margoigo
 
5 - 16.02.18 - 07:58
если устанавливаю принудительно типКода  = 1, то в таком случае некоторые штрихкоды печатает, а в некоторых пишет инвалид баркод ))))) Хотя штрихкоды только 1 цифрой отличаются.
   margoigo
 
6 - 16.02.18 - 08:06
   nordbox
 
7 - 16.02.18 - 08:07
(5) >>Хотя штрихкоды только 1 цифрой отличаются.
Ты сначала почитай про ШК как они формируются, а у ЕАН-13 еще контрольное число считается
   nordbox
 
8 - 16.02.18 - 08:08
(6) Дык это разные типы
   margoigo
 
9 - 16.02.18 - 08:09
видимо действительно дело в контрольном символе
   nordbox
 
10 - 16.02.18 - 08:10
Видимо тебе сначала матчасть почитать надо
 
 Рекламное место пустует
   DrZombi
 
11 - 16.02.18 - 08:12
(0) При печати ШК, табличный документ должен быть 100%, ни 90%, ни 50% от максимального.
Только 100%, без каких либо сжатий.
   DrZombi
 
12 - 16.02.18 - 08:12
+ Если надо уменьшить масштаб, то придется переписывать печатную форму, подгоняя её размер.

Либо переходите на ВК, которые могут создавать векторные рисунки для печати ШК :)
   nordbox
 
13 - 16.02.18 - 08:13
(10) хотя бы это почитай https://ru.wikipedia.org/wiki/Штриховой_код
   nordbox
 
14 - 16.02.18 - 08:13
(13) для (9) )))
   DrZombi
 
15 - 16.02.18 - 08:15
+ рисунки формата BMP, JPG, PNG... всегда теряют качество при сжатии, и изменении масштаба
   DrZombi
 
16 - 16.02.18 - 08:16
(6)  Еще прикол, никогда не обводи ШК в рамку.
Сканер видит первую линию и думает, что ШК некорректный :)
   VladZ
 
17 - 16.02.18 - 10:57
(6) Разные ШК. Проверь контрольную цифры. Она точно правильная?
   VladZ
 
18 - 16.02.18 - 10:57
*контрольную цифру.
   Kigo_Kigo
 
19 - 16.02.18 - 11:10
(17) она точно не правильная :)
вот функция формирования контрольго символа
Функция глКонтрольныйСимволEAN(ШтрКод, Тип) Экспорт
    
    Четн = 0;
    Нечетн = 0;
    
    Если Тип = 13 Тогда
        КолвоИтераций = 6;
    Иначе
        КолвоИтераций = 4;
    КонецЕсли;
    
    Для Индекс = 1 По КолвоИтераций Цикл
        Четн = Четн + Сред(ШтрКод, 2 * Индекс, 1);
        Нечетн = Нечетн + Сред(ШтрКод, 2 * Индекс - 1, 1);
    КонецЦикла;
    
    Если Тип = 13 Тогда
        Четн = Четн * 3;
    Иначе
        Нечетн = Нечетн * 3;
    КонецЕсли;
    
    КонтЦифра = 10 - (Четн + Нечетн) % 10;
    
    Возврат ?(КонтЦифра = 10, "0", Строка(КонтЦифра));
    
КонецФункции// глКонтрольныйСимволEAN()

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует