Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Редактирование реквизита формы документа при ТолькоПросмотр() = 1

Я
   dk
 
14.02.18 - 15:12
Кинул текстовый реквизит на форму документа - надо чтобы он редактировался даже при открытии документа только на просмотр
Это не реквизит документа - просто текстовое поле
Пробовал
приоткрытии
     
    Форма.ДопИнфо_ВремяПриемки.Доступность(1);
    Форма.ДопИнфо_ВремяПриемки.Редактирование(1);
--------------
в привыборезакладки тот же код вставил 
и нифига - не дает редактировать реквизит если док тока на просмотр открывается
---------
Есть решение стандартное или через формекс?
 
 
   Kigo_Kigo
 
1 - 14.02.18 - 15:15
Да , прилепить кнопку и ВвестиЗначение()
   dk
 
2 - 14.02.18 - 15:36
так себе решение
думал формекс все умеет, но похоже тут не поможет (
   Kigo_Kigo
 
3 - 14.02.18 - 15:40
(2) Может и так себе решение, зато рабочее
   aka AMIGO
 
5 - 14.02.18 - 15:48
Отбой, ошибка..
   Вафель
 
6 - 14.02.18 - 15:49
перходи на 8, там такое есть )))
   Масянька
 
7 - 14.02.18 - 15:53
(2) Процедура ПослеОткрытия()
    
    Если (ТолькоПросмотр = 1) или (НулевоеГашение = 1)  Тогда
        РасшФормы.УстановитьФорму(Форма);
        
        Для Счетчик = 0 По (РасшФормы.КоличествоАтрибутов() - 1) Цикл
            РасшФормы.ПолучитьАтрибут(Счетчик).Доступность = 0;
        КонецЦикла;

        Форма.Корректировка.Доступность(1);
        Форма.кнЗакрыть.    Доступность(1);
        Форма.кнДействия.    Доступность(1);
        
        Если (НулевоеГашение = 1) Тогда
            Форма.кнОК.         Доступность(1);
            Форма.кнОБГ.     Доступность(1);
            Форма.кнЗаписать.Доступность(1);
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры// ПослеОткрытия


В Для - обход элементов формы и закрытие (только просмотр), затем для нужных открытие (редактирование).
    РасшФормы = СоздатьОбъект("РасширениеФормы");
   Kigo_Kigo
 
8 - 14.02.18 - 15:55
(7) Садись, по 8-ке Пять, по 7-ке два!
   cincout
 
9 - 14.02.18 - 15:57
(0) Кнопка, с программной записью в журнал регистрации
   Масянька
 
10 - 14.02.18 - 16:00
(8) Значит так! За изобретение ставлю «пять», а по предмету — «неуд». (С)
 
 Рекламное место пустует
   Kigo_Kigo
 
11 - 14.02.18 - 16:05
(10) А шо це не так?(с)
   dk
 
12 - 14.02.18 - 16:06
(7) т.е. закрыть форму и потом открыть не на просмотр?
тоже не фонтан
   Масянька
 
13 - 14.02.18 - 16:10
(12) Открываешь форму (просто). Для ТолькоПросмотр свой параметр. И при наличии этого параметра - делаешь.
"Не фонтан" - переходи на снеговика. Ну, или напиши.
   Масянька
 
14 - 14.02.18 - 16:11
(11) У меня в семерке работает.
   Kigo_Kigo
 
15 - 14.02.18 - 16:21
(14) Без формекса? ))))
   Kigo_Kigo
 
16 - 14.02.18 - 16:22
(12) Она при открытии обходит все элементы формы и закрывает их
   Ёпрст
 
17 - 14.02.18 - 16:56
(0) есть. на кнопку повесть активикс с текстом.
Будет тебе редактирование
   Ёпрст
 
18 - 14.02.18 - 16:56
т.к кнопки не блокируются, твой активикс тоже не будет блокирован
   Ёпрст
 
19 - 14.02.18 - 16:58
Ну или, через ДобавитьАтрибут поиграться.
Т.е программно лепишь этот атрибут на форме сам.
Хотя я не уверен, что при ТолькоПросмотр он будет доступен, лень проверять
   big
 
20 - 15.02.18 - 05:16
(15) процедура ПослеОткрытия() - это уже формекс. Ну, и "расширениеформы" какбэ намекает ))


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует