Вход | Регистрация

1С:Предприятие ::

Метки: 

8.3, Ubuntu - При установке толстого клиента требует сервер(!)

Я
   mihmih
 
14.02.18 - 11:53
Скачал с портала 1С (https://releases.1c.ru/project/Platform83)
Клиент 1С:Предприятия (64-bit) для DEB-based Linux-систем
(версии 8.3.10-2580, т.к. установлен сервер именно этой версии)

я так понимаю - это толстый клиент?

При установке:
dpkg -i 1c-enterprise83-client_8.3.10-2580_amd64.deb
требует в зависимостях СЕРВЕР(?):
Распаковывается 1c-enterprise83-client (8.3.10-2580) …
dpkg: зависимости пакетов не позволяют настроить пакет 1c-enterprise83-client:
1c-enterprise83-client зависит от 1c-enterprise83-common (= 8.3.10-2580), однако:
  Пакет 1c-enterprise83-common не установлен.
 1c-enterprise83-client зависит от 1c-enterprise83-server (= 8.3.10-2580), однако:
  Пакет 1c-enterprise83-server не установлен.

Какого он требует сервер, если мне нужен только клиент?
 
 
   Звездец
 
1 - 14.02.18 - 11:54
ну так Борис решил. Да, бред что не выделили нужные компоненты в отдельный пакет, но факт есть факт. Так что ставь и отключи его запуск
   tesseract
 
2 - 14.02.18 - 12:04
А зачем вам толстый клиент под линух? Из-за особенностей реализации он действительно не может работать без сервера - там нет директив компиляции.  

Легаси же тотальный.
   Фрэнки
 
3 - 14.02.18 - 12:10
(0) вам для работы с какими базами нужен клиент? Если все базы примерно соответствуют БП 3, УТ 11 и т.д., то можно Тонкого клиента поставить и не морочить себе голову.

А конфигуратор в этой платформе в линукс все равно проглючивает и для повседневной работы кодера не пригоден.
   mihmih
 
4 - 14.02.18 - 12:14
(3) Конфигуратор не нужен, цель - уйти от Windows (внешних у стройств и печати не планируется, простое рабочее место оператора)
   Фрэнки
 
5 - 14.02.18 - 12:17
(4) А базы/конфигурации какие?
   mihmih
 
6 - 14.02.18 - 12:19
(5) Все на "управляемых" формах, попробую тонкий клиент поставить.
(Просто нет понимания - в чём отличается толстый от тонкого клиента)
   Звездец
 
7 - 14.02.18 - 12:21
(6) так может стоит загуглить на эту тему для начала?
   Фрэнки
 
8 - 14.02.18 - 12:22
(6) в данном конкретном случае - просто в нем нет конфигуратора.
Ну а в системном смысле, по другому работает с памятью, не может запускать "обычные формы" и т.п.
   Cool_Profi
 
9 - 14.02.18 - 12:54
Зачем вам вообще эта студенческая под(д)елка?
   Вафель
 
10 - 14.02.18 - 12:57
мне кажется в вайне понадежнее будет
 
 Рекламное место пустует
   Фрэнки
 
11 - 14.02.18 - 13:07
(10) и что ты в вайне именно будешь запускать?
Толстого клиента, когда у него все формы уже УФ?
   Фрэнки
 
12 - 14.02.18 - 13:08
(9) Это ты про 1С ?
   Вафель
 
13 - 14.02.18 - 13:08
(11) Толстого клиента конечно. В УПП или ЗУП 2.5 например не все формы УФ
   Фрэнки
 
14 - 14.02.18 - 13:08
(13) так сказали же НЕТ таких форм.
   Cool_Profi
 
15 - 14.02.18 - 13:10
(12) Это я про линух
   Фрэнки
 
16 - 14.02.18 - 13:10
(13) даже принтеров нет.
   Фрэнки
 
17 - 14.02.18 - 13:15
(15) Понятно.
LibreOffice тоже в топку? GoogleDoc, который с форматами OpenDocument работает? И обновленные версии Excel, которые тоже слету подхватывают OpenDocument - в топку!

А обновления Win10 Вам еще не надоели?


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует