Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Расширение - перехват клиентской процедуры

Расширение - перехват клиентской процедуры
Я
   ildary
 
14.02.18 - 08:41
Уважаемые специалисты, скажите пожалуйста, что я делаю не так:
делаю расширение для УТ11.4, в основном всё получается, но не удалось перехватить процедуру КарточкаНоменклатурыОбработкаРасшифровки в форме Справочник.Номенклатура.ФормаЭлемента.

Делаю так - добавил в расширение ФормаЭлемента и в её модуле:

&НаКлиенте
&Перед("КарточкаНоменклатурыОбработкаРасшифровки")
Процедура Общ_КарточкаНоменклатурыОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка) Экспорт
   
   А = 1;//досюда не доходит.

    
КонецПроцедуры

При этом сама процедура КарточкаНоменклатурыОбработкаРасшифровки() отрабатывает. И другие процедуры, но серверные перехватываются успешно. Скажите пожалуйста, где я недоделал?
 
 
   mszsuz
 
1 - 14.02.18 - 11:08
Подписку на событие элемента надо устанавливать через палитру свойств этого элемента.
   ildary
 
2 - 14.02.18 - 11:15
(1) Спасибо за ответ!
Простите мне мою глупость, а где надо искать эту подписку? У макета?
   mszsuz
 
3 - 14.02.18 - 11:17
у элемента формы в расширении
   mszsuz
 
4 - 14.02.18 - 11:23
   ildary
 
5 - 14.02.18 - 12:54
(4) огромное спасибо, нашёл. Единственное - мне пришлось сделать обработчик не &Перед, а &Вместо, потому что я не понял, как прервать выполнение последующего кода. Сделал примерно так:

&НаКлиенте
Процедура Общ_КарточкаНоменклатурыОбработкаРасшифровкиВместо(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)
//чтобы работала расшифровка по документу поступления (добавлено в Номенклатура.МодульМенеджера.Общ_ТабличныйДокументКарточкиНоменклатуры()

    
    Если ТипЗнч( Расшифровка ) = Тип( "ДокументСсылка.ПриобретениеТоваровУслуг" ) Тогда
        
        СтандартнаяОбработка = Ложь;
        ПоказатьЗначение( , Расшифровка );
        Возврат;
        
    КонецЕсли;
    
    ПродолжитьВызов( Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры );
    
КонецПроцедуры

p.s. Хочу сказать огромное спасибо автору процедуры отбора в ТЗ по значению для 7.7. Ваш код до сих пор применяется в ряде организаций.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует