Вход | Регистрация

1С:Предприятие ::

Метки: 

При отладке не входит в серверную процедуру

Я
   Dmitriy_ Kolesnikov
 
13.02.18 - 14:29
Есть:

&НаКлиенте
Процедура РассчитатьСуммы(СообщатьОбОшибках = Истина)
    Отказ = ОбщегоНазначенияБГУКлиентСервер.ПроверитьЗаполнениеРеквизитов(
        СтруктураПроверяемыхРеквизитов(), Объект, СообщатьОбОшибках);
    Если Отказ Тогда
        Возврат;
    КонецЕсли;    
    РассчитатьСуммыНаСервере();
КонецПроцедуры

&НаСервере
Процедура РассчитатьСуммыНаСервере()

Когда доходим до РассчитатьСуммыНаСервере() - жму F11, но следующий шаг сразу идет на КонецПроцедуры, в РассчитатьСуммыНаСервере не входит.
Если в этой процедуре я ставлю точку останова - не останавливается.
Почему?
 
 
   Джинн
 
1 - 13.02.18 - 14:30
Сервер в -debug?
   Волшебник
 
Модератор
2 - 13.02.18 - 14:30
нужно подключить отладчик к сеансу сервера, а в свойствах службы сервера должен быть ключ -debug
   Dmitriy_ Kolesnikov
 
3 - 13.02.18 - 14:43
(3) забыл, спасибо. Вопрос закрыт.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует