Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ Не могу установить текущую строку в таблице формы?

УФ Не могу установить текущую строку в таблице формы?
Я
   budnik
 
12.02.18 - 11:32
&НаКлиенте
Процедура Команда11(Команда)
П = Новый Структура("Ключ", Табель);
Форма = ПолучитьФорму("Документ.ТабельУчетаРабочегоВремени.ФормаОбъекта", П);
Форма.Элементы.ДанныеОВремени.ТекущаяСтрока = 2; 
КонецПроцедуры
 
 
   Lexey_
 
1 - 12.02.18 - 11:39
(0) и что, форма не открывается?
   Сияющий Асинхраль
 
2 - 12.02.18 - 11:46
На сервере получи идентификатор строки, и затем присвой его на клиенте. Как-то так:

&НаСервере
Функция ДанныеПоКолвуТоваров()
    
    СтруктураПоПервойСтроке = Новый Структура;
    
    КолвоСтрокТов = Объект.Товары.Количество();
    
    СтруктураПоПервойСтроке.Вставить("КолвоСтрокТов",КолвоСтрокТов);
    
    Если КолвоСтрокТов > 0 Тогда
        СтруктураПоПервойСтроке.Вставить("ИДСтроки",Объект.Товары[0].ПолучитьИдентификатор());
    КонецЕсли;
    
    Возврат СтруктураПоПервойСтроке;
КонецФункции

&НаКлиенте
Процедура ИФП01_ПриОткрытииПосле(Отказ)
    СтруктураПоПервойСтроке = ДанныеПоКолвуТоваров();
    Если СтруктураПоПервойСтроке.КолвоСтрокТов > 0 Тогда
        Элементы.Товары.ТекущаяСтрока = СтруктураПоПервойСтроке.ИДСтроки;
    КонецЕсли;
КонецПроцедуры
   Сияющий Асинхраль
 
3 - 12.02.18 - 11:47
В (2) Текущей делается первая строка, в случае если нужны другие номера надпись Объект.Товары[0] ясно дело будет изменена
   budnik
 
4 - 12.02.18 - 12:10
(2) нет , Объект.Товары[0].ПолучитьИдентификатор() вернет число , какая разница я на прямую пишу , как было неопределено так и остается.
   budnik
 
5 - 12.02.18 - 12:13
в модуле формы такая конструкция работает , кстати.
   hhhh
 
6 - 12.02.18 - 12:14
(4) наверно открыть форму надо. Какой смысл туда бабахать 2, если он при открытии всё равно напишет своё?
   cw014
 
7 - 12.02.18 - 12:14
"ДанныеОВремени" к чему привязано? К табличной части или таблице значений?
   budnik
 
8 - 12.02.18 - 12:15
ДанныеОВремени табличная часть документа.
   cw014
 
9 - 12.02.18 - 12:16
(8) Попробуй сначала открыть форму, а потом текущую строку указывать
   budnik
 
10 - 12.02.18 - 12:17
(9) спасибо , ок.
 
 Рекламное место пустует
   lodger
 
11 - 12.02.18 - 12:20
в уф так делать не принято.
требуемый номер текущей строки надо передать в структуру параметров.
в той форме при открытии разобрать параметры, если есть указание строки - сфокусироваться на ней.
   budnik
 
12 - 12.02.18 - 12:23
(11) Пример .
   budnik
 
13 - 12.02.18 - 12:26
(9) все работает , цель была воспользоваться стандартной функцией на форме при выбора сотрудника . Чуть не удобно что форма открывается у пользователя и закрывается , как скрыть.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует