Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Открыть форму("не работает!")!

v7: Открыть форму("не работает!")!
Я
   Сухраб
 
08.02.18 - 14:25
пишу, ОткрытьФорму("Документ.Бронь_Подрезки",Контекст);
но не открывает этот документ, если кто знает, помогите пожалуйста!
пробовал разные варианты и этот документ существует.
 
 
   YFedor
 
1 - 08.02.18 - 14:26
(0) СП нужно почитать
   1dvd
 
2 - 08.02.18 - 14:26
Что такое Контекст?
   cincout
 
3 - 08.02.18 - 14:28
(0) Пытаетесь открыть существующий документ, или создать новый?
   Сухраб
 
4 - 08.02.18 - 14:29
все там перечитал, никак не пойму в чем дело
   Сухраб
 
5 - 08.02.18 - 14:29
новый (3)
   YFedor
 
6 - 08.02.18 - 14:31
возвращает-то что эта функция у тебя?
   cincout
 
7 - 08.02.18 - 14:32
(5) Либо в конфе не так называется документ; либо в самом документе, в процедурах ПриОткрытии(), ВводНового(), ВводНаОсновании() какая то обработка есть
   Kigo_Kigo
 
8 - 08.02.18 - 14:33
Что написано в документе процедурах ПриОкрытии(), ВВодНового() ?
   Сухраб
 
9 - 08.02.18 - 14:36
ПриОткрытии(), ВводНового(), там все очистил, там и ничего такого не было
   Сухраб
 
10 - 08.02.18 - 14:36
все равно не работает!
 
 Рекламное место пустует
   Сухраб
 
11 - 08.02.18 - 14:38
и где-то в каких то доках работает в каких то нет
   Kigo_Kigo
 
12 - 08.02.18 - 14:44
А так
ДокБронь = СоздатьОбъект("Документ.Бронь_Подрезки");
ДокБронь.Новый();
ОткрытьФорму(ДокБронь,Контекст);
   NikVars
 
13 - 08.02.18 - 14:48
   Сухраб
 
14 - 08.02.18 - 14:52
(12) не работает!
   Kigo_Kigo
 
15 - 08.02.18 - 14:53
(14) Откуда вызывается? Справочник, обработка/отчет, документ?
   Сухраб
 
16 - 08.02.18 - 14:56
из документа (15)
   Сухраб
 
17 - 08.02.18 - 14:57
вот
Процедура Флаторезка2()  
    ДокБронь=СоздатьОбъект("документ.бронь_подрезка");
    ДокБронь.Новый();
    открытьформу(ДокБронь,глВзятьКонтекст(контекст));
КонецПроцедуры
//***********************************************************************
   Головоломка
 
18 - 08.02.18 - 14:57
(12) Чуть поправить.
ДокБронь = СоздатьОбъект("Документ.Бронь_Подрезки");
ДокБронь.Новый();
ДокБронь.Записать();
ОткрытьФорму(ДокБронь.ТекущийДокумент(),Контекст);
И в (13) все "свершено" :)
   silent person
 
19 - 08.02.18 - 14:59
(17) глВзятьКонтекст(контекст) - вместо этого переменная должна быть.
   Kigo_Kigo
 
20 - 08.02.18 - 14:59
(17) Так Бронь_Подрезки или Бронь_ПодрезкА ?
   Сухраб
 
21 - 08.02.18 - 15:00
Бронь_Подрезка это я вручную написал
   Сухраб
 
22 - 08.02.18 - 15:01
(18) работает, только почему таким трудным путём?
   Сухраб
 
23 - 08.02.18 - 15:02
в документе есть еще одна функция "открытьформу()" но она работает, а эта нет почему-то!
   Сухраб
 
24 - 08.02.18 - 15:02
(23) т.е. не работала)
   NikVars
 
25 - 08.02.18 - 15:03
(22) Вот волшебная палочка:
ДокБронь.Записать()
   Головоломка
 
26 - 08.02.18 - 15:06
(22) Открываем ссылку в (13) и внимательно (очень внимательно!) читаем 2-ой пост.
   Kigo_Kigo
 
27 - 08.02.18 - 15:08
(26) А если документ не надо записывать?
   azernot
 
28 - 08.02.18 - 15:08
Самый правильный совет в (1)

ОткрытьФорму(<ОписательОбъекта>,<КонтекстФормы>,<ДокументОснование>)

ПараметрКонтекста = "";
ОткрытьФорму("Документ.Бронь_Подрезки", ПараметрКонтекста);
   Kigo_Kigo
 
29 - 08.02.18 - 15:10
(28) ТОка сча проверил, прямо из новой внешней обработки
Процедура Сформировать() 
    ОткрытьФорму("Документ.Реализация",Контекст);

КонецПроцедуры
усе работает, ТС база SQL? Версия платформы какая?
   Сухраб
 
30 - 08.02.18 - 15:20
эта процедура отлично работает:
//***********************************************************************

Процедура Сформировать3()
    Если КоличествоСтрок()=0 Тогда
        Предупреждение("Выберите расходный материал!");
        Возврат;
    ИначеЕсли Итог("Количество")<1 Тогда
        Предупреждение("Введите количество расходного материала!");
        Возврат;
    КонецЕсли;
    
    глПроверкаОстатков(глВзятьКонтекст(контекст));
    глУдалитьПустыеСтроки(глВзятьКонтекст(контекст));
    
    Если Проведен()=1 Тогда                         

        глФлагРасшифровки=1;
            ВозвратМатериала();
        глФлагРасшифровки=0;

        глФлагРасшифровки = 1;
            ОткрытьФорму("Документ.Продукция",глВзятьКонтекст(контекст)); 
        глФлагРасшифровки = 0;
        Статус();
        Записать();
        Провести(); 
        форма.закрыть(0);
    иначе
        Предупреждение("Документ нужно сохранить/провести!");
            Если Вопрос("Сохранить документ?","Да+Нет") = "Да" Тогда
                Статус();
                Записать();
                Провести();
                Форма.Закрыть(0);
            Иначе
                Возврат;
            КонецЕсли;
    Конецесли;
КонецПроцедуры                                                                 
//***********************************************************************
   Сухраб
 
31 - 08.02.18 - 15:21
(26) мне нужен новый документ, а не существующий
   Сухраб
 
32 - 08.02.18 - 15:27
АХАХ), хотите прикол, открытьформу не работала потому что слово "документ" был написан с маленькой буквой, пишу с большой работает)))
   Сухраб
 
33 - 08.02.18 - 15:27
3 раза проверил!!
 
 
   NikVars
 
34 - 08.02.18 - 15:44
Что-то ты спутал... Но ты тут еще разок перечитай - вся инфа у тебя.
   azernot
 
Модератор
35 - 08.02.18 - 17:06
(32) Так-так.. значит в 0 ты соврал? Ввёл сообщество в заблуждение? Отвлёк от важных дел? Заставил кого-то поставить давно забытую 1С 7.7, а кого-то даже поднять SQL-сервер для проверки работы в разных вариантах работы базы? И всё это только потому что ты не смог корректно нажать Ctrl+C / Ctrl+V?!


Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует