Вход | Регистрация

1С:Предприятие ::

Метки: 

Как открыть встроенный в режиме предприятия отчет

Я
   lirt82
 
08.02.18 - 11:25
В режиме предприятия в справочник "Внешние отчеты, обработки и печатные формы добавлен файл отчета, как к нему программно обратиться и открыть форму? конфа на обычных формах.
 
  Рекламное место пустует
   lirt82
 
1 - 08.02.18 - 11:26
через Хранилище? раз он встроен, значит это уже объект базы?
   1dvd
 
2 - 08.02.18 - 11:26
(0) посмотри как он открывается при двойном щелчке
   1dvd
 
3 - 08.02.18 - 11:29
тип такого

            ИмяФайла = ПолучитьИмяВременногоФайла();
            ДвоичныеДанные = ВыбраннаяСтрока.ХранилищеВнешнейОбработки.Получить();
            ДвоичныеДанные.Записать(ИмяФайла);
            
            Если ЭтоОбработка Тогда                
                Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);                
            Иначе                                                                
                Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);                   
            КонецЕсли;
            
            Если Не Форма = Неопределено Тогда
                
                //2014-08-15 ГКМ, Тимошенко: для передачи ссылки и параметров из справочника во внешнюю обработку

                Попытка                    
                    Форма.ВнешняяОбработка = ВыбраннаяСтрока.Ссылка;
                Исключение
                КонецПопытки;
                
                Форма.Открыть();
            Иначе
                Если ЭтоОбработка Тогда
                    ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла);
                Иначе
                    ВнешнийОтчет = ВнешниеОтчеты.Создать(ИмяФайла);
                КонецЕсли;
            КонецЕсли; 
            
            УдалитьФайлы(ИмяФайла);

   lirt82
 
4 - 08.02.18 - 11:46
(2) точно! я перемудрил, не нужно код писать, просто еще раз двойным кликом мышки новый экземпляр этого отчета открывается:)


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует