Вход | Регистрация

1С:Предприятие ::

Метки: 

Реализовать возможность свернуть шапку в документе (Обычные формы)

Я
   Alekzander Wolf
 
08.02.18 - 09:37
Ваши идеи как проще всего реализовать такой механизм. Это нужно для того, чтобы пользователь смог увидеть табличную часть документа на весь экран. Делать еще одну форму для документа с одной табличной частью как-то не хочется (да и криво это будет выглядеть), знаю что это как-то можно сделать через порядок обхода на форме... Кто-то с этим сталкивался?
 
 
   Йохохо
 
1 - 08.02.18 - 09:41
в 7.7 ТИС это реализовано
   Alekzander Wolf
 
2 - 08.02.18 - 09:44
(1) Каким образом?
   catena
 
3 - 08.02.18 - 09:48
Вот процедура свертки быстрых отборов из шаблона отчета. Под себя уж сами как-нибудь:

Процедура СверткаПанелиОтбор (Пометка)
    
    ПрефиксИмениКн = "КнГр_";
    // Удалить старые кнопки

    Сч = 0;
    Пока Сч < ЭлементыФормы.Количество() Цикл
        ТекЭлемент = ЭлементыФормы.Получить(Сч);
        Если Найти(ТекЭлемент.Имя, ПрефиксИмениКн) > 0 Тогда
            ЭлементыФормы.Удалить(ТекЭлемент);
        Иначе
            Сч = Сч + 1;
        КонецЕсли;
    КонецЦикла;
    
    Если Пометка Тогда
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.Свертка = РежимСверткиЭлементаУправления.Нет;
        ЭлементыФормы.БыстрыеОтборы.Свертка = РежимСверткиЭлементаУправления.Нет;
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.УстановитьПривязку(ГраницаЭлементаУправления.Верх);
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.УстановитьПривязку(ГраницаЭлементаУправления.Низ, ЭлементыФормы.РазделительНижнейИВерхнейЧасти, ГраницаЭлементаУправления.Верх);
        ЭлементыФормы.БыстрыеОтборы.УстановитьПривязку(ГраницаЭлементаУправления.Низ, ЭлементыФормы.РазделительНижнейИВерхнейЧасти, ГраницаЭлементаУправления.Верх);
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.Видимость = Ложь;
    Иначе
        ЭлементыФормы.БыстрыеОтборы.УстановитьПривязку(ГраницаЭлементаУправления.Низ);
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.УстановитьПривязку(ГраницаЭлементаУправления.Верх, ЭлементыФормы.БыстрыеОтборы, ГраницаЭлементаУправления.Низ);
        ЭлементыФормы.БыстрыеОтборы.Свертка = РежимСверткиЭлементаУправления.Верх;
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.Свертка = РежимСверткиЭлементаУправления.Верх;
        ЭлементыФормы.РазделительНижнейИВерхнейЧасти.Видимость = Истина;
    КонецЕсли;
    
    СгенерироватьКнопкиУправленияГруппировкой();
    
КонецПроцедуры
   zenik
 
4 - 08.02.18 - 09:51
(2) закладки :) Реквизиты шапки и ТЧ на разных закладках.
   Alekzander Wolf
 
5 - 08.02.18 - 10:10
(3) ага спасибо, попробую
   FIXXXL
 
6 - 08.02.18 - 10:11
(0) все реквизиты - на панель и играйся как хочешь
   1dvd
 
7 - 08.02.18 - 10:24
(6) +1
В типовых такое есть
   Alekzander Wolf
 
8 - 09.02.18 - 07:01
У меня две панели на форме: панель шапки документа и основная панель, которая имеет несколько вкладок (страниц) При свертке панели шапки документа, разворачивается основная панель. Это я сделал, но тут я столкнулся со следующими проблемами:
- табличная часть, которая находится в основной панели не доступна для редактирования, не могу даже выделить элемент на ней, колесико мыши, чтобы прокрутить таблицу не работает, единственное могу прокрутить её тыкая мышкой непосредственно на прокрутку.
- табличные части и элементы форм, которые находятся на других вкладок основной панели (и на которых я в данный момент не нахожусь) не растягиваются, растягиваются только в том случае когда я непосредственно нахожусь на донной вкладке, тогда при свертке шапки все работает нормально.
- если я закрываю форму документа при свернутой шапки, то при следующем открытии формы данного документа она полностью сбивается, лечиться только с помощью восстановления положения окна. Кэш почистил не помогло.
   МимохожийОднако
 
9 - 09.02.18 - 07:58
Закладки используешь? Попробуй их.
В чем проблема сделать доступной табличную часть?
Какой-то супердокумент...
   Alekzander Wolf
 
10 - 09.02.18 - 07:59
(9) В том-то и дело что табличная часть полностью доступна
 
 Рекламное место пустует
   FIXXXL
 
11 - 09.02.18 - 09:39
(8) привязки - они такие
   Alekzander Wolf
 
12 - 09.02.18 - 10:03
(11) И не говори, что делать только не понятно.
   1dvd
 
13 - 09.02.18 - 10:37
(12) так же как и в типовых менять размеры программно
   Вафель
 
14 - 09.02.18 - 10:50
в обычных формах у группы есть режим свертки
   Alekzander Wolf
 
15 - 09.02.18 - 11:02
(14) Так все визуально прекрасно сворачивается
Проблема в том, что элементы формы на развернутой панели перестают быть доступными, хотя  Доступность стоит в Истине


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует