Вход | Регистрация

1С:Предприятие ::

Метки: 

Мобильная разработка 1С.

Я
   Raqumore
 
08.02.18 - 00:09
Разрабатываю мобильное приложение на платформе 1с, нужно сделать геопозиционирование. Нашел в учебнике данный способ получение точки на карте:
  Координаты = Неопределено; 
Если Объект.Широта <> 0 ИЛИ Объект.Долгота <> 0 Тогда  
Координаты = Новый ГеографическиеКоординаты(Объект.Широта, Объект.Долгота); 
Иначе  СтруктураДанныхАдреса = Новый Структура();  СтруктураДанныхАдреса.Вставить("Страна", Объект.Страна);  СтруктураДанныхАдреса.Вставить("Город", Объект.Город);  СтруктураДанныхАдреса.Вставить("Улица", Объект.Улица);  СтруктураДанныхАдреса.Вставить("Дом", Объект.Дом);  
ДанныеАдреса = Новый ДанныеАдреса(СтруктураДанныхАдреса);  
Координаты = ПолучитьМестоположениеПоАдресу(ДанныеАдреса); 
КонецЕсли; 
Если Координаты <> Неопределено Тогда  ПоказатьНаКарте(Координаты); Иначе  // Сообщим пользователю о том, что информация не консистентна.  

Сообщение = Новый СообщениеПользователю();  
Сообщение.Текст = "Не заполнены поля, описывающие адрес клиента!";  Сообщение.Поле = "Объект.Страна";  
Сообщение.Сообщить(); 
КонецЕсли; 

Но выдает ошибку : Тип не определен(ДанныеАдреса) в строчке ДанныеАдреса = Новый ДанныеАдреса(СтруктураДанныхАдреса); 
Как можно это исправить?
 
 
   Юрий Лазаренко
 
1 - 08.02.18 - 00:22
Версия мобильной платформы какая? Может в ней ещё не были реализованы ДанныеАдреса.
   Raqumore
 
2 - 08.02.18 - 14:02
Сама 1с распознает функцию , но почему то выдает ошибку. Посмотрел в синтакс - помощнике, там все так же написано как я делаю.
   Cyberhawk
 
3 - 08.02.18 - 14:04
Щас гляну, как в рабочей конфигурации сделано
   Cyberhawk
 
4 - 08.02.18 - 14:08
Координаты = Неопределено;
    
    #Если МобильноеПриложениеКлиент Тогда

    СтруктураАдреса = УправлениеКонтактнойИнформациейМобильноеПриложение.ДесериализацияАдресаВСтруктуруДляКарты(
        ЗначенияПолей, Представление);
    ДанныеАдреса = Новый ДанныеАдреса(СтруктураАдреса);
    Координаты = ПолучитьМестоположениеПоАдресу(ДанныеАдреса);
    #КонецЕсли

    
    Возврат Координаты;
   Cyberhawk
 
5 - 08.02.18 - 14:09
У тебя пади контекст не подходящий
   ejikbeznojek
 
6 - 08.02.18 - 14:42
Думаю ответ в (1) 
https://prnt.sc/ibtujs
   Raqumore
 
7 - 08.02.18 - 15:47
Не хватало #Если МобильноеПриложениеКлиент Тогда , спасибо за помощь Cyberhawk))
   Raqumore
 
8 - 08.02.18 - 15:51
Кто нибудь может подсказать как между двумя точками построить маршрут на карте ?
   AlexTim03
 
9 - 08.02.18 - 16:39
(8) у Яндекса вроде как есть свое API для этого
   Cyberhawk
 
10 - 08.02.18 - 16:42
(7) Пожалуйста
(8) Пожалуй сто
 
 Рекламное место пустует
   _Дайвер_
 
11 - 08.02.18 - 17:23
   ejikbeznojek
 
12 - 08.02.18 - 17:27
(8) Вот же))
https://prnt.sc/ibwfa0


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует