Вход | Регистрация

1С:Предприятие ::

Метки: 

ВыбратьПериод проблемы выбора дня.

Я
   Босечка
 
07.02.18 - 13:50
Использую функцию выбрать период. Выбираю "день", месяц встает правильно а год 0001. Что с этим делать подскажите пожалуйста.
 
 
   Lexey_
 
1 - 07.02.18 - 13:59
(0) "Что с этим делать"
это смотря какой результат нужен
   Босечка
 
2 - 07.02.18 - 14:02
Нужно, чтобы при выборе "День" выбирался Год, который стоит сверху (2018), а не 0001.
   Босечка
 
3 - 07.02.18 - 14:19
Неужели никто не сталкивался?
   Гипервизор
 
4 - 07.02.18 - 14:34
Значит неправильно используете функцию. Приведите код.
   Босечка
 
5 - 07.02.18 - 17:47
&НаКлиенте
Процедура ВыбратьПериодЗавершение(РезультатВыбора, ДопПараметры) Экспорт
    
    Если РезультатВыбора = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    ПериодВыбора.ДатаНачала = РезультатВыбора.НачалоПериода;
    ПериодВыбора.ДатаОкончания  = РезультатВыбора.КонецПериода;
    
КонецПроцедуры
&НаКлиенте
Процедура ВыбратьПериод(Команда)
    ПараметрыВыбора = Новый Структура("ДатаНачала,ДатаОкончания", ПериодВыбора.ДатаНачала, ПериодВыбора.ДатаОкончания);
    ОписаниеОповещения = Новый ОписаниеОповещения("ВыбратьПериодЗавершение", ЭтотОбъект);
    ОткрытьФорму("ОбщаяФорма.ВыборСтандартногоПериода", ПараметрыВыбора,,,,, ОписаниеОповещения);
КонецПроцедуры
   Босечка
 
6 - 07.02.18 - 20:11
ап
   Russiagreat
 
7 - 07.02.18 - 20:13
(6) ап
   Сильф
 
8 - 08.02.18 - 11:04
Интересный вопрос, подниму тоже.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует