Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Печать 2х экземпляров на странице горизонтально

Печать 2х экземпляров на странице горизонтально
Я
   dkmn
 
06.02.18 - 18:57
Народ подскажите что не так...
пытаюсь вывести на печать 2 экземпляра
в двух словах так:
    
ТабличныйДокумент = Новый ТабличныйДокумент;
ТабличныйДокумент1 = Новый ТабличныйДокумент;
    
ТабличныйДокумент1.Присоединить(ТабличныйДокумент);
ТабличныйДокумент1.Присоединить(ТабличныйДокумент);
ТабличныйДокумент1.АвтоМасштаб = Истина;
ТабличныйДокумент1.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;

Шапка и подвал в которых нет вертикальных областей выводятся как положено, а вот непосредственно табличная часть в правой колонке почемуто отсутствует(. Т.е. выглядит так

Шапка Шапка
данные
Подвал Подвал

В правой части где должны быть данные просто пусто... Может кто сталкивался?
 
 
   dkmn
 
1 - 07.02.18 - 08:13
up
   МимохожийОднако
 
2 - 07.02.18 - 08:21
Ты ТабличныйДокумент  даже не выводишь
   МимохожийОднако
 
3 - 07.02.18 - 08:22
Посмотри как сделаны акты взаиморасчетов в типовых
   dkmn
 
4 - 07.02.18 - 08:41
ты меня за идиота принимаешь? а как по твоему у меня данные на экране появляются? если я не написал в посте код вывода на экран, это не значит что я его не вывожу)))
в типовых посмотрю - но я там нигде не видел вывода 2х экземпляров на 1й странице горизонтально...
   МимохожийОднако
 
5 - 07.02.18 - 08:47
(4) Не провоцируй )) Я тебя принимаю за того, кто еще не разобрался...
Попробуй завести третий табличный документ и в нём выводи два предыдущих присоединением секций.
   МимохожийОднако
 
6 - 07.02.18 - 08:49
Убери масштаб по ширине, попробуй на небольших секциях. В настройках параметров страницы есть режим 2 экземпляра
   Zmich
 
7 - 07.02.18 - 08:49
(0). Попробуй так:

ТабличныйДокумент1.Вывести(ТабличныйДокумент.ПолучитьОбласть(1, 1, ТабличныйДокумент.ВысотаТаблицы, ТабличныйДокумент.ШиринаТаблицы));
   ТабличныйДокумент1.Присоединить(ТабличныйДокумент.ПолучитьОбласть(1, 1, ТабличныйДокумент.ВысотаТаблицы, ТабличныйДокумент.ШиринаТаблицы));
   dkmn
 
8 - 07.02.18 - 10:29
(7) В этом варианте и в левой части пропала секция с данными((( чето я вообще ничего не понимаю... как сюда скриншот прикрепить?
теперь выглядит так:

Шапка Шапка
(должна быть табличная часть - тут пусто)
Подвал Подвал
   dkmn
 
9 - 07.02.18 - 11:18
Пробую такой вариант:
    
        Обл = ТабличныйДокумент.ПолучитьОбласть();
    ТабличныйДокумент1.Вывести(Обл);
    ТабличныйДокумент1.ВставитьОбласть(Обл);

Получаю ошибку - 
Ошибка при вызове метода контекста (ВставитьОбласть)
    ТабличныйДокумент1.ВставитьОбласть(Обл);
по причине:
Выделение не соответствует вставляемому блоку
   Рэйв
 
10 - 07.02.18 - 11:20
Обл = Макет.ПолучитьОбласть("ИмяОбл");
/// заполняешь Обл.Параметры

    ТабличныйДокумент1.Вывести(Обл);
 
 Рекламное место пустует
   dkmn
 
11 - 07.02.18 - 11:26
(10) Да там все уже заполнено - мне нужно справа прилепить копию этой-же области...
Если пробую так:
    Обл = ТабличныйДокумент.ПолучитьОбласть();
    ТабличныйДокумент1.Вывести(Обл);
    ТабличныйДокумент1.Присоединить(Обл);

То при выводе на печать идет не справа от исходной а после последнего дока...

ШапкаДок1
Данные1
Подвал1
ШапкаДок2
Данные2
Подвал2
ШапкаДок1
Данные1
Подвал1
ШапкаДок2
Данные2
Подвал2

а мне нужно
Шапкадок1 ШапкаДок1
Данные1 Данные1
Подвал1 Подвал1
Шапкадок2 ШапкаДок2
Данные2 Данные2
Подвал2 Подвал2
   dkmn
 
12 - 07.02.18 - 11:26
такое ощущение что область данных безразмерная по ширине...
   Zmich
 
13 - 07.02.18 - 11:32
Ну присоединяй тогда в лоб, построчно: вывел строчку в таблицу, сразу присоединил копию, и так для всех строк.
   dkmn
 
14 - 07.02.18 - 11:37
(13) Сейчас попробую - отпишусь... Блин там километр кода - хотел малой кровью )))
   МимохожийОднако
 
15 - 07.02.18 - 11:49
(14) Сделай отдельный тестовый вариант без километров. А как разберешься-ныряй в рабочий вариант.ИМХО, так будет быстрее.
   dkmn
 
16 - 07.02.18 - 12:52
Подскажите еще 1 момент

есть области:
             ОблНомер ОблАртикул ОблНаименование ...
Облстрока

Строка таблицы с данными формируется так
Пока ВыборкаПоТоварам.Следующий() Цикл
    ТабличныйДокумент.Вывести("ОблСтрока|ОблНомер");
    Если Артикул Тогда
       ТабличныйДокумент.Присоединить("ОблСтрока|ОблАртикул");
    КонецЕсли;
       ТабличныйДокумент.Присоединить("ОблСтрока|ОблНаименование");
.....
//Здесь нужно получить область для присоединения???

КонецЦикла;

Как получить Область необходимую для присоединения???
   МимохожийОднако
 
17 - 07.02.18 - 12:55
Попробуй
ТабличныйДокумент.Присоединить("ОблСтрока|ОблНомер");
    Если Артикул Тогда
       ТабличныйДокумент.Присоединить("ОблСтрока|ОблАртикул");
    КонецЕсли;
       ТабличныйДокумент.Присоединить("ОблСтрока|ОблНаименование");
   dkmn
 
18 - 07.02.18 - 13:05
(17) Так присоединяет только номер ))) Ну не задваивать же весь код )))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует