Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: ЗиК 7.70.366 не считает страховые взносы в ПФР с превышения (10%)

v7: ЗиК 7.70.366 не считает страховые взносы в ПФР с превышения (10%)
Я
   BlackMor
 
06.02.18 - 18:37
Добрый день !

Столкнулся с тем что в релизе 366 ЗиК 77 при расчёте Страховых взносов
не считаются взносы в ПФР с превышения (1021000 руб.) в 2018 году.
Для предыдущих периодов до 2018 года этот релиз 366 считает нормально.

Кто уже сталкивался с такой проблемой ?? Подскажите, пожалуйста,
как решить проблему.
 
 
   Крэкпэк
 
1 - 06.02.18 - 19:09
С форума кубани

Исправляем:

//************************************************** ****************************

// глРассчитыватьВзносыСБазыПревышения()
//

// Параметры:
//    

//
// Возвращаемое значение:

//    
//

//    Описание:
//    

//
Функция глРассчитыватьВзносыСБазыПревышения(ВидТарифа, ДатаПериода) Экспорт 

//Если ДатаГод(ДатаПериода)>=2018 Тогда

//    Возврат 0; 
//КонецЕсли;


ДатаАктуальности = КонГода(ДатаПериода);
   Asmody
 
2 - 06.02.18 - 19:12
(0) Закопать стюардессу и трахаться как все приличные люди - с ЗУПом.
   Gucci76
 
3 - 06.02.18 - 21:30
(1) Это они специально?
Или одно из двух? )))
   BlackMor
 
4 - 06.02.18 - 23:58
(1) Огромное СПАСИБО !!!
   IvaneS
 
5 - 14.02.18 - 16:34
(3) Специально, т.к хорошие заняты 8.х. А на 7 по остатку)))
Там еще при сохранении СЗВ-СТАЖ в файл вылетает... пока подозреваю что больше 1000 сотров не тянет, т.к в списке все номером строки "999"
Сегодня разберусь наверное.
(0) Федеральный закон от 27 ноября 2017 г. N 361-ФЗ
"Президентом РФ подписан Закон о сохранении на период до 2020 г. включительно тарифов страховых взносов, действующих в 2017-2019 гг. для основной категории плательщиков"

Вернее будет :
  Если ДатаГод(ДатаПериода)>=2020 Тогда
   IvaneS
 
6 - 14.02.18 - 16:59
+(5)
Если в списке больше 1000 сотрудников, то внести изменение в Отчет.ПодготовкаСведенийДляПФР2017

стр.1936 (длину с 3 изменяем на 4)
    СведенияСотрудников.НоваяКолонка("Ном","Число",4,0, "№ п/п",2);
   HK_Mers
 
7 - 14.02.18 - 19:01
справки 2-НДФЛ там старые?
есть у кого информация, когда они новый релиз собираются выпустить?
   2S
 
8 - 14.02.18 - 19:34
Вот же хитрые жо (пы)
   IvaneS
 
9 - 15.02.18 - 09:46
в 366 релизе СЗВ-СТАЖ при записи в файл "схлопывается" 1С (задача потерпела неудачу).
Я подозреваю на строки 1804-1817
    // Сохраняем файл в кодировке UTF-8 

    АдоДБСтрим = CreateObject("Adodb.Stream");
    АдоДБСтрим.Charset="windows-1251";
    АдоДБСтрим.Type = 2;
    АдоДБСтрим.Mode= 3;
    АдоДБСтрим.Open();
    АдоДБСтрим.LoadFromFile(ПолноеИмяФайла);
    ТекстАдоДБСтрим = АдоДБСтрим.ReadText();
    АдоДБСтрим.Close();
    АдоДБСтрим.Charset = "utf-8";
    АдоДБСтрим.Open();
    АдоДБСтрим.WriteText(ТекстАдоДБСтрим);
    АдоДБСтрим.SaveToFile(ПолноеИмяФайла, 2);
    АдоДБСтрим.Close();

При этом сам xml файл сформирован. При попытке поменять кодировку - вызывает ошибку.
Кто покажет направление?
   IvaneS
 
10 - 15.02.18 - 09:48
+(9) зачем так мутить...?
 
 Рекламное место пустует
   NikVars
 
11 - 15.02.18 - 09:52
(9) Исправление.
1) Открой в текстовом редакторе файл и сохрани ручками в формате ютф.
2) Или доработай как в реготчетах в файле RSV14.ERT
        //Сохраняем файл в кодировке UTF-8

        Если КолДопЛистов <= 2500 Тогда
            АдоДБСтрим = СоздатьОбъект("Adodb.Stream");
            АдоДБСтрим.Charset = "windows-1251";
            АдоДБСтрим.Type = 2;
            АдоДБСтрим.Mode= 3;
            АдоДБСтрим.Open();
            АдоДБСтрим.LoadFromFile(ИмяФайлаВыгрузкиФЛ);
            ТекстАдоДБСтрим = АдоДБСтрим.ReadText();
            АдоДБСтрим.Close();
            АдоДБСтрим.Charset = "utf-8";
            АдоДБСтрим.Open();
            АдоДБСтрим.WriteText(ТекстАдоДБСтрим);
            АдоДБСтрим.SaveToFile(ИмяФайлаВыгрузкиФЛ, 2);
            АдоДБСтрим.Close();
            Сообщить("Сформирован файл: " + ИмяФайлаВыгрузкиФЛ); 
        Иначе
            Сообщить("Сформирован файл: " + ИмяФайлаВыгрузкиФЛ); 
            Сообщить("Сформированый файл содержит данные более 2500 физических лиц и его не удалось сохранить в кодировке UTF-8.", "!");
            Сообщить("Рекомендуется сформированный файл открыть в текстовом редакторе и сохранить в кодировке UTF-8.", "!");
        КонецЕсли;
   NikVars
 
12 - 15.02.18 - 09:53
(10) А как из 7.7 сохранить в формате ютф большой файл?
   2S
 
13 - 15.02.18 - 09:58
с3.1415жено
      АдоДБСтрим = CreateObject("Adodb.Stream");    
    АдоДБСтрим.Charset="windows-1251";
    АдоДБСтрим.Type = 2;
    АдоДБСтрим.Mode= 3;
    АдоДБСтрим.Open();
    АдоДБСтрим.LoadFromFile(ПолноеИмяФайла); 
    Байт=255;
    СтримВход=АдоДБСтрим;
    СтримВыход=СоздатьОбъект("ADODB.Stream");
    СтримВыход.Type=2;
    СтримВыход.charset="utf-8";
    СтримВыход.LineSeparator=-1;
    СтримВыход.Open();
    Всего=СтримВход.size;
    Пока СтримВход.EOS=0 Цикл
        СтримВыход.WriteText(СтримВход.ReadText(Байт),?(Байт=-2,1,0));
        Состояние("" + Формат(100 * СтримВход.position/Всего,"Ч(0)5.2")+"%");
    КонецЦикла;
    СтримВыход.SaveToFile(ПолноеИмяФайла,2);


работает
   IvaneS
 
14 - 15.02.18 - 10:15
(13) Благодарю, проверяю...
   IvaneS
 
15 - 15.02.18 - 11:11
В файле у сотрудников с вредными условиями код позиции отсутствует(((
   IvaneS
 
16 - 15.02.18 - 11:30
(13) Работает. (с3.1415женый код рабочий) )))
   IvaneS
 
17 - 15.02.18 - 16:41
Для код позиции пришлось подправить в процедуре записи в файл, выгрузились.
Далее в ПУ-6 загрузились хорошо, там расчетчики будут шаманить с "вредниками", которым не считают не полные дни - вредными. А отпуск и больничные идут как вредные.
Чудеса у нас в законе.
Кто не понял, если сотрудник отработал меньше 6 часов на  вредных условиях (отпросился, заняли в другом участке...), то этот день считается без вредных условий. Тут без смеха ни как.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует