Вход | Регистрация

1С:Предприятие ::

Метки: 

Спозиционироваться на определенной строке табличного поля

Я
   МимохожийОднако
 
06.02.18 - 09:28
Обычные формы. Внешняя обработка с табличной частью товары. После заполнения табличного поля на форме надо спозиционировать курсор на 4 строчку (например).Допустим таблица заполнена на 10 строчек.
У табличного поля нет метода Получить().
Чего-то не соображу как закончить строчку:
ЭлементыФормы.Товары.Текущаястрока =
 
 
   oslokot
 
1 - 06.02.18 - 09:29
ЭлементыФормы.Товары.Текущаястрока = Товары[8]
   oslokot
 
2 - 06.02.18 - 09:32
можно и так:

Строки = ТабличноеПоле1.НайтиСтроки(СтруктураПоиска);
Если Строки.Количество() > 0 Тогда
  ЭлементыФормы.ТабличноеПоле1.ТекущаяСтрока = Строки[0];
КонецЕсли;
   МимохожийОднако
 
3 - 06.02.18 - 10:40
Спасибо. Этот же код я изначально пытался использовать в обработчике ПослеОкончанияРедактированияСтроки и получал ошибку:"невозможно изменить текущую строку".
Думал, что неправильно писал код определения текущей строки.
Но когда понял, что дело в том, что не в том месте размещал этот код.
В конечном итоге добавил другую функцию, в которой добавил
    ПодключитьОбработчикОжидания("СпозиционироватьсяНаСтрокеТовары",0.01,Истина);
    //ОтключитьОбработчикОжидания("СпозиционироватьсяНаСтрокеТовары");

КонецПроцедуры

Процедура СпозиционироватьсяНаСтрокеТовары()
    ИндексСтрокиПосле=Мин(НомерСтрокиДо-1,Товары.Количество()-1);
    Если ИндексСтрокиПосле>0 Тогда
        ЭлементыФормы.Товары.ТекущаяСтрока=Товары[ИндексСтрокиПосле];
    КонецЕсли;    
КонецПроцедуры
Может быть и пригодится кому.


Список тем форума
Рекламное место пустует Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует