Вход | Регистрация

1С:Предприятие ::

Метки: 

Почему не увеличивается переменная?

Я
   Keiby
 
02.02.18 - 17:50
ЗУП 2.5
Документ СЗВ-СТАЖ, если больше 99 записей о стаже, то выгружается только 99. Я нашел в чем дело, но не пойму почему так. Вот исходный кусок кода:
//Нумерация записей стажа 

        НомерОсновнойЗаписи = 0; 
        НомерСтроки = 0;
        Для Каждого СтрокаСтажа Из ВременнаяТаблицаФизлица цикл
            
            НомерСтроки = НомерСтроки + 1;
            ТекстОшибкиСНомеромСтроки = "В строке стажа " + НомерСтроки + ": ";
            
            //Контролируем смену основной записи

            Если ЗначениеЗаполнено(СтрокаСтажа.ДатаНачалаПериода) И ЗначениеЗаполнено(СтрокаСтажа.ДатаОкончанияПериода) тогда
                //Встретили основную запись

                НомерОсновнойЗаписи = НомерОсновнойЗаписи + 1; 
                НомерДополнительнойЗаписи = 0;
            ИначеЕсли Не ЗначениеЗаполнено(СтрокаСтажа.ДатаНачалаПериода) И Не ЗначениеЗаполнено(СтрокаСтажа.ДатаОкончанияПериода) тогда    
                Если НомерОсновнойЗаписи <> 0 Тогда
                    НомерДополнительнойЗаписи = НомерДополнительнойЗаписи + 1; 
                ИначеЕсли СообщатьОПроблемах Тогда
                    ОбщегоНазначенияЗК.ВывестиИнформациюОбОшибке(ТекстОшибкиСНомеромСтроки + "не указаны даты начала и окончания периода!", Отказ);
                КонецЕсли;
            ИначеЕсли СообщатьОПроблемах Тогда
                Если ЗначениеЗаполнено(СтрокаСтажа.ДатаНачалаПериода) Тогда
                    ОбщегоНазначенияЗК.ВывестиИнформациюОбОшибке(ТекстОшибкиСНомеромСтроки + "не указана дата окончания периода!", Отказ);
                Иначе
                    ОбщегоНазначенияЗК.ВывестиИнформациюОбОшибке(ТекстОшибкиСНомеромСтроки + "не указана начала окончания периода!", Отказ);
                КонецЕсли;
            КонецЕсли;    
            
            СтрокаСтажа.НомерОсновнойЗаписи = НомерОсновнойЗаписи;
            СтрокаСтажа.НомерДополнительнойЗаписи = НомерДополнительнойЗаписи;
            
        КонецЦикла;    

В параметр "СтрокаСтажа.НомерОсновнойЗаписи" записывается число не больше 99, как только больше, так остается 99 и все.
 
 
   Keiby
 
1 - 02.02.18 - 17:51
Из-за этого ни XML не выгружается правильно, ни печатная форма. Только 99 строк и все.
   EgaisZavis2
 
2 - 02.02.18 - 17:55
Может у неё тип Число(2,0)?
   МимохожийОднако
 
3 - 02.02.18 - 17:55
Размер НомерОсновнойЗаписи какой?
   Михаил Козлов
 
4 - 02.02.18 - 17:56
Ограничение разрядности (НомерОсновнойЗаписи), скорее всего.
Летунов - на мыло! Даже если работал 50 лет, то каждый год 2-жды менял работу.
   Keiby
 
5 - 02.02.18 - 17:58
(3) (4)
Переменная (НомерОсновнойЗаписи) успешно растет больше 99.
   Keiby
 
6 - 02.02.18 - 18:00
СтрокаСтажа.НомерОсновнойЗаписи это же получается ВременнаяТаблицаФизлица.НомерОсновнойЗаписи.
А она, в свою очередь, создается так ВременнаяТаблицаФизлица = ЗаписиОСтаже.ВыгрузитьКолонки();
   Keiby
 
7 - 02.02.18 - 18:02
Точно, отладчиком посмотрел, когда выполняется "ВременнаяТаблицаФизлица = ЗаписиОСтаже.ВыгрузитьКолонки();
"
разрядность по "НомерОсновнойЗаписи" проставляется 2.
   Keiby
 
8 - 02.02.18 - 18:04
Все, понял, в "ЗаписиОСтаже" тоже разрядность 2. Надо поправить
   Keiby
 
9 - 02.02.18 - 18:16
Все получилось, увеличил разрядность параметра и все встало на свои места! Спасибо!


Список тем форума
Рекламное место пустует Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует