Вход | Регистрация


Метод "оповестить" оповещает все открытые формы?

Метод "оповестить" оповещает все открытые формы?
Я
   Shur1cIT
 
02.02.18 - 16:08
Из Формы элемента справочника открывается другая форма по кнопки
//-----------------------------------------------

Процедура КоманднаяПанель1Добавить(Кнопка)
    ФормаВвода                 = ЭтаФорма.ЭтотОбъект.ПолучитьФорму("ФормаДобавленияФайла", ЭтаФорма);
    ФормаВвода.Открыть();

КонецПроцедуры
//------------------------------------------------

Далее в открытой форме происходит следующее

Процедура ОсновныеДействияФормыДобавить(Кнопка)    
    Оповестить("ОбновитьФорму",ЭтаФорма , ВладелецФормы);
    ЭтаФорма.Закрыть()
КонецПроцедуры

Процедура ПриОткрытии()
    Ссылка = ЭтаФорма.ВладелецФормы.Ссылка;
    ПолучитьСсылкуНасерию();
КонецПроцедуры
//----------------------------------------------------


после закрытия в форме элемента справочника выполняется следующий код

Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = "ОбновитьФорму" Тогда
//-----------------------------------------------------



Хотел вопрос задать чтобы точно на 100% быть увереным, если открыто две формы элемента справочника и в одной из них открыта другая форма то после отработки оповестится все формы? и процедура обработка оповещения отработает везде? так как в обработке оповещения не указано условие по параметру?
 
 
   Lexey_
 
1 - 02.02.18 - 16:21
(0) в любой непонятной ситуации читай СП:

"Описание:
Посылает оповещение всем созданным формам".

И "чтобы точно на 100% быть увереным" возьми и проверь сам
   Фрэнки
 
2 - 02.02.18 - 16:31
в данном сеансе, в текущем только, на текущей рабочей станции - оповестит.

Тестить сейчас лень, и на 100% не уверен... Уверен, что оно оповестит все формы на основании ВладелецФормы
   Shur1cIT
 
3 - 02.02.18 - 16:36
(1) пришлось протестить, действительно оповещает все и отрабатывает везде где  ИмяСобытия = "ОбновитьФорму"
   Lexey_
 
4 - 02.02.18 - 16:40
(3) неправильно, оповещает все и отрабатывает везде, где есть ОбработкаОповещения()
   Lexey_
 
5 - 02.02.18 - 16:41
+(4) а вообще оповещает всё, а обрабатывать это ОбработкойОповещения или нет это уже другой вопрос

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует