Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Проводка на забалансовый счет.

Проводка на забалансовый счет.
Я
   __Se24
 
02.02.18 - 11:02
Господа , подскажите , кто знает .
Документ "Ввод начальный остатков" , самописный.
При попытке сделать проводку на счет "000" , являющийся забалансовым.
В дебете "000" и заполнено одно субконто, в кредите пустая ссылка на счет, субконты тож не заполнены.
Про попытке провести документ выдается ошибка о том , что нельзя сделать проводку с балансового счета на забалансовый.
В чем тут может быть проблема ?
 
 
   Гипервизор
 
1 - 02.02.18 - 11:04
В том что забалансовые счета не корреспондируют с балансовыми счетами.
   Гипервизор
 
2 - 02.02.18 - 11:07
А что за конфа, в которой счет 000 вдруг стал забалансовый и имеет субконто?
   __Se24
 
3 - 02.02.18 - 11:08
Своя , самописная ...
   __Se24
 
4 - 02.02.18 - 11:09
(2) не путайте счет "00" и "000"
   Гипервизор
 
5 - 02.02.18 - 11:16
(4) Вы спросили про 000, я про него и отвечаю. Может вы что-то путаете?
   __Se24
 
6 - 02.02.18 - 11:18
(5) я в топике все написал.
00 - балансовый
000- забалансовый
Что тут непонятного ?
   hhhh
 
7 - 02.02.18 - 11:20
(4) 000 - балансовый
   Дмитрий
 
8 - 02.02.18 - 11:20
(0) нужно смотреть, что именно пытается провести Ваш "Документ "Ввод начальный остатков" , самописный."
   Гипервизор
 
9 - 02.02.18 - 11:21
(6) Где в топике про 00?? Ну где?? Написал он все, писатель..
   hhhh
 
10 - 02.02.18 - 11:21
(6) может он на другие строчки ругается, а не на эту. Другие проводки какие в этом документе?
 
 Рекламное место пустует
   __Se24
 
11 - 02.02.18 - 11:23
(9) это был ответ на ваше замечание "Почему вдруг 000 стал забалансовым и с субконто "
В нашей конфе он и был изначально Забалансовым.
   __Se24
 
12 - 02.02.18 - 11:24
(10) в этом документе только одна строчка. больше там не на что ругаться ..
   Гипервизор
 
13 - 02.02.18 - 11:27
(11) Для чего вы мне тогда про какой-то  00 рассказываете? В типовых 000 именно балансовый и без субконто. А у вас не только алгоритм собственный, но и счета особые.
   hhhh
 
14 - 02.02.18 - 11:27
(12) ну давайте код, хрустальные шары для связи с Плутоном все дома позбывали.
   Гипервизор
 
15 - 02.02.18 - 11:34
У вас проверка, которая ругается на использование балансового и забалансового счета, тоже своя собственная? Она учитывает что кор.счет не заполнен? Потому что у пустой ссылки так-то Забалансовый = Ложь. Вот ваша самописка и считает что использовано недопустимое сочетание.
   __Se24
 
16 - 02.02.18 - 11:35
врБР=РегистрыБухгалтерии.РегистрБухгалтерииФилиалы;
    врВалюта=Константы.ВалютаДоллар.Получить();
    врСчет00=ПланыСчетов.План1.НайтиПоКоду("00");
    
    Для Каждого СтрТаб Из ТаблицаДвижений Цикл
        
        врСчет1="";
        врСубк1="";
        врСубк2="";
        врСубк3="";
        Если СтрТаб.БухгСчет.Забалансовый=Ложь Тогда
            врСчет1=врСчет00;
            врСубк1=СтрТаб.Субконто1;
            врСубк2=СтрТаб.Субконто2;
            врСубк3=СтрТаб.Субконто3;
        КонецЕсли;
        
        Если СтрТаб.ДебетКредит="Дт" Тогда
Вот код документа.            
врБР.СделатьПроводку(ЭтотОбъект,СтрТаб.БухгСчет,СтрТаб.Субконто1,СтрТаб.Субконто2,СтрТаб.Субконто3,врСчет1,врСубк1,врСубк2,врСубк3,СтрТаб.СуммаРуб,СтрТаб.Количество,СтрТаб.СуммаВал,врВалюта,"Ввод начальных остатков");
        Иначе
            врБР.СделатьПроводку(ЭтотОбъект,врСчет1,врСубк1,врСубк2,врСубк3,СтрТаб.БухгСчет,СтрТаб.Субконто1,СтрТаб.Субконто2,СтрТаб.Субконто3,СтрТаб.СуммаРуб,СтрТаб.Количество,СтрТаб.СуммаВал,врВалюта,"Ввод начальных остатков");
        КонецЕсли; 
        
    КонецЦикла;
   __Se24
 
17 - 02.02.18 - 11:36
Вот код документа :

врБР=РегистрыБухгалтерии.РегистрБухгалтерииФилиалы;
    врВалюта=Константы.ВалютаДоллар.Получить();
    врСчет00=ПланыСчетов.План1.НайтиПоКоду("00");
    
    Для Каждого СтрТаб Из ТаблицаДвижений Цикл
        
        врСчет1="";
        врСубк1="";
        врСубк2="";
        врСубк3="";
        Если СтрТаб.БухгСчет.Забалансовый=Ложь Тогда
            врСчет1=врСчет00;
            врСубк1=СтрТаб.Субконто1;
            врСубк2=СтрТаб.Субконто2;
            врСубк3=СтрТаб.Субконто3;
        КонецЕсли;
        
        Если СтрТаб.ДебетКредит="Дт" Тогда
            врБР.СделатьПроводку(ЭтотОбъект,СтрТаб.БухгСчет,СтрТаб.Субконто1,СтрТаб.Субконто2,СтрТаб.Субконто3,врСчет1,врСубк1,врСубк2,врСубк3,СтрТаб.СуммаРуб,СтрТаб.Количество,СтрТаб.СуммаВал,врВалюта,"Ввод начальных остатков");
        Иначе
            врБР.СделатьПроводку(ЭтотОбъект,врСчет1,врСубк1,врСубк2,врСубк3,СтрТаб.БухгСчет,СтрТаб.Субконто1,СтрТаб.Субконто2,СтрТаб.Субконто3,СтрТаб.СуммаРуб,СтрТаб.Количество,СтрТаб.СуммаВал,врВалюта,"Ввод начальных остатков");
        КонецЕсли; 
        
    КонецЦикла;
   __Se24
 
18 - 02.02.18 - 11:36
(16) не читать ))
   __Se24
 
19 - 02.02.18 - 11:37
(15) да , до этого я сам тоже дошел ...
но примерно месяца 2-3 назад этот документ проводился.
сейчас пришлось его снять с проведения и провести по-новой и начались эти непонятные ошибки
   Гипервизор
 
21 - 02.02.18 - 11:40
Посыпаю голову пеплом, но я так и не постиг ваших игр с нулями. Сначала вы уверяете, что счет таки 000, а в примере кода снова появляется 00.
   Гипервизор
 
22 - 02.02.18 - 11:43
(20) Не понял, балансовый счет искать по коду нельзя?
   __Se24
 
23 - 02.02.18 - 11:45
(21) Код смотрите внимательнее ...
00 это балансовый вспомогательный. Документ может вводить остатки не только для забалансовых счетов.

мне вам код оттранслировать ?
ок
Если в таблице Счет балансовый , то в корреспонденцию подставляется счет 00 , а если Забалансовый , то тогда корреспонденция остается незаполненной.
   __Se24
 
24 - 02.02.18 - 11:47
(20)  - пост 23
   Джо-джо
 
25 - 02.02.18 - 11:47
(23) А при чём тут "000"?
   Гипервизор
 
26 - 02.02.18 - 11:48
(23) Да ешкин код, в (0) счет 000, в (17) 00. Вы тролль?
   __Se24
 
27 - 02.02.18 - 11:50
Ок
В документе , в табличной части идет запись движенияпо счету "000" .... если вам удобнее , замените его на любой забалансовый счет "ХХХ"
   __Se24
 
28 - 02.02.18 - 11:53
(26)  Вы пост 23 прочитали полностью? или так же как и топик ? )
   Гипервизор
 
29 - 02.02.18 - 11:57
(28) Что вам дает основание усомниться, что я невнимательно прочитал топик? Вот меня сомнения терзают, это да, уж коли вы в 27-м лишь сообщении изволили объяснить, что оказывается 000 счет для примера и если нам (!) так удобнее, можно заменить на любой.
Это было шикарно.
   Гипервизор
 
30 - 02.02.18 - 11:58
Хотя пятница же, все понятно.
   catena
 
31 - 02.02.18 - 11:59
(28)Надо смотреть, что в врБР.СделатьПроводку
   catena
 
32 - 02.02.18 - 12:01
И хорошо бы скрин отладчика с расчитанным значением СтрТаб.БухгСчет.Забалансовый.
   hhhh
 
33 - 02.02.18 - 12:01
(27) вообще-то прогнать отладчиком у вас займет 20 секунд, вам просто скучно наверно, решили с народом пообщаться.
 
 
   __Se24
 
34 - 02.02.18 - 12:01
(31) окло 100 тысяч документов делают проводки при помощи этой процедуры , проблема возникла только с этой комбинацией данных
   hhhh
 
35 - 02.02.18 - 12:03
(34) ну с забалансовыми счетами миллионы работают, и с вводом остатков тоже. Ни у кого не было такого за более чем 15 лет. Проверяйте - это реально ваш косяк, глупо кивать на 1с.
   __Se24
 
36 - 02.02.18 - 12:03
(33) я прогонял отладчиком , неоднократно ...
в коллекцию движений все записывается так как нужно (в дебет - забалансовый счет , в кредит - ничего )
в результате транзакцию отбивает ...
что еще можно увидеть в отладчике ?
   __Se24
 
37 - 02.02.18 - 12:05
(35) я понимаю , что миллионы ...
и мне бухгальтеры говорят , что все так и должно быть ...
но почему-то не получается ...
   hhhh
 
38 - 02.02.18 - 12:07
(37) посмотрите, может вредители сняли эту галку, забалансовый. Или план счетов План2, а не План1
   hhhh
 
39 - 02.02.18 - 12:08
(37) чего прям реально план счетов назвали План1 ??
   __Se24
 
40 - 02.02.18 - 12:09
(38) да не ... уже проверил и неоднократно.
План счетов 1
Да , так и назвали ... чтобы не думать долго ))
   hhhh
 
41 - 02.02.18 - 12:11
(40) но что мешает вам посмотреть отладчиком? Ведь для отладчика - ерундовый вопрос, а если вы философскими рассуждениями будете решать, тогда может неделя уйти.
   YFedor
 
42 - 02.02.18 - 12:11
Ругань на невозможность сделать проводку между балансовым и забалансовым счетами зашита в платформу.

Поэтому, такую проводку сделать не получится.
   hhhh
 
43 - 02.02.18 - 12:13
(42) да правильно у него.
   YFedor
 
44 - 02.02.18 - 12:15
(43) Сообщение такое выходит только в одном случае, который описал в (42) - значит неправильно
   Гипервизор
 
45 - 02.02.18 - 12:15
(36) Судя по (17) "ничего" (т.е. пустой счет) для вас это врСчет1="" ?? Реально? Т.е. не пустая ссылка плана счетов, а строка??
   __Se24
 
46 - 02.02.18 - 12:17
(45) Да , при присвоении данных элементу коллекции движений он конвертирует его в пустую ссылку
   __Se24
 
47 - 02.02.18 - 12:17
строка превращается в "пустой счет"
   __Se24
 
48 - 02.02.18 - 12:20
(44) Я как бы в курсе ...
этот документ раньше проводился (был проведен) его распровели и началась вот такая хрень. Документ (содержание и код) не изменялись
   Гипервизор
 
49 - 02.02.18 - 12:25
Не знаю как вы неоднократно прогоняли отладчиком, но почему бы вам не поставить в врБР.СделатьПроводку() точку останова с таким условием:
(СтрТаб.БухгСчет.Забалансовый И НЕ врСчет1.Забалансовый) ИЛИ (НЕ СтрТаб.БухгСчет.Забалансовый И врСчет1.Забалансовый)
 
 Рекламное место пустует
   hhhh
 
50 - 02.02.18 - 12:36
(48) поставьте точку останова на конеццикла и покажите нам эту проводку, которая сделалась.
   Dmitrii
 
51 - 02.02.18 - 12:41
ОФФ.
Весело тут у вас.
1,5 часа обсуждать вопрос, который смотрится за 1,5 минуты отладчиком.....
   hhhh
 
52 - 02.02.18 - 12:43
(51) пятница же. Отладчик - это скукота.
   Dmitrii
 
53 - 02.02.18 - 12:53
Дык ведь даже если так скучно - чисто логические рассуждения приводят нас к нескольким вариантам причин проблемы:
- счет 000 всё таки балансовый (автор, утверждая обратное, либо вообще не утруждался это проверить, либо смотрит не в том плане счетов, либо...)
- корсчет всё таки чем-то заполнен (код врСчет1="" не меняет корсчет на пустой) и это что-то - это балансовый счет.
- в процедуре врБР.СделатьПроводку происходит что-то, что либо меняет нам счет "000" на какой-то другой (например, очищает или пихает туда какой-то балансовый счет и в результате получаем корреспонденцию между пустыми счетами или между балансом и забалансом)
- в модуле набора записей регистра РегистрБухгалтерииФилиалы  или в подписке на событие в ПередЗаписью присходит что-то аналогичное написанное в предыдущем пункте.

Все эти варианты расследуется за 3 минуты...
   __Se24
 
54 - 02.02.18 - 16:06
Всем спасибо за участие.
ТИИ помог исправить ситуацию.
   hhhh
 
55 - 02.02.18 - 16:11
(54) да, действительно пятница


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует