Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Работа с хранилищем открытие файла для редактирования

Работа с хранилищем открытие файла для редактирования
Я
   DenisVich
 
02.02.18 - 08:31
Здравствуйте. Столкнулся с такой проблемой. Если открываю файл из хранлища, то он не сохраняется. Как сделать чтобы сохранялся? Извлекаю из хранилища и открываю во временных файлах. А как сразу из хранилища и с сохранением? Спасибо.
 
 
   catena
 
1 - 02.02.18 - 08:39
Пишешь код извлечения.
Пишешь код сохранения.
   Рэйв
 
2 - 02.02.18 - 08:45
(0)Код хоть покажи, искатель телепатов.
   DenisVich
 
3 - 02.02.18 - 10:53
вот мой код "Процедура ПосмотретьФайл(ТекущийЭлемент)
    //Объявление, инициализация переменных. +

    Перем ФайлОбъект, СтрокаКаталогВременныхФайлов;
    Перем ПеременнаяПодстановки;

    //Объявление, инициализация переменных. -


    СтрокаКаталогВременныхФайлов = КаталогВременныхФайлов() + "FilesCTO";
    ФайлОбъект = Новый Файл(СтрокаКаталогВременныхФайлов);
    Если Не ФайлОбъект.Существует() Или Не ФайлОбъект.ЭтоКаталог() Тогда
        СоздатьКаталог(СтрокаКаталогВременныхФайлов);
    КонецЕсли;

    ПеременнаяПодстановки = ТекущийЭлемент;
    Если Не ПеременнаяПодстановки = Неопределено Тогда
        //РегистрСведенийНаборЗаписейОбъект = РегистрыСведений.ХранилищеФайлов.СоздатьНаборЗаписей();

        //РегистрСведенийНаборЗаписейОбъект.Отбор.ОбъектБД.Установить(ПеременнаяПодстановки.ОбъектБД, Истина);

        //РегистрСведенийНаборЗаписейОбъект.Отбор.ВидДокумента.Установить(ПеременнаяПодстановки.ВидДокумента, Истина);

        //РегистрСведенийНаборЗаписейОбъект.Отбор.НомерСтраницы.Установить(ПеременнаяПодстановки.НомерСтраницы, Истина);

        //РегистрСведенийНаборЗаписейОбъект.Отбор.ОписаниеФайла.Установить(ПеременнаяПодстановки.ОписаниеФайла, Истина);

        //РегистрСведенийНаборЗаписейОбъект.Прочитать();


//        РегистрСведенийЗаписьОбъект = РегистрСведенийНаборЗаписейОбъект[0];


        ПеременнаяПодстановки = СтрокаКаталогВременныхФайлов + "\" + ТекущийЭлемент.Название//.ИмяФайла + "." + РегистрСведенийЗаписьОбъект.РасширениеФайла;


        Если ТекущийЭлемент.ДанныеДокумента.Получить() = Неопределено Тогда
            Предупреждение("Присоединенный файл отсутствует!");
        Иначе
            ТекущийЭлемент.ДанныеДокумента.Получить().Записать(ПеременнаяПодстановки);

            ФайлОбъект = Новый Файл(ПеременнаяПодстановки);
            Если ФайлОбъект.Существует() Тогда
                ЗапуститьПриложение(ПеременнаяПодстановки);
            Иначе
                Предупреждение("Не удалось открыть файл для просмотра!");
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры//ПосмотретьФайл

"
   МимохожийОднако
 
4 - 02.02.18 - 11:03
где здесь работа с хранилищем?
   DenisVich
 
5 - 02.02.18 - 13:24
Я беру из хранлища - ТекущийЭлемент.ДанныеДокумента
   nordbox
 
6 - 02.02.18 - 13:36
ты его из каталога берешь, а не из хранилища
   DenisVich
 
7 - 02.02.18 - 13:49
Записывается файл во временный из хранилища. Потом он открывается из временного файла.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует